30选5玩法|福彩30选5开奖结果321|
 

标签:qos

Cisco思科交换机QOS限速配置实例

No Comments CISCO

每个接口每个方向只支持一个策略;一个策略可以用于多个接口。

因此所有PC的?#30053;?#36895;?#23454;?#38480;制都应该定义在同一个策略

(在本例子当中为policy-map user-down),而PC不同速?#23454;那?#20998;是在Class-map分别定义。

1、在交换机上启动QOS

Switch(config)#mls qos //在交换机上启动QOS

2、分别定义PC1(10.10.1.1)和PC2(10.10.2.1)访问控制列表

Switch(config)#access-list 10 permit 10.10.1.0 0.0.0.255 //控制pc1上行流量 Switch(config)#access-list 100 permit any 10.10.1.0 0.0.0.255 //控制pc1下行流量 Switch(config)#access-list 11 permit 10.10.2.0 0.0.0.255 //控制pc2上行流量 Switch(config)#access-list 111 permit any 10.10.2.0 0.0.0.255 //控制pc2下行流量

class-map mach-all {name}

match access-group 110

policy-map

class

二、详细配置过程

注:每个接口每个方向只支持一个策略;一个策略可以用于多个接口。因此所有PC的?#30053;?#36895;?#23454;?#38480;制都应该定义在同一个策略(在本例子当中

为policy-map user-down),而PC不同速?#23454;那?#20998;是在Class-map分别定义。

1、在交换机上启动QOS

Switch(config)#mls qos //在交换机上启动QOS

2、分别定义PC1(10.10.1.1)和PC2(10.10.2.1)访问控制列表

Switch(config)#access-list 10 permit 10.10.1.0 0.0.0.255 //控制pc1上行流量

Switch(config)#access-list 100 permit any 10.10.1.0 0.0.0.255 //控制pc1下行流量

Switch(config)#access-list 11 permit 10.10.2.0 0.0.0.255 //控制pc2上行流量

Switch(config)#access-list 111 permit any 10.10.2.0 0.0.0.255 //控制pc2下行流量

3、定义类,并和上面定义的访问控制列表绑定

Switch(config)# class-map user1-up //定义PC1上行的类,并绑定访问列表10

Switch(config-cmap)# match access-group 10

Switch(config-cmap)# exit

Switch(config)# class-map user2-up

Switch(config-cmap)# match access-group 11 //定义PC2上行的类,并绑定访问列表10

Switch(config-cmap)# exit

Switch(config)# class-map user1-down

------中间广告---------

Switch(config-cmap)# match access-group 100 //定义PC1下行的类,并绑定访问列表100

Switch(config-cmap)# exit

Switch(config)# class-map user2-down

Switch(config-cmap)# match access-group 111 //定义PC2下行的类,并绑定访问列表111

Switch(config-cmap)# exit

4、定义策略,把上面定义的类绑定到该策略

Switch(config)# policy-map user1-up //定义PC1上行的速率为1M

Switch(config-pmap)# class user1-up

Switch(config-pmap-c)# trust dscp

Switch(config-pmap-c)# police 1024000 1024000 exceed-action drop

Switch(config)# policy-map user2-up //定义PC2上行的速率为2M

Switch(config-pmap)# class user2-up

Switch(config-pmap-c)# trust dscp

Switch(config-pmap-c)# police 2048000 1024000 exceed-action drop

Switch(config)# policy-map user-down

Switch(config-pmap)# class user1-down

Switch(config-pmap-c)# trust dscp

Switch(config-pmap-c)# police 1024000 1024000 exceed-action drop

Switch(config-pmap-c)# exit

Switch(config-pmap)# class user2-down

Switch(config-pmap-c)# trust dscp

Switch(config-pmap-c)# police 2048000 1024000 exceed-action drop

Switch(config-pmap-c)# exit

5、在接口上运用策略

Switch(config)# interface f0/1

Switch(config-if)# service-policy input user1-up

Switch(config)# interface f0/2

Switch(config-if)# service-policy input user2-up

Switch(config)# interface g0/1

Switch(config-if)# service-policy input user-down

队列和拥塞 配置指南

No Comments CISCO ,

Fast Switching和CEF
提问 给路由器配置最有效的包交换算法
回答
Fast Switching缺省是启用的
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface FastEthernet0/0
Router(config-if)#ip route-cache
Router(config-if)#exit
Router(config)#end
Router#
如果使用策略,需要下面的命令
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface FastEthernet0/0
Router(config-if)#ip route-cache policy
Router(config-if)#exit
Router(config)#end
Router#
CEF缺省是没有启用的,全局和端口启用
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#ip cef
Router(config)#interface FastEthernet0/0
Router(config-if)#ip route-cache cef
Router(config-if)#exit
Router(config)#end
Router#
注释 除了上面的policy?#38382;?#20197;外,还有下面的?#38382;?#26469;保证进出是同一物理接口
Router(config)#interface Serial0/0
Router(config-if)#ip route-cache same-interface
可以使用下面命令进行验证show cef interface show cef drop 和 show cef not-cef-switched show ip cef
11.2.  设置DSCP 或者TOS位
提问 路由器标记特定数据包的DSCP或者TOS位
回答
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#access-list 101 permit any eq ftp any
Router(config)#access-list 101 permit any any eq ftp
Router(config)#access-list 102 permit any eq ftp-data any
Router(config)#access-list 102 permit any any eq ftp-data
Router(config)#class-map match-all ser00-ftpcontrol
Router(config-cmap)#description branch ftp control traffic
Router(config-cmap)#match input-interface serial0/0
Router(config-cmap)#match access-group 101
Router(config-cmap)#exit
Router(config)#class-map match-all ser00-ftpdata
Router(config-cmap)#description branch ftp data traffic
Router(config-cmap)#match input-interface serial0/0
Router(config-cmap)#match access-group 102
Router(config-cmap)#exit
Router(config)#policy-map serialftppolicy
Router(config-pmap)#description branch ftp traffic policy
Router(config-pmap)#class ser00-ftpcontrol
Router(config-pmap-c)#set ip precedence immediate
Router(config-pmap-c)#exit
Router(config-pmap)#class ser00-ftpdata
Router(config-pmap-c)#set ip precedence priority
Router(config-pmap-c)#exit
Router(config-pmap)#exit
Router(config)#interface serial0/0
Router(config-if)#ip route-cache policy
Router(config-if)#service-policy input serialftppolicy
Router(config-if)#exit
Router(config)#end
Router#
注释 先使用classmap来定义特殊的数据流,然后使用policymap来对TOS位进行标记
11.3.  使用优先级队列(Priority Queuing)
提问 使用优先级队列这种?#32454;?#30340;方式来保证高优先级的数据?#32570;?#22788;理
回答
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#access-list 101 permit ip any any precedence 5 tos 12
Router(config)#access-list 102 permit ip any any precedence 4
Router(config)#access-list 103 permit ip any any precedence 3
Router(config)#priority-list 1 protocol ip high list 101
Router(config)#priority-list 1 protocol ip medium list 102
Router(config)#priority-list 1 protocol ip normal list 103
Router(config)#priority-list 1 default low
Router(config)#interface Ethernet0
Router(config-if)#priority-group 1
Router(config-if)#exit
Router(config)#end
Router#
注释 单纯使用优先级队列可能会导致高优先级的数据占用掉所有的带宽。precedence 5 tos 12 等同于dscp ef。缺省情况下会被不匹配的数据包归入到normal优先级队列,本例中特别配置其归入了low优先级队?#23567;how interface命令可以看到缺省各个队列大小(high优先级为20个,medium为40个,?#26469;?#36882;增)
Output queue (queue priority: size/max/drops):
     high: 0/20/0, medium: 0/40/0, normal 0/60/0, low 0/80/0
可以使用Router(config)#priority-list 1 queue-limit 10 15 25 35 命令来修改。建议使用LLQ或者CBWFQ来替代单纯的优先级队列
11.4.  使用自定义队列(Custom Queuing)
提问 根据数据流中IP优先级的不同来自定义队列共享带宽
回答
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#access-list 103 permit ip any any precedence 5
Router(config)#access-list 104 permit ip any any precedence 4
Router(config)#access-list 105 permit ip any any precedence 3
Router(config)#access-list 106 permit ip any any precedence 2
Router(config)#access-list 107 permit ip any any precedence 1
Router(config)#queue-list 1 protocol ip 3 list 103
Router(config)#queue-list 1 protocol ip 4 list 104
Router(config)#queue-list 1 protocol ip 5 list 105
Router(config)#queue-list 1 queue 5 byte-count 3000 limit 55
Router(config)#queue-list 1 protocol ip 6 list 106
Router(config)#queue-list 1 protocol ip 7 list 107
Router(config)#queue-list 1 default 8
Router(config)#interface HSSI0/0
Router(config-if)#custom-queue-list 1
Router(config-if)#exit
Router(config)#end
Router#
注释 通过配置自定义队列可以生成16个应用队列和1个系统队?#23567;?
Queuing strategy: custom-list 1
  Output queues: (queue #: size/max/drops)
     0: 0/20/0 1: 0/20/0 2: 0/20/0 3: 0/20/0 4: 0/20/0
     5: 0/55/3 6: 5/20/0 7: 0/20/0 8: 0/20/0 9: 0/20/0
     10: 0/20/0 11: 0/20/0 12: 0/20/0 13: 0/20/0 14: 0/20/0
     15: 0/20/0 16: 0/20/0

缺省情况下自定义队列?#25442;?#23545;无分类的数据流进行队列归属,所以需要配置一个缺省队?#23567;?#32570;省情况下每个队列会读取1500字节,每个队列可最多保存20个数据包,可以通过queue-list 1 queue 5 byte-count 3000 limit 55 命令来修改。
对于这种队列方式需要注意的是队列是基于字节的不是基于数据包的,所以对于字节下的数据流会发送相对多的数据包,但是总体?#27492;?#27969;量是平均的。此种方式也是比较老的方案,推荐使用CBWFQ
11.5.  自定义队列混和优先级队列
提问 高优先级数据优先处理,低优先级数据共享带宽
回答
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#access-list 101 permit ip any any precedence 7
Router(config)#access-list 102 permit ip any any precedence 6
Router(config)#access-list 103 permit ip any any precedence 5
Router(config)#access-list 104 permit ip any any precedence 4
Router(config)#access-list 105 permit ip any any precedence 3
Router(config)#access-list 106 permit ip any any precedence 2
Router(config)#access-list 107 permit ip any any precedence 1
Router(config)#queue-list 1 protocol ip 1 list 101
Router(config)#queue-list 1 protocol ip 2 list 102
Router(config)#queue-list 1 protocol ip 3 list 103
Router(config)#queue-list 1 protocol ip 4 list 104
Router(config)#queue-list 1 protocol ip 5 list 105
Router(config)#queue-list 1 protocol ip 6 list 106
Router(config)#queue-list 1 protocol ip 7 list 107
Router(config)#queue-list 1 lowest-custom 4
Router(config)#interface HSSI0/0
Router(config-if)#custom-queue-list 1
Router(config-if)#exit
Router(config)#end
Router#
注释 相比11.4多了一个queue-list 1 lowest-custom 4 ,这样123.被定义为优先级队列
11.6.  使用加权公平队列(Weighted Fair Queuing)
提问 根据TOS/DSCP位来转发数据包
回答
缺省情况下WFQ会自动在小于2M速?#23454;?#25509;口启用
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface Serial0/0
Router(config-if)#fair-queue 64 512 10
Router(config-if)#exit
Router(config)#end
Router#
注释 WFQ在没有TOS/DSCP标记?#37027;?#20917;下依然可以工作。命令后面的?#38382;?#20998;为三个,第一个为丢弃阀值,某个队列如果超过64个数据包,以后的数据包就会被丢弃,第二个为动态队列数目,是16的倍数,如果端口有很多的数据流建议增加,第三个为RSVP预留队列,缺省为0。
11.7.  使用基于类的加权公平队列(Using Class-Based Weighted Fair Queuing)
提问 在端口上配置基于类的加权公平队列
回答
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#class-map highprec
Router(config-cmap)#description Highest priority Prec=5
Router(config-cmap)#match ip precedence 5
Router(config-cmap)#exit
Router(config)#class-map medhiprec
Router(config-cmap)#description Medium-high priority Prec=4
Router(config-cmap)#match ip precedence 4
Router(config-cmap)#exit
Router(config)#class-map medloprec
Router(config-cmap)#description Medium-low priority Prec=2,3
Router(config-cmap)#match ip precedence 2 3
Router(config-cmap)#exit
Router(config)#policy-map cbwfqpolicy
Router(config-pmap)#class highprec
Router(config-pmap-c)#bandwidth percent 25
Router(config-pmap-c)#exit
Router(config-pmap)#class medhiprec
Router(config-pmap-c)#bandwidth percent 25
Router(config-pmap-c)#exit
Router(config-pmap)#class medloprec
Router(config-pmap-c)#bandwidth percent 25
Router(config-pmap-c)#exit
Router(config-pmap)#class class-default
Router(config-pmap-c)#fair-queue 512
Router(config-pmap-c)#queue-limit 96
Router(config-pmap-c)#exit
Router(config-pmap)#exit
Router(config)#interface serial0/1
Router(config-if)#service-policy output cbwfqpolicy
Router(config-if)#exit
Router(config)#end
Router#
注释
11.8.  使用NBAR
提问 使用NBAR(Network Based Application Recognition)在应用层对数据进行识别和分类
回答
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#ip cef
Router1(config)#class-map INTERACTIVE
Router1(config-cmap)#match protocol citrix
Router1(config-cmap)#match protocol telnet
Router1(config-cmap)#exit
Router1(config)#policy-map QoSPolicy
Router1(config-pmap)#class INTERACTIVE
Router1(config-pmap-c)#bandwidth percent 50
Router1(config-pmap-c)#set dscp ef
Router1(config-pmap-c)#exit
Router1(config-pmap)#class class-default
Router1(config-pmap-c)#bandwidth percent 20
Router1(config-pmap-c)#random-detect dscp-based
Router1(config-pmap-c)#exit
Router1(config-pmap)#exit
Router1(config)#interface FastEthernet0/0
Router1(config-fi)#service-policy inbound QoSPolicy
Router1(config-if)#exit
Router1(config)#end
Router1#
思科支持在网上?#30053;豍DLM(Packet Description Language Module)来激活NBAR分类
Router1#show flash
System flash directory:
File  Length   Name/status
  1   23169076  c2600-ipvoice-mz.124-10.bin
  2   3100     bittorrent.pdlm
[23172304 bytes used, 9857836 available, 33030140 total]
32768K bytes of processor board System flash (Read/Write)
Router1#Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#ip nbar pdlm flash://bittorrent.pdlm
Router1(config)#class-map BITTORRENT
Router1(config-cmap)#match protocol bittorrent
Router1(config-cmap)#exit
Router1(config)#end
Router1#

也可以使用NBAR来自动对网络协议进行分类统计
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#interface FastEthernet0/0
Router1(config-if)#ip nbar protocol-discovery
Router1(config-if)#exit
Router1(config)#end
Router1#
注释 NBAR会增加CPU利用率。Router1#show ip nbar protocol-discovery top-n 5 可以显示出NBAR所识别各个协议数据统计
<!–[if !supportLists]–>11.9.       <!–[endif]–>使用WRED来控制拥塞
提问
回答
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#class-map Prec5
Router(config-cmap)#description Critical
Router(config-cmap)#match ip precedence 5
Router(config-cmap)#exit
Router(config)#policy-map cb_wred
Router(config-pmap)#class Prec5
Router(config-pmap-c)#random-detect dscp-based
Router(config-pmap-c)#exit
Router(config-pmap)#class class-default
Router(config-pmap-c)#fair-queue 512
Router(config-pmap-c)#queue-limit 96
Router(config-pmap-c)#random-detect dscp-based
Router(config-pmap-c)#exit
Router(config-pmap)#exit
Router(config)#interface HSSI0/1
Router(config-if)#service-policy output cb_wred
Router(config-if)#exit
Router(config)#end
Router#
注释
11.10.  使用RSVP
提问 在网络中启用RSVP
回答
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#access-list 15 permit ip 192.168.1.0 0.0.0.255
Router(config)#interface FastEthernet0/0
Router(config-if)#ip rsvp bandwidth 128 56
Router(config-if)#ip rsvp neighbor 15
Router(config-if)#exit
Router(config)#end
Router#
注释 配置RSVP之前,接口要配置WFQ, CBWFQ, 或者WRED
11.11.  Manual RSVP Reservations
提问
回答
Sender主机(192.168.100.202)连接R1
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#interface FastEthernet0/0
Router1(config-if)#ip address 192.168.100.21 255.255.255.0
Router1(config-if)#ip rsvp bandwidth 128 56
Router1(config-if)#exit
Router1(config)#interface Serial0/0
Router1(config-if)#no ip address
Router1(config-if)#encapsulation frame-relay
Router1(config-if)#fair-queue 64 256 37
Router1(config-if)#ip rsvp bandwidth
Router1(config-if)#exit
Router1(config)#interface Serial0/0.1 point-to-point
Router1(config-subif)#ip address 192.168.55.9 255.255.255.252
Router1(config-subif)#frame-relay interface-dlci 904
Router1(config-fr-dlci)#ip rsvp bandwidth 128 56
Router1(config-subif)#exit
Router1(config)#ip rsvp sender 192.168.9.100 192.168.100.202 UDP 1300 1300 192.168.100.202 FastEthernet0/0 55 1
Router1(config)#end
Router1#
Receiver主机(192.168.9.100)连接R4
Router4# configure terminal
Router4(config)#interface Ethernet0/0
Router4(config-if)#ip address 192.168.9.3 255.255.255.0
Router4(config-if)#ip rsvp bandwidth 128 56
Router4(config-if)#exit
Router4(config)#interface Serial0/0
Router4(config-if)#no ip address
Router4(config-if)#encapsulation frame-relay
Router4(config-if)#fair-queue 64 256 37
Router4(config-if)#ip rsvp bandwidth
Router4(config-if)#exit
Router4(config)#interface Serial0/0.1 point-to-point
Router4(config-subif)#ip address 192.168.56.5 255.255.255.252
Router4(config-subif)#frame-relay interface-dlci 107
Router4(config-fr-dlci)#ip rsvp bandwidth 128 56
Router4(config-subif)#exit
Router4(config)#ip rsvp reservation 192.168.9.100 192.168.100.202 UDP 1300 1300 192.168.9.100 Ethernet0/0 FF RATE 55 1
Router4(config)#end
Router4#
注释
11.12.  聚合RSVP的预留(Aggregating RSVP Reservations)
提问 聚合多个RSVP这样核心网络不需要对每个数据流进行追踪
回答
Router2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router2(config)#interface FastEthernet0/0
Router2(config-if)#ip address 192.168.101.1 255.255.255.0
Router2(config-if)#ip rsvp bandwidth 128 56
Router2(config-if)#ip rsvp data-packet classification none
Router2(config-if)#ip rsvp resource-provider none
Router2(config-if)#exit
Router2(config)#interface Serial0/0.1 point-to-point
Router2(config-subif)#ip address 192.168.55.10 255.255.255.252
Router2(config-subif)#frame-relay interface-dlci 409
Router2(config-fr-dlci)#ip rsvp bandwidth 128 56
Router2(config-subif)#ip rsvp data-packet classification none
Router2(config-subif)#ip rsvp resource-provider none
Router2(config-subif)#exit
Router2(config)#end
Router2#
注释 RSVP扩展性不强,对于核心网络?#25925;?#20351;用传统的DSCP标记方式,12.2(2)T的IOS引入了新的办法来解决此问题,核心路由器配置RSVP来支持RSVP Requests,但是队列的时候不需要使用RSVP的信息
11.13.  Using Generic Traffic Shaping
提问
回答
注释
11.14.  Using Frame-Relay Traffic Shaping
提问
回答
注释
11.15. Using Committed Access Rate
提问
回答
注释
11.16.  部署基于标准的PHB(Per-Hop Behavior)
提问 配置基于规范的根据DSCP位的PHB
回答
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#class-map EF
Router(config-cmap)#description Real-time application traffic
Router(config-cmap)#match ip precedence 5
Router(config-cmap)#exit
Router(config)#class-map AF1x
Router(config-cmap)#description Priority Class 1
Router(config-cmap)#match ip precedence 1
Router(config-cmap)#exit
Router(config)#class-map AF2x
Router(config-cmap)#description Priority Class 2
Router(config-cmap)#match ip precedence 2
Router(config-cmap)#exit
Router(config)#class-map AF3x
Router(config-cmap)#description Priority Class 3
Router(config-cmap)#match ip precedence 3
Router(config-cmap)#exit
Router(config)#class-map AF4x
Router(config-cmap)#description Priority Class 4
Router(config-cmap)#match ip precedence 4
Router(config-cmap)#exit
Router(config)#policy-map cbwfq_pq
Router(config-pmap)#class EF
Router(config-pmap-c)#priority 58 800
Router(config-pmap-c)#exit
Router(config-pmap)#class AF1x
Router(config-pmap-c)#bandwidth percent 15
Router(config-pmap-c)#random-detect dscp-based
Router(config-pmap-c)#exit
Router(config-pmap)#class AF2x
Router(config-pmap-c)#bandwidth percent 15
Router(config-pmap-c)#random-detect dscp-based
Router(config-pmap-c)#exit
Router(config-pmap)#class AF3x
Router(config-pmap-c)#bandwidth percent 15
Router(config-pmap-c)#random-detect dscp-based
Router(config-pmap-c)#exit
Router(config-pmap)#class AF4x
Router(config-pmap-c)#bandwidth percent 15
Router(config-pmap-c)#random-detect dscp-based
Router(config-pmap-c)#exit
Router(config-pmap)#class class-default
Router(config-pmap-c)#fair-queue 512
Router(config-pmap-c)#queue-limit 96
Router(config-pmap-c)#exit
Router(config-pmap)#exit
Router(config)#interface HSSI0/1
Router(config-if)#service-policy output cbwfqpolicy
Router(config-if)#exit
Router(config)#end
Router#
注释
11.17.  AutoQoS
提问 配置路由器自动生成Voip或者一般数据包的QoS策略配置
回答
一种是针对VoIP数据的
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#ip cef
Router1(config)#interface Serial0/0
Router1(config-if)#no ip address
Router1(config-if)#encapsulation frame-relay
Router1(config-if)#exit
Router1(config)#interface Serial0/0.1 point-to-point
Router1(config-subif)#ip address 192.168.55.9 255.255.255.252
Router1(config-subif)#frame-relay interface-dlci 904
Router1(config-fr-dlci)#auto qos voip
%Creating new map-class.
Router1(config-fr-dlci)#exit
Router1(config-subif)#exit
Router1(config)#end
Router1#
*Mar  1 01:32:55.031: %RMON-5-FALLINGTRAP: Falling trap is generated because the
value of cbQosCMDropBitRate.1169.1171 has fallen below the falling-threshold va
lue 0
Router1#
针对一般的IP数据包,第一步是流量模式的?#21344;?
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#ip cef
Router1(config)#interface Serial0/0
Router1(config-if)#no ip address
Router1(config-if)#encapsulation frame-relay
Router1(config-if)#exit
Router1(config)#interface Serial0/0.1 point-to-point
Router1(config-subif)#ip address 192.168.55.9 255.255.255.252
Router1(config-subif)#frame-relay interface-dlci 904
Router1(config-fr-dlci)#auto discovery qos
Router1(config-fr-dlci)#exit
Router1(config-subif)#exit
Router1(config)#end
Router1#
第二步?#24039;?#25104;策略
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#interface Serial0/0.1 point-to-point
Router1(config-subif)#frame-relay interface-dlci 904
Router1(config-fr-dlci)#auto qos
%Creating new map-class.
Router1(config-fr-dlci)#no auto discovery qos
Router1(config-fr-dlci)#exit
Router1(config-subif)#exit
Router1(config)#end
Router1#
注释 AutoQoS很好,但是有下面几个限制:只能针对点对点的链路,不能和frame map或者virtual templates一起使用,不能用于SVC,两端必须同时配置,必须禁止掉所有的服务策略或者access-groups即使用于其他的端口,要启用CEF。针对VoIP的AutoQoS引自12.2(15)T,通过一个宏来生成配置,可以用show auto qos来查看。针对通用IP数据流的引自12.3(7)T,自动针对数据流分类至十个不同类别,要先用auto qos然后再no掉原来的discovery。注意的是你如果后来想不用auto qos了,虽然可以no auot qos但是?#25925;?#26377;很多配置是没法自动清除的,记得要保存之前的show auto qos的输出。AutoQoS不是万能的,要慎用
查看队列?#38382;?
提问 查看当前端口的队列配置
回答
Router#show queue FastEthernet0/0
Router#show queuing
注释 配置优先级队列或者自定义队列的时候show queue命令没有相应的输出

Queue mapping

No Comments CISCO ,

map:

   cos 6 7 map to queue 1

   cos 5 4 map to queue 2

   cos 3 2 map to queue 3

   cos 1 0 map to queue 4

Mls qos

int fa0/4

   mls qos trust cos

   wrr-queue cos-map 1 6 7

   wrr-queue cos-map 2 4 5

   wrr-queue cos-map 3 2 3

   wrr-queue cos-map 4 0 1

// 3550 wrr 3560 srr

Queue 1,2,3,4 bandwidth 百分比是10%,10%,20%,60%。queue 1的weight是5 int f0/4   wrr-queue bandwidth 5 5 10 30

QoS | CAR, CIR, MIR, EIR, PIR, CDR

No Comments 网络技术

Several a day ago I posted about CIR how to calculate TC, this is list figure of rate, if there is wrong CMIIW (correct me if I wrong)
Committed Access Rate (CAR) is used to limit traffic that can enter or exit an interface.
Committed Information Rate (CIR) is minimum bandwidth that is guaranteed to work under normal conditions, at any time the bandwidth should not fall below.
Minimum Information Rate (MIR) is minimum bandwidth, the lowest information rate will be assigned where there is congestion.
Excess Information Rate (EIR) is burstable bandwidth, CIR plus excess burst rate.
Peak Information Rate (PIR) is bandwidth will may use during data bursts when there is excess bandwidth available and no congestion also mention maximum information rate (MaxIR/MIR).
Committed Data Rate (CDR) refers also to voice and non-data packets and not only to data packets as in CDR.
All rate figure in kilobits per second (kbit/s).

QoS学习笔记

No Comments 网络技术 ,

marking:
1.定义class-map.
class-map [match-all/match-any] {map-name}
默认不打的话是match-all
2.定义匹配命令match
match access-group {NO}
match input-interface {interface}
match class-map {map-name} class-map嵌套
match source-address {mac-address} 源mac地址
match destination-address {mac-address} 目的mac地址
match vlan {vlan-ID}
match ip dscp {DSCP}
match ip precedencc {precedence}
match protocol {protocol} 基于NBAR
Router(config) class-map FOO
Router(config-cmap)#match ?
access-group Access group
any Any packets
class-map Class map
cos IEEE 802.1Q/ISL class of service/user priority values
destination-address Destination address
input-interface Select an input interface to match
ip IP specific values
mpls Multi Protocol Label Switching specific values
not Negate this match result
protocol Protocol
qos-group Qos-group
source-address Source address
3.设置policy-map
policy-map {policy-name}
4.调用class-map
class-map {map-name}
5.设置标记
set ip dscp {DSCP}
set ip precedence {PRECEDENCE}
set cos {COS}
priority {Kbps|percent PERCENT} [bc] 定义优先级流量的带宽以及突发流量
bandwidth {Kbps|percent PERCENT} 定义保留带宽
random-detect 启用WRED
police {CIR BC BE} conform-action {action} exceed-action {action} [violated-action {action}] 使用令牌桶限速
queue-limit {PACKETS} 定义队列中数据报的最大个数
service-policy {policy-name} 调用其它的策略进行嵌套
shape {average|peak} {CIR [BC] [BE]} 整形
drop
6.在接口模式下调用policy-map
service-policy [input|ouput] {POLICY-NAME}
察看命令:
show policy-map [policy-name]
show policy-map interface [INTERFACE]
show class-map [class-name]
show ip nbar pdlm
show ip nbar port-map 显示NBAR使用的协议到端口的?#25104;?br /> NBAR应用:
使用限制:
1.快速以太网信道
2.隧道接口或?#29992;?#30340;接口
3.SVI(交换虚拟接口)
4.拨号接口
5.多链路PPP(MLP)
使用前先要敲命令:ip cef
class-map {name}
match protocol …
ip nbar pdlm flash://bittorrent.pdlm 加载bittorrent.pdlm 到路由器闪存里(事先要把pdlm复制到flash中)
match procotol http url “*.jpeg|*.jpg” (匹配url中带有jpeg和jpg的连接)
match procotol http url “*.gif” (匹配url中有gif的连接)
拥塞管理
WFQ:
特点:
1.基于流(5元素)分类,队列数N可以配置
2.出队后按IP优先级来分配带宽,优先?#23545;?#20302;则带宽越小
3.在其它队列?#38556;?#26102;抢占它们的带宽,又有流量时归还带宽
4.是低于2.048Mbps串行接口的默认配置
配置命令:
接口模式下fair-queue
show queueing fair
show queue [interface]
PQ:
缺点:1.只能静态配置,不能适应网络拓扑的变化2.不支持隧道接口3.要通过数据分类卡,比FIFO慢
配置:
1.定义优先级队列,可以基于协议和基于进站接口
基于协议riority-list {list-number} protocol {PROTOCOL-NAME} {high|medium|normal|low}
基于进站接口riority-list {list-number} interface {interface} {high|medium|normal|low}
2.定义默认优先级队列,未被分类的数据报被送到此处,默认级别为normal
priority-list {list-number} default {high|medium|normal|low}
3.定义每个队列中数据报的个数,从高到低,默认为20,40,60,80
priority-list {list-number} queue-limit {high-limit medium-limit normal-limit low-limit}
4.把优先级队列运用在接口上
priority-group {list-number}
察看命令:
show queue [interface]
show queueing priority
RTP(Real Time Protocol)
支持端口号为偶数的udp报文
可以进行限速,超过的可丢弃,也可以配置带宽,?#25442;?#21344;用超出规定的带宽
命令:
ip rtp priority {starting-rtp-port-number port-number-range} {bandwidth}
max-reserved-bandwidth PERCENT
show queue [interface]
debug priority
CRTP(压缩实时协议): 用来压缩ip/udp/rtp报头
压缩分为三种:链路压缩,有效负载压缩,报头压缩
二层报头–tcp/ip报头–有效负载
1.链路压缩:对整个分组进行压缩,包括报头和有效负载。独立于协议的。只适用于点到点链路。两种算法:Predictor和STAC
2.有效负载压缩:只压缩数据部分,对报?#35775;?#26377;影响。适用于frame-relay或ATM网络。
3.tcp/ip报头压缩:针对协议的,适用于几个字节数据的小型分组。
配置:
对HDLC,LAPB: compress [predictor|stac|mppc]
对ppp: ip compress [predictor|stac]
对frame-relay点到点接口或子接口启用stac压缩: frame-relay payload-compress
启用crtp:
1. ip rtp header-compression [passive]
若不启用passive,则?#36816;?#26377;RTP数据流压缩;若启用passive,则只有当进入端口的RTP分组被压缩?#20445;?#36719;件才能对离开该接口的RTP分组压缩
2. ip rtp compression-connections {NUMBER}
更改CRTP压缩的条数,默认为16条
3. 启用tcp报头压缩: ip tcp header-compression [passive] 若没有启用passive, 则必须指定关键字active,将?#36816;?#26377;IP/UDP/RTP包?#26041;?#34892;压缩
ip tcp compression-connections {NUMBER}
frame-relay中的 crtp:
在物理接口上启用CRTP,则在它的子接口上将继承特性
frame-relay ip rtp header-compression [passive]
frame-relay ip rtp compression-connections {NUMBER}
只针对特定的PVC启用CRTP:
frame-relay map ip {ip-address} {dlci} [broadcast] rtp header-compression [active|passive] [connections number]
察看命令:
show ip rtp header-compression [interface] [detail]
show frame-relay ip rtp header-compression [interface]
WRR(weighted round-robin)
一种队列调度机制,根据每个出站队列的权值来分配带宽,权值与带宽成正?#21462;?br /> 仅当发生拥塞时才会使用WRR,不拥塞时?#25442;?#20998;配带宽。
步骤:
1.全?#21046;?#29992;mls qos
2.进入接口模式
3.通过COS将数据报分配到不同的队列中去。
wrr-queue cos-map QUEUE-ID THROSHOLD COS1… COSn 它用于配置cos?#26723;?#20986;站队列的?#25104;?#20851;系。
对队列进行编号?#20445;拥?#20248;先级开始,到?#32454;?#20248;先级结束。
配置?#32454;?#20248;先级队列:wrr-queue priority-queue
4.配置WRR队列的权重
wrr-queue bandwidth WEIGHT1 WEIGHT2 WEIGHT3 WEIGHT4
计算每个队列的方法是:
example:wrr-queue bandwith 1 2 3 4
则带宽: 队列1:权重1/总权重=1/10
5.定义传输队列长度的比例,取值为1-100%
wrr-queue queue-limit LOW-PRIORITY-QUEUE-WEIGHT MEDIUM-PRIORITY-QUEUE-WEIGHTS HIGH-PRIORITY-QUEUE-WEIGHTS
高优先级队列因为延时小,数据量小,所以不需要太大的缓存区。往往将大部?#21482;?#20914;区用于低优先级队?#23567;?br /> 拥塞避免
1.尾丢弃
?#36816;?#26377;通信流平等对待,将导致TCP全局同步
wrr-queue threshold QUEUE-ID THR1% 100% THR1%是开?#32423;?#24323;通信流时输出队列的填满程度,后面一个是100%是尾丢弃
2.WRED
WRED与RED?#37027;?#21035;在于前者引入IP优先权DSCP值来区别丢弃策略,可以为不同IP优先级DSCP设定不同的队列长?#21462;?#38431;列阈值、丢弃概率。并且RED只对TCP流量有用
通过对队列数据流传输速度的平均?#23548;?#31639;来决定是否丢弃,防止了对突发流量的不公平待遇。
WRED和LLQ矛盾
WRED往往和WRR一起使用。
WRED可以在接口上进行配置,也可以在policy上进行配置,可以针对于precedence进行RED,也可以针对于DSCP?#21040;?#34892;RED,当然,两者之间只能选择一个。
(1)基于DSCP
random-detect dscp-based
random-detect dscp {DSCP} {min max mark}
(2)基于ip precedence
random-detect
random-detect precedence {PRECEDENCE} {min max mark}
WRED与WRR连用:
wrr-queue random-detect min-throshold QUEUE-ID THR1% [THR2% [THR3% …]]
wrr-queue random-detect max-throshold QUEUE-ID THR1% [THR2% [THR3% …]]
min-throshold表示开?#32423;?#24323;某些数据包时的最大填满程度
max-throshold表示丢弃所有数据包时的最大填满程度
example:
int G1/1
wrr-queue bandwidth 50 75
wrr-queue queue-limit 100 50
wrr-queue random-detect min-throshold 1 50 70
wrr-queue random-detect max-throshold 1 75 100
wrr-queue cos-map 1 1 0 2
wrr-queue cos-map 1 2 3
wrr-queue cos-map 2 1 4
wrr-queue cos-map 2 2 6
priority-queue cos-map 1 1 5 7
rcv-queue cos-map 1 1 0
switchport
解释:共有两个队?#23567;?#24403;队列1的填满程度达到50%和70%?#20445;?#20132;换机分别对?#25104;?#21040;闸值1和闸值2的数据包进行WRED(?#32431;级?#24323;),当队列1的填满程度达到75%和100%?#20445;?#20132;换机分别对?#25104;?#21040;闸值1和闸值2的数据包全部丢弃。注意:队列2没有采取WRED。
基于流的WRED(WRED和WFQ结合起来使用)
小的流丢弃的概率小,大的流丢弃的概率大,保护小的流。
命令:
1.启用基于流的WRED。
random-detect flow
2.设置平均深度因素(average depth factor)的值,值必须为2的幂,默?#29616;?#20026;4.可选:
random-detect flow average-depth-factor {scaling-factor} 这个?#38382;?#26159;改变一个乘法的比例因数.从而改变队列的大小,其实就是改变队列的长?#21462;?br /> 3.设置基于流的WRED 的数据流数目,默?#29616;?#20026;256
random-detect flow count {number}
流量策略
qos的流程:1.基于流或基于类的分类;2.结合令牌桶进行policing或shaping(CAR或GTS);3.拥塞避免(尾丢弃或WRED);4.拥塞管理(各种队列机制);5.出队。
标记在什么地方进行??(标记可以在进行CAR的时候进行,CAR也可以进行重新标记)
CAR(Committed Access Rate)
CAR通过使用令牌桶TC来进行流量控制。分类后,不需要流控的流量直接继续发送,而需要进行流控的流量就要经过令牌桶。只有当令牌桶中有令牌?#20445;?#30456;应的流量才能通过。若没有足够的令牌,要么流量被直接丢弃(policing),要么缓存起来(shaping),等有了足够的令牌后再发送出去。
CAR还可以用来做mark或remark(即可以用来设置ip优先级或重新设置ip优先级)
CAR可以为不同类别的报文设置不同的流量特性和标记特性,即可以对每个类进行CAR。CAR的策略还可以串联处理,比如先对总的流量进行一次限速,然后再对各个类进行小范围的限速。
CAR一般用在网络边界路由器上。可以在一个接口上设置多个CAR策略,数据包?#26469;?#21644;多个CAR策略匹配,若没有匹配的,则默认操作时转发数据包。
CAR的使用有以下限制:1.只能对IP流量限速;2.不支持fast EtherChannel;3.不支持隧道接口;4.不支持ISDN PRI接口。
命令:
rate-limit {output|input} {CIR BC BE} conform-action {action} exceed-action {action}
注意:CIR单位是bit/s;而BC和BE的单位是byte/s。
conform-action的条件是指当要发的数据小于正常突发(bc)的时候。exceed-action是指要发的数据大于普通突发,小于最大突发(be)的时候。
action的选项共有如下这些:
continue 继续执行下一条CAR语句
drop 丢弃数据包
tranmsit 转发数据包
set-prec-continue {precedence} 设置IP优先级并继续执行下一条CAR语句
set-prec-transmit {precedence} 设置IP优先级并转发数据包
set-dscp-continue {dscp} 设置dscp值并继续执行下一条CAR语句
set-dscp-transmit {dscp} 设置dscp值并转发数据包
上面都是只能基于整个接口的流量进行CAR,下面的可以分别针对某个流量或ip precedence或dscp值或MAC地?#26041;?#34892;CAR
扩展的配置
1.针对dscp?#21040;?#34892;CAR
rate-limit {output|input} [dscp DSCP] {CAR BC BE} conform-action {action} exceed-action {action}
2.针对ACL进行CAR
rate-limit {output|input} access-group {ACL NUM} {CAR BC BE} conform-action {action} exceed-action {action}
3.针对限速ACL进行CAR
rate-limit {output|input} access-group rate-limit {ACL NUM} {CAR BC BE} conform-action {action} exceed-action {action}
限速ACL只是一种调用关系:access-list rate-limit {ACL NUM} {precedence|mac-address} 可以匹配优先级,也可以匹配MAC地址
察看命令:
1.查看限速ACL:show access-lists rate-limit [ACL]
2.查看接口的限速信息:show interfaces [interface] rate-limit
policy map中CAR操作
police {CIR BC BE} conform-action {action} exceed-action {acion} violated-action {acion}
action的选项同上。
流量整形(shaping)
通常通过缓冲区和令牌桶来完成,当报文的发送速度过快?#20445;?#39318;先在缓冲区进行缓存,在令牌桶的控制?#30053;?#22343;匀地发送这些?#25442;?#20914;的报文。
采用的技术为GTS(通用流量整形)。
GTS与CAR的主要区别在于:利用CAR进行报文流量控制时对不符合流量特性的报文进行丢弃,而GTS对于不符合流量特性的报文则是进行缓冲,减少了报文的丢弃,同时满足报文的流量特性。
若报文不需要进行GTS,则不经过令牌桶的处理直接发送。
当因为缺乏足够的令牌而采用GTS后,GTS按一定的周期从队列中取出报文进行发送。每次发送都会与令牌桶中的令牌数作比较。直到令牌桶中的令牌数减少到队列中的报文不能再发送或是队列中的报文全部发送完毕为止。
一般在路由器的出口进行shaping,入口进行policing。
命令:
1.基本的GTS:traffic-shape rate {CIR BC BE}
2.基于ACL的GTS: traffic-shape group {ACL} {CIR BC BE}
察看:
1.查看GTS 的配置信息:show traffic-shape [interface]
2.查看GTS 的统计信息:show traffic-shape statistics [interface]
GTS在Frame Relay上的实现
1.在接口上启用GTS:
traffic-shape rate {CIR [Bc [Be]]}
2.当接口收到向后显性拥塞通知(BECN)时,估算流量速?#23454;?#26368;低值:
traffic-shape adaptive {CIR}
3.以向前显性拥塞通知(FECN)做为BECN 的响应.可选:
traffic-shape fecn-adapt
GTS在policy map上的实现
GTS还可以定义平均值和峰?#26723;?#27969;量整形,并且可以在配置GTS 的时候采用CBWFQ。
配置基于分类的流量整形的步骤如下:
1.定义平均值和峰?#26723;腃IR,Bc 和Be:
(config-pmap-c)#shape {average|peak} {CIR [Bc] [Be]} average指的是平均值,peak?#26723;?#26159;峰值
2.定义缓冲区上限,默?#29616;?#20026;1000.可选:
(config-pmap-c)#shape max-buffers {number-of-buffers}
3.在策略上应用CBWFQ。可选:
(config-if)#service-policy output {policy-name}

H3C 华为交换机限速

H3C华为交换机限速有以下方法:
              line-rate(lr)
              s被过滤广告peed
              traffic-limit
              qos car
    H3C华为交换机端口限速
        二层较为准确(如:lr,speed),三层不准确(如:traffic-linit,qos car)
        lr :
            E050:(可信度100%)
                  [Quidway-Ethernet0/1]line-rate ?
                 INTEGER<1-100> Target rate(Mbps
            S5500:(可信度100%)
                  [S5500-GigabitEthernet1/0/1]qos lr outbound cir ?
                 INTEGER<64-1000000> Committed Information Rate(kbps), it must be a multiple of 64
        speed :    (可信度100%)
                 [S5500-GigabitEthernet1/0/1]speed ?
                 10    Specify speed of current port 10Mb/s
                 100   Specify speed of current port 100Mb/s
                 1000 Specify speed of current port 1000Mb/s
                 auto Enable port’s speed negotiation automatically
        traffic-limit : (可信度50%,当设定50M?#20445;?#24102;宽为7M左右;当设定10M?#20445;?#24102;宽为1M左右)
                 [Quidway E050-Ethernet0/1]traffic-limit inbound ip-group 2000 ?
                 INTEGER<1-100> Target rate(Mbps)
                 link-group      Apply the link-based acl
                 rule            Specify the ID of acl rule
        qos car :(s5500)(可信度50%,当设定9.6M?#20445;?#24102;宽为5M左右)
                 acl number 2000
                 rule 0 permit source 10.0.0.0 0.0.0.255
                 traffic classifier liukong operator and
                 if-match acl 2000
                 traffic behavior liukong
                 car cir 9600 cbs 200000 ebs 4000 green pass red discard yellow pass
                 qos policy liukong
                 classifier liukong behavior liukong
                 interface GigabitEthernet1/0/1
                 qos apply policy liukong inbound

    补充说明:交换机端口限速
    2000_EI系列以上的交换机都可以限速!
    限速不同的交换机限速的方式不一样!
    2000_EI直接在端口视图下面输入LINE-RATE (4 )?#38382;?#21487;选!
    端口限速配置
    1功能需求及组网说明
    端口限速配置
    『配置环境?#38382;?
    1. PC1和PC2的IP地址分别为10.10.1.1/24、10.10.1.2/24
    『组网需求』
    1. 在SwitchA上配置端口限速,将PC1的?#30053;?#36895;率限制在3Mbps,同时将PC1的上传速率限制在1Mbps
    2数据配置步骤
    『S2000EI系列交换机端口限速配置流程』
    使用以太网物理端口下面的line-rate命令,来对该端口的出、入报文进行流量限速。
    【SwitchA相关配置】
    1. 进入端口E0/1的配置视图
    [SwitchA]interface Ethernet 0/1
    2. 对端口E0/1的出方向报文进行流量限速,限制到3Mbps
    [SwitchA- Ethernet0/1]line-rate outbound 30
    3. 对端口E0/1的入方向报文进行流量限速,限制到1Mbps
    [SwitchA- Ethernet0/1]line-rate inbound 16
    ?#38745;?#20805;说明】
    报文速率限制级别取值为1~127。如果速率限制级别取值在1~28范围内,则速率限制的粒度为64Kbps,这种情况下,当设置的级别为N,则端口上限制的速率大小为N*64K;如果速率限制级别取值在29~127范围内,则速率限制的粒度为1Mbps,这种情况下,当设置的级别为N,则端口上限制的速率大小为(N-27)*1Mbps。
    此系列交换机的具体型号包括:S2008-EI、S2016-EI和S2403H-EI。
    『S2000-SI和S3000-SI系列交换机端口限速配置流程』
    使用以太网物理端口下面的line-rate命令,来对该端口的出、入报文进行流量限速。
    【SwitchA相关配置】
    1. 进入端口E0/1的配置视图
    [SwitchA]interface Ethernet 0/1
    2. 对端口E0/1的出方向报文进行流量限速,限制到6Mbps
    [SwitchA- Ethernet0/1]line-rate outbound 2
    3. 对端口E0/1的入方向报文进行流量限速,限制到3Mbps
    [SwitchA- Ethernet0/1]line-rate inbound 1
    ?#38745;?#20805;说明】
    对端口发送或接收报文限制的总速率,这里以8个级别来表示,取值范围为1~8,含义为:端口工作在10M速率?#20445;?~8分别表示312K,625K,938K,1.25M,2M,4M,6M,8M;端口工作在100M速率?#20445;?~8分别表示3.12M,6.25M,9.38M,12.5M,20M,40M,60M,80M。
    此系列交换机的具体型号包括:S2026C/Z-SI、S3026C/G/S-SI和E026-SI。
    『S3026E、S3526E、S3050、S5012、S5024系列交换机端口限速配置流程』
    使用以太网物理端口下面的line-rate命令,对该端口的出方向报文进行流量限速;结合acl,使用以太网物理端口下面的traffic-limit命令,对端口的入方向报文进行流量限速。
    【SwitchA相关配置】
    1. 进入端口E0/1的配置视图
    [SwitchA]interface Ethernet 0/1
    2. 对端口E0/1的出方向报文进行流量限速,限制到3Mbps
    [SwitchA- Ethernet0/1]line-rate 3
    3. 配置acl,定义符合速率限制的数据流
    [SwitchA]acl number 4000
    [SwitchA-acl-link-4000]rule permit ingress any egress any
    4. 对端口E0/1的入方向报文进行流量限速,限制到1Mbps
    [SwitchA- Ethernet0/1]traffic-limit inbound link-group 4000 1 exceed drop
    ?#38745;?#20805;说明】
    line-rate命令直接对端口的所有出方向数据报文进行流量限制,而traffic-limit命令必须结合acl使用,对匹配了指定访问控制列表规则的数据报文进行流量限制。在配置acl的时候,也可以通过配置三层访问规则,来对指定的源或目的网段报文,进行端口的入方向数据报文进行流量限制。
    端口出入方向限速的粒度为1Mbps。
    此系列交换机的具体型号包括:S3026E/C/G/T、S3526E/C/EF、S3050C、S5012G/T和S5024G。
    『S3528、S3552系列交换机端口限速配置流程』
    使用以太网物理端口下面的traffic-shape和traffic-limit命令,分别来对该端口的出、入报文进行流量限速。
    【SwitchA相关配置】
    1. 进入端口E0/1的配置视图
    [SwitchA]interface Ethernet 0/1
    2. 对端口E0/1的出方向报文进行流量限速,限制到3Mbps
    [SwitchA- Ethernet0/1]traffic-shape 3250 3250
    3. 配置acl,定义符合速率限制的数据流
    [SwitchA]acl number 4000
    [SwitchA-acl-link-4000]rule permit ingress any egress any
    4. 对端口E0/1的入方向报文进行流量限速,限制到1Mbps
    [SwitchA- Ethernet0/1]traffic-limit inbound link-group 4000 1000 150000 150000 1000 exceed drop
    ?#38745;?#20805;说明】
    此系列交换机的具体型号包括:S3528G/P和S3552G/P/F。
    『S3900系列交换机端口限速配置流程』
    使用以太网物理端口下面的line-rate命令,对该端口的出方向报文进行流量限速;结合acl,使用以太网物理端口下面的traffic-limit命令,对匹配指定访问控制列表规则的端口入方向数据报文进行流量限制。
    【SwitchA相关配置】
    1. 进入端口E1/0/1的配置视图
    [SwitchA]interface Ethernet 1/0/1
    2. 对端口E0/1的出方向报文进行流量限速,限制到3Mbps
    [SwitchA- Ethernet1/0/1]line-rate 3000
    3. 配置acl,定义符合速率限制的数据流
    [SwitchA]acl number 4000
    [SwitchA-acl-link-4000]rule permit ingress any egress any
    4. 对端口E0/1的入方向报文进行流量限速,限制到1Mbps
    [SwitchA- Ethernet1/0/1]traffic-limit inbound link-group 4000 1000 exceed drop
    ?#38745;?#20805;说明】
    line-rate命令直接对端口的所有出方向数据报文进行流量限制,而traffic-limit命令必须结合acl使用,对匹配了指定访问控制列表规则的数据报文进行流量限制。在配置acl的时候,也可以通过配置三层访问规则,来对指定的源或目的网段报文,进行端口的入方向数据报文进行流量限制。
    端口出入方向限速的粒度为64Kbps。
    此系列交换机的具体型号包括:S3924、S3928P/F/TP和S3952P。
    『S5600系列交换机端口限速配置流程』
    使用以太网物理端口下面的line-rate命令,对该端口的出方向报文进行流量限速;结合acl,使用以太网物理端口下面的traffic-limit命令,对匹配指定访问控制列表规则的端口入方向数据报文进行流量限制。
    【SwitchA相关配置】
    1. 进入端口E1/0/1的配置视图
    [SwitchA]interface Ethernet 1/0/1
    2. 对端口E0/1的出方向报文进行流量限速,限制到3Mbps
    [SwitchA- Ethernet1/0/1]line-rate 3000
    3. 配置acl,定义符合速率限制的数据流
    [SwitchA]acl number 4000
    [SwitchA-acl-link-4000]rule permit ingress any egress any
    4. 对端口E0/1的入方向报文进行流量限速,限制到1Mbps
    [SwitchA- Ethernet1/0/1]traffic-limit inbound link-group 4000 1000 exceed drop
    ?#38745;?#20805;说明】
    line-rate命令直接对端口的所有出方向数据报文进行流量限制,而traffic-limit命令必须结合acl使用,对匹配了指定访问控制列表规则的数据报文进行流量限制。在配置acl的时候,也可以通过配置三层访问规则,来对指定的源或目的网段报文,进行端口的入方向数据报文进行流量限制。
    端口出入方向限速的粒度为64Kbps。
    此系列交换机的具体型号包括:S5624P/F和S5648P

Cisco QoS配置说明(CBWFQ/LLQ/PQ/CQ/WFQ)

No Comments CISCO ,

CBWFQ 基于类别的加权公平排队,通常使用ACL定义数据流类别,并将注入宽带和队列限制等?#38382;?#24212;用于这些类别.
CBWFQ特点:
1)能够给不同的类保障一定的带宽
2)对传统的WFQ作了扩展支持用户自己定义流量的分类:
3)队列的个数和类别是一一对应,给每个class 保留带宽
CBWFQ与WFQ?#37027;?#21035;:
WFQ: 用户无法控制分类,由HASH算法自己决定
CBWFQ:让用户对流量自己来分类
WFQ 对正常流量 处理没问题,但是对语音流量显得”太公平”(语音要求低?#26144;?
CBWFQ:考虑到公平特性,并没有考虑?#25509;?#38899;的应用
CBWFQ Configuration:
CBWFQ(config)#
CBWFQ(config)#class-map match-any CBWFQ1
CBWFQ(config-cmap)#match dscp 6
CBWFQ(config-cmap)#match protocol http //两个条件,满足其中一个就可以匹配CBWFQ1//
CBWFQ(config-cmap)#exit
CBWFQ(config)#
CBWFQ(config)#class-map match-all CBWFQ2
CBWFQ(config-cmap)#match precedence 3
CBWFQ(config-cmap)#match protocol telnet //两个条件必须全部满足才能匹配CBWFQ2//
CBWFQ(config-cmap)#exit
CBWFQ(config)#
CBWFQ(config)#policy-map CBWFQ
CBWFQ(config-pmap)#class CBWFQ1 //调用class-map CBWFQ1//
CBWFQ(config-pmap-c)#bandwidth 60
CBWFQ(config-pmap)#
CBWFQ(config-pmap)#class CBWFQ2
CBWFQ(config-pmap-c)#bandwidth 30
CBWFQ(config)#
CBWFQ(config)#int s0/0
CBWFQ(config-if)#service-policy output CBWFQ   //CBWFQ只能在出方向上调用//
CBWFQ#
查看:
CBWFQ#
CBWFQ#show class-map
Class Map match-any class-default (id 0)
Match any
Class Map match-any CBWFQ1 (id 1)
Match dscp 6
Match protocol http
Class Map match-all CBWFQ2 (id 2)
Match precedence 3
CBWFQ#
CBWFQ#
CBWFQ#show policy-map
Policy Map CBWFQ
Class CBWFQ1
Bandwidth 60 (kbps) Max Threshold 64 (packets)
Class CBWFQ2
Bandwidth 30 (kbps) Max Threshold 64 (packets)
CBWFQ#
CBWFQ#
CBWFQ(config)#
CBWFQ(config)#policy-map CBWFQ
CBWFQ(config-pmap)#class CBWFQ1
CBWFQ(config-pmap-c)#queue-limit 30 // 定义每个队能存放的报文数量,超过后丢包方式:Tail drop//
CBWFQ#
CBWFQ#
CBWFQ#show policy-map
Policy Map CBWFQ
Class CBWFQ1
Bandwidth 60 (kbps) Max Threshold 30 (packets)
Class CBWFQ2
Bandwidth 30 (kbps) Max Threshold 64 (packets)
CBWFQ#
配置实例:
一家公司需求;HTTP流量保障256Kbps带宽,FTP流量保证512Kbps带宽,禁止BT流量.
CBWFQ(config)#
CBWFQ(config)#class-map class_HTTP   //定义一个匹配HTTP的类//
CBWFQ(config-cmap)#match protocol http
CBWFQ(config)#
CBWFQ(config)#class-map class_FTP
CBWFQ(config-cmap)#match protocol ftp
CBWFQ(config)#
CBWFQ(config)#class-map class_BT
CBWFQ(config-cmap)#match protocol bittorrent
CBWFQ(config)#
CBWFQ(config)#policy-map CBWFQ   //定义策略,调用类class//
CBWFQ(config-pmap)#class class_HTTP
CBWFQ(config-pmap-c)#bandwidth 256
CBWFQ(config-pmap)#
CBWFQ(config-pmap)#class class_FTP
CBWFQ(config-pmap-c)#bandwidth 512
CBWFQ(config-pmap)#
CBWFQ(config-pmap)#class class_BT
CBWFQ(config-pmap-c)#drop
CBWFQ(config-pmap)#
CBWFQ(config-pmap)#class class-default
CBWFQ(config-pmap-c)#fair-queue  //网络中剩下的流量除了HTTP,FTP之使用WFQ放到fair-queue中了//
CBWFQ(config)#
CBWFQ#
CBWFQ(config)#int s0/0
CBWFQ(config-if)#service-policy output CBWFQ
CBWFQ(config)#

QOS-WFQ
Weighted Fair Queue,加权公平队?#23567;FQ将分组按照不同的业务流、不同的IP优先级,自动按照HASH算法,划分成不同的队列,在保证高优先级业务的同?#20445;?#25353;照配置权重,将带宽公平地分给低优先级别的业务。Quidway路由器在每个接口上最大支持4096个队列,在此范围之内,网络治理员可以配置队列的数目和相应权值。WFQ的优点是?#36816;?#26377;应用都能比较公平地提供服务质量,对于要求?#32454;?#30340;业务可以通过设置权重保障优先级,能智能划分队列和调度,配置相对简单,对网络治理员要求相对?#31995;停?#32570;点是由于相对公平,对于QOS要求极高的应用,不能象PQ那样绝对保证,策略计算复杂,比较消耗路由器处理能力。它适用于应用?#32454;?#26434;,并且应用相对公平的网络,如Internet网。WFQ的思想:
i,为每个流创建一个专用的队列,避免队列的饥饿,?#26144;伲?#25238;动 等
ii,在所有流间公平,正确地分配带宽
iii,WFQ使用 [IP优先级] 作为分配带宽的权重 在CISCO路由器上,接口小于E1的链路会默认启用WFQ.
注:在WFQ中,weight的计算方式为4096/(IP优先级+1)或者32384r/(IP优先级+1)
因此在show queue中看到的weight值越大,表示权重越低。
WFQ优点
1.配置简单(不用手工分类)
2.保证所有的流都有一定的带宽
3.丢弃野蛮流量
4.大多数平台上都支持
5.支持所有IOS版本(11.0以上)
WFQ缺点
1.每个子队列?#25216;?#25215;了FIFO的缺点
2.多个不同的流可能会被分入同一个队列(流的数量超过了配置的队列数)
3.不支持手工分类
4.不能提供固定带宽保证
5.因为使用了复杂的分类和调度机制,对系统资源有一定的限制
配置命令:
route(config-if):fair-queue cdt dynamic-queues reservable-queues
动态队列个数 保留队列个数
reservable-queues:
保留队列个数:针对RSVP流,可以保留一定的队列,缺省是0,范围0~1000
dynamic-queues:
动态队列个数: 缺省是256,流确实很多,可以调大,最大4096
cdt:
每个队自己的长度
一个数据排到第一个队中,cdt=64,如果该队的报文己达到64,新的报文丢包!
每个队中排的报文数量是有限的
所有队列加起来,上限:
router(config-if)#hold-queue max-limit out 缺省1000
一个报文是否在WFQ中排到队列中的二个因素:
1)–本队列是否己满
2)–所有队列是否超出队列上限   —-超出报文丢弃
WFQ Configuration:
WFQ(config)#
WFQ(config)#int s0/1
WFQ(config-if)#fair-queue //表面接口启用WFQ,CISCO路由器小于E1会默认启用//
WFQ(config-if)#fair-queue 128 1024 100 //设置CDT为128,动态队列数量为1024个,保留队列个数100//
WFQ(config-if)#hold-queue 1200 out //所有队列加起来CDT上限是1200//
WFQ(config-if)#
查看:
WFQ#
WFQ#show int s0/1
Serial0/1 is up, line protocol is up
Queueing strategy: weighted fair
Output queue: 0/1200/64/0 (size/max total/threshold/drops)
Conversations   0/1/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 1158 kilobits/sec
5 minute input rate 3000 bits/sec, 3 packets/sec
5 minute output rate 3000 bits/sec, 3 packets/sec
1001 packets input, 97009 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
1004 packets output, 96674 bytes, 0 underruns
0 output errors, 0 collisions, 3 interface resets
0 output buffer failures, 0 output buffers swapped out
3 carrier transitions     DCD=up   DSR=up   DTR=up   RTS=up   CTS=up
WFQ#
QOS-CQ
Customized Queue 用户定制队列
CQ使用了17个子队列(其中0子队列是PQ队列,优先级很高,留给系统使用),CQ使用WRR(Round-Robin)机制。首先谈谈RR机制,RR在处理完一个队列的一个数据包之后,会接着处理另一个队列的一个数据包,一直下去,最后又?#25317;?#19968;个队列开始轮流处理每个队列中的数据包,RR中的每个队列的优先级都是一样的。RR的改进版是WRR(WeightedRound-Robin),WRR允许用户为每个队列分配一个权值,根据这个权值,每个队列都能获得一定的接口带宽。在CQ中,权值就是一次轮循中可以转发的字节数。
前面?#26723;?#20102;0队列是PQ队列,实际上可以把其他队列也设置成PQ队列:
可以通过以下命令来设置:
queue-list list-number lowest-custom queue-number
比如命令queue-list 1 lowest-custom 3,说明0,1,2都是优先级队列,3以及3以上编号的队列都是定制队?#23567;?
CQ configuration:
r2(config)#
r2(config)#access-list 101 permit ip any any precedence 5
r2(config)#
r2(config)#queue-list 16 protocol ip 1 list 101 //把ACL101定义的数据流?#25104;?#21040;子队列1中//
r2(config)#queue-list 16 queue 1 limit 40 //设置子队列1的队列深度为40个数据包//
r2(config)#queue-list 16 lowest-custom 2  //设置queue 0,1为优先级队列PQ,其余的为CQ//
r2(config)#queue-list 16 interface s0/0 2 //把s0/0接口进入的流量?#25104;?#21040;子队列2中//
r2(config)#queue-list 16 queue 2 byte-count 3000 //设置子队列2在一个轮循内可以传输3000字节数据包
r2(config)#queue-list 16 protocol ip 3 //把所有IP流量?#25104;?#21040;子队列3中//
r2(config)#queue-list 16 queue 3 byte-count 5000
r2(config)#queue-list 16 default 4 //其它所有流量?#25104;?#21040;子队列4中//
r2(config)#
r2(config)#
r2(config)#int s0/1
r2(config-if)#custom-queue-list 16 //应用CQ到接口s0/1上//
r2(config)#
QOS-PQ

PQ使用了4个子队列,优先级分别是high,medium,normal,low。PQ会先服务高优先级的子队列,若高优先级子队列里没有数据后,再服务中等优先级子队列,?#26469;?#31867;推。如果PQ正在服务中等优先级子队列,但是高优先级里又来了数据包,则PQ会中?#29616;?#31561;优先级子队列的服务,转而服务高优先级子队?#23567;?#27599;一个子队列都有一个最大队列深度(queue-size),如果达到了最大队列深度,则进行尾丢弃。
PQ优点
1.对高优先级的数据流提供了低?#26144;?#30340;转发
2.大多数平台上都支持该队列机制
3.支持所有的IOS版本(10.0以上)
PQ缺点
1.对单一子队列而言,会继承FIFO队列的所有缺点
2.对低优先级的数据流而言,可能会被“饿死?#20445;?#22240;为只有高优先级队列里有数据,PQ就?#25442;?#26381;务低优先级队列
3.需要在每一跳上都手工的配置分类
PQ Configuration:
PQ(config)#
PQ(config)#priority-list 1 protocol ip high list 101 //把Acl101定义的数据?#25104;?#21040;high优先级队列//
PQ(config)#priority-list 1 interface s0/0 medium  //把来自s0/1口的流量?#25104;?#21040;Medium优先级队列//
PQ(config)#priority-list 1 default normal //所有其它流量?#25104;?#21040;Normal优先级队列//
PQ(config)#priority-list 1 queue-limit 20 30 40 50 //分别设置高,中,普通,低优先级队列长度//
PQ(config)#
PQ(config)#int s0/1
PQ(config-if)#priority-group 1 //把PQ?#25104;?#21040;接口s0/1上//
PQ(config)#
查看:
PQ#
PQ#show queueing int s0/1
Interface Serial0/1 queueing strategy: priority
Output queue utilization (queue/count)
high/13 medium/0 normal/2056 low/0
PQ#
PQ#
PQ#show queueing priority
Current DLCI priority queue configuration:
Current priority queue configuration:
List Queue   Args
1    high protocol ip       list 101
1    medium interface Serial0/0
1    medium limit 30
1    normal limit 40
1    low limit 50
PQ#
QOS-LLQ
Low Latency Queueing(低?#26144;?#38431;列LLQ)
i、特点
在CBWFQ中添加一个优先级队列用于实时的流量。
* 高优先级队列得到如下保障:
a)低?#26144;?#30340;报文转发
b)带宽
注:在拥塞发生?#20445;?#39640;优先级的流量同时受到管制—即它们占用的带宽不能超过它们所保障的带宽。
* 低优先级队列使用CBWFQ。
ii、配置LLQ
priority 带宽值—-为一个类分配固定的带宽?#31561;?#20445;快速转发;若拥塞?#20445;?#36229;过该带宽的流量将被丢弃。(若没有拥塞,将?#25442;?#20351;用管制)
LLQ基本可?#26376;?#36275;企业中融合的网络应用
支持语音对网络的低?#26144;伲?#25238;动小,保障带宽
对其它流量提供公平处理
LLQ= CBWFQ+PQ
LLQ configuration:
LLQ(config)#
LLQ(config)#class-map VOIP
LLQ(config-cmap)#match ip precedence 5
LLQ(config)#
LLQ(config)#class-map cbwfq1
LLQ(config-cmap)#match ip precedence 3 4
LLQ(config)#
LLQ(config)#class-map cbwfq2
LLQ(config-cmap)#match ip precedence 1 2
LLQ(config)#
LLQ(config)#policy-map LLQ
LLQ(config-pmap)#class VOIP
LLQ(config-pmap-c)#priority percent 10 //针对VOIP类流量使用PQ,这路流量在任何情况下都优先发送
LLQ(config-pmap-c)#                   同时最大带宽可以为接口带宽的10%//
LLQ(config-pmap)#class cbwfq1
LLQ(config-pmap-c)#bandwidth percent 30
LLQ(config-pmap-c)#
LLQ(config-pmap)#class cbwfq2
LLQ(config-pmap-c)#bandwidth percent 20 //CBWFQ方式进行调度,分别保障30%和20%接口带宽//
LLQ(config-pmap-c)#
LLQ(config-pmap)#class class-default
LLQ(config-pmap-c)#fair-queue    //剩下其它队列采用缺省的WFQ调度//
LLQ(config-pmap-c)#
LLQ(config)#
LLQ(config)#int s0/0
LLQ(config-if)#service-policy output LLQ
LLQ(config)#

使用QOS限速 CISCO交换机

No Comments CISCO , , ,

int f 0/1

service-policy input policymap1

end

第四步:保存设置

write

同上配置Fa0/3、Fa0/5、Fa0/7,设置端口限速为 2M / 5M /10M

基于MAC地址的带宽限制
该配置案例假设需限制源MAC地址000c.7693.b93a的用户的上行带宽为1M,设置步骤如下:

第一步:配置对应MAC地址的数据流定义

conf

mac access-list extended Macratelimit1

permit host 000c.7693.b93a any  

exit

第二步:设置对应该数据流的带宽限制(1M/bps), 猝发数据量为64k/8usec

class-map classmap2

match access-group Macratelimit1

exit

policy-map policymap5

class classmap2

police 1000000 65536 exceed-action drop

exit

exit

第三步:与要进行带宽限制的端口关联

int f 0/9

service-policy input policymap5

end

第四步:保存设置

write

同上配置Fa0/11、Fa0/13、Fa0/15,设置端口限速为 2M / 5M /10M

基于四层协议的带宽限制
该配置案例假设需要控制用户的TCP数据流,控制带宽为1M,配置步骤如下:

第一步:定义扩展访问列表

conf

ip access-list extended TCPACL

permit tcp host 192.168.26.146 any

exit

第二步:设置对应该数据流的带宽限制

class-map classmap3

match access-group TCPACL

exit

policy-map policymap9

class classmap3

police 1000000 65536 exceed-action drop

exit

exit

第三步:与要进行带宽限制的端口关联

int f 0/17

service-policy input policymap9

end

第四步:保存设置

write

同上配置Fa0/19、Fa0/21、Fa0/23,设置端口限速为 2M / 5M /10M

基于应用层的带宽限制
在基于应用层的测试中发现对ftp?#30053;?#38480;速无效!经过分析,发现ftp?#31361;?#31471;与Serv-U建立ftp?#30053;?#36830;接?#20445;?#20250;变更?#30053;?#27969;的源端口。建议售?#23433;?#35797;时不要推荐用户测ftp应用层带宽线速,如要测试,可先用sniifer抓出?#30053;?#27969;的端口,然后在交换机上配置相应端口的ACL。

下面是http流限速的配置举例:

第一步:定义扩展访问列表

conf

ip access-list extended www

permit tcp host 192.168.26.146 eq www any

exit

第二步:设置对应该数据流的带宽限制

class-map classmap4

match access-group www

exit

policy-map policymap13

class classmap4

police 1000000 65536 exceed-action drop

exit

exit

第三步:与要进行带宽限制的端口关联

int f 0/18

service-policy input policymap13

end

第四步:保存设置

write

附:ftp?#30053;?#38480;速结果,供测试参考。

无限制时实际?#30053;?#36895;度与FTP服务器的性能,及?#31361;?#31471;PC的网卡有关。

实际?#30053;?#36895;度
无限制
1.22M/B
基于IP的限速
1M/bps
0.1M/B
2M/bps
0.16M/B
5M/bps
0.26M/B
10M/bps
0.84M/B
基于MAC的限速
1M/bps
0.1M/B
2M/bps
0.16M/B
5M/bps
0.27M/B
10M/bps
0.88M/B
基于四层端口的限速
1M/bps
0.1M/B
2M/bps
0.16M/B
5M/bps
0.26M/B
10M/bps
0.77M/B

测试注意要点:

1、 限速配置的第一步是定义需要限速的流,这项是通过QOS 的ACL列表来完成的。对于不在QOS ACL列表中的流,交换机依旧转发,只是限速功能无效。

2、 所有的限速,只对端口的input有效,即进入交换机端口的流有效。目前无法做到对单一端口的input/outpt双向控制。

3、 速度控制,在1M/bps时较准,其他的有偏移,但还可体现出速?#32570;?#38480;制。

cisco QOS配置案例

No Comments CISCO , ,

典型QoS配置案例
一般的QoS配置不外乎四个步骤:
1,设置ACL匹配应用流量;
2,设置class-map匹配相应ACL或者相应端口等等,不过一般式匹配ACL;
3,设置policy-map匹配class-map,然后定一规则动作;
4,将policy-map绑定到相应的接口上。下面使用一个比?#31995;?#22411;的案例?#27492;?#26126;QoS的配置步骤:需求:路径带宽为622Mbps,四种应用流量,需要保证如下几点:
流量1,某一具体应用流量,永?#38431;?#20808;传输,最小带宽保证为365Mbps;
流量2,某一具体应用流量,次优先传输,最小带宽保证为200Mbps;
流量3,此为业务流量,保证在1和2后的其余带宽下传输即可;
流量4,某一具体应用流量,保证在123流量外的带宽下传输即可。具体配置如下:
第一步,定义ACL匹配应用流量:
ip access-list extended tra1_acl
permit tcp 1.1.1.0 0.0.0.255 1.1.2.0 0.0.0.255 eq 8818
ip access-list extended tra2_acl
permit tcp 1.1.3.0 0.0.0.255 1.1.4.0 0.0.0.255 eq 901
ip access-list extended tra4_acl
permit ip 1.1.5.0 0.0.0.255 1.1.6.0 0.0.0.255
第二步,定义class-map匹配相关ACL:
class-map match-all tra1_cmap
match access-group name tra1_acl
class-map match-all tra2_cmap
match access-group name tra2_acl
class-map match-all tra4_cmap
match access-group name tra4_acl
第三步,定义policy-map:
policy-map tra_pmap
class tra1_cmap
    set precedence 5
plicy cir 365000000 bc 8500000 be 13500000 conform-action transmit exceed-action set-prec-transmit 3 violate-action set-prec-transmit 2
    bandwitch 365000
class tra2_cmap
    set precedence 4
policy cir 200000000 bc 10000000 be 13000000 conform-action transmit exceed-action set-prec-transmit 3 violate-action set-prec-transmit 2 bandwidth 200000
class tra4_cmap
    set precedence 1
class class-default
    set precedence 2
第四步,绑定policy-map于相应的接口:
int pos1/0/0
service-policy output tra_pmap
至此,配置完毕。通过命令查看policy-map的匹配情况:
switch-a#sh policy-map interface pos1/0/0
POS1/0/0 Service-policy output: tra_map    Class-map: tra1_cmap (match-all)
      66639423781 packets, 74849682635166 bytes
      30 second offered rate 260369000 bps, drop rate 0 bps //匹配此class-map的流量速率
      Match: access-group name tra1_acl
      Queueing
      queue limit 91250 (packets)
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts queued/bytes queued) 66639405294/74849695040832
      QoS Set
        ip precedence 5
          Packets marked 66639423781
      police:
          cir 365000000 bps, bc 8500000 bytes, be 13500000 bytes //注意cir、bc和be的单位
        conformed 66191701966 packets, 74341131469597 bytes; action: transmit
        exceeded 218369922 packets, 232627302399 bytes; action: set-prec-transmit 4
        violated 229208950 packets, 275718927918 bytes; action: set-prec-transmit 3
        conformed 256761000 bps, exceed 1656000 bps, violate 1939000 bps //每个action的流量速率,注意这三个值总和应该大致等于上面的总速率;
      bandwidth 365000 kbps     Class-map: tra2_cmap (match-all)
      11315788699 packets, 7283900643868 bytes
      30 second offered rate 10753000 bps, drop rate 0 bps
      Match: access-group tra2_acl
      Queueing
      queue limit 50000 (packets)
      (queue depth/total drops/no-buffer drops) 1/0/0
      (pkts queued/bytes queued) 11315783713/7283897663316
      QoS Set
        ip precedence 4
          Packets marked 11315788699
      police:
cir 200000000 bps, bc 10000000 bytes, be 13000000 bytes
        conformed 11315784826 packets, 7283898283723 bytes; action: transmit
        exceeded 0 packets, 0 bytes; action: set-prec-transmit 3
        violated 0 packets, 0 bytes; action: set-prec-transmit 2
        conformed 10753000 bps, exceed 0 bps, violate 0 bps
      bandwidth 200000 kbps     Class-map: tra4_cmap (match-all)
      1751296887 packets, 2633425803184 bytes
      30 second offered rate 149000 bps, drop rate 0 bps
      Match: access-group name tra4_acl
      QoS Set
        ip precedence 1
          Packets marked 1751296887     Class-map: class-default (match-any)
      22956539608 packets, 17721898306471 bytes
      30 second offered rate 196094000 bps, drop rate 528000 bps
      Match: any
      queue limit 14250 (packets)
      (queue depth/total drops/no-buffer drops) 0/9004701/0
      (pkts queued/bytes queued) 24700897941/20350618920708
      QoS Set
        ip precedence 2
          Packets marked 22958504481
switch-a#必要命令解释:
plicy cir 365000000 bc 8500000 be 13500000 conform-action transmit exceed-action set-prec-transmit 3 violate-action set-prec-transmit 2
cir为?#20449;档?#24102;宽速率,即需要保证的带宽速率,单位为bps;
bc为普通突发,单位为bytes;
be为最高突发,单位为bytes;
set-prec-transmit,表示设置IP优先级并转发数据包;
上面整体命令解释为:?#20449;?#24102;宽365Mbps,普通突发为8.5Mbytes,最高突发为13.5Mbytes。当速率小于450Mbps(365+85)是转发数据包,当超过450Mbps小于500Mbps(365+135)是重写IP优先级为3并转发数据包,当超过500Mbps是重写IP优先级为2并转发数据包。

30选5玩法