30选5玩法|福彩30选5开奖结果321|
 

标签:ntp

国内免费的NTP服务器

No Comments Linux

中国 · 中国教育网 · 中国香港 · 中国台湾 · 美国 · 新加坡 · 韩国 · 日本 · 德国 · 印度尼西亚 · 其他

区域
域名
IP池

中国
cn.ntp.org.cn

223.65.211.46
由*?#25945;?#31185;技*提供

223.113.97.99
由*?#25945;?#31185;技*提供

118.24.4.66
自有节点

202.108.6.95

120.25.108.11
由*阿里云*提供

182.92.12.11
由*阿里云*提供

203.107.6.88
由*阿里云*提供

120.25.115.20
由*阿里云*提供

中国教育网
edu.ntp.org.cn

202.112.31.197
由*东北大学*提供

202.112.29.82
由*东北大学*提供

202.118.1.130
由*东北大学*提供

202.118.1.81
由*东北大学*提供

中国香港
hk.ntp.org.cn

118.193.151.223
由*维智创想*提供

中国台湾
tw.ntp.org.cn

123.204.45.116

103.18.128.60

美国
us.ntp.org.cn

158.69.48.97
由*微林*提供

216.218.254.202

------中间广告---------

208.53.158.34

66.228.42.59

新加坡
sgp.ntp.org.cn

103.11.143.248

202.73.57.107

128.199.134.40

218.186.3.36

188.166.245.58

韩国
kr.ntp.org.cn

211.233.40.78

106.247.248.106

日本
jp.ntp.org.cn

106.186.122.232
由*Allen Zhong*提供

106.187.100.179
由*Allen Zhong*提供

133.100.11.8
由*日本福冈大学*提供

129.250.35.251

德国
de.ntp.org.cn

131.188.3.220

131.188.3.223

印度尼西亚
ina.ntp.org.cn

203.114.74.17
由*Allen Zhong*提供

特殊机房专用线路,请勿外用

区域
域名
IP池

Simcentric
sim.ntp.org.cn

182.16.3.162
由*Simcentric*提供

windows 2008安装ntp时间同步服务器 测试无效

windows 2008安装ntp时间同步服务器

1. 下载ntp服务器软件 http://www.meinberg.de/english/sw/index.htm

2. 安装过程中国设置服务器地址为127.127.1.0

3.打开c:\program files\ntp\etc\ntp.conf

设置从本机获取时间,也可以指定网络上的时间服务器

www.2cto.com

server 127.127.1.0 prefer

fudge 127.127.1.0 stratum 10

4. 修改了配置,服务里重启ntp服务, netstat -nap udp看123端口啊有启动

linux设置计划任务和这台windows server时间同步

执行cron -e命令:类似vim编辑器,编辑完:wq保存退出即可

*/10 * * * * /usr/sbin/ntpdate 192.168.1.88

作者 gaoxuefeng

本文隐藏内容 登陆 后才可以浏览

windows server 2008 NTP服务器 测试无效

一、服务器端

修改注册表,提供NTP服务。

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\Parameters]    实测正版2008没有这条
"LocalNTP"=dword:00000001
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\TimeProviders\NtpServer]
"Enabled"=dword:00000001
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\Config]
"AnnounceFlags"=dword:0000000a

在命令行中输入”net stop w32time && net start w32time“重启W32Time服务

测试结果,无法同步 

 

二、客户端

设置时间同步服务器和重启服务:

net time/setsntp:10.1.0.7 (Myntp server ip:10.1.0.7)
net stop w32time && net startw32time

三、同步时间间隔

修改注册表中相关地方设置

客户端和服务器:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\W32Time\Config 下面的 UpdateInterval
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\W32Time\TimeProviders\NtpClient下面的SpecialPollInterval

时间以秒做单位,我设置成30分钟,1800,目前工作良好。设置得太大,有时不能同步。

PS:210.72.145.44 国家什么标准时钟,可让服务器与其它同步。此项可有可无的。

 

 

2003 没有相应服务器故无法测试

win2003系统为例介绍如何设置NTP服务器。

Windows 2002系统在默认情况下,是作为NTP(Network TimeProtocol)客户端工作的 ,所以必须通过修改注册表,以使系统作为NTP服务器运?#23567;?

1.修改注册表的键值:Run-<regeditHKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\TimeProviders\NtpServer内的Enabled为1,打开NTP服务器功能(默认是不开启NTP Server服务,除非电脑升级成为域控制站)

2.修改注册表键值HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\Config下的AnnounceFlags为5.该设定强制主机将它自身宣布为可靠的时间源.如果不修改此项则可能报错:时间例子被拒绝,因为:对等机器的层次(stratum)不主机层次少.

3.重启w32time服务 :Run-<cmd进入命令行: net stop w32time netstart w32time好了,如果你运气足够好的话(我经常遇到莫名的问题),此时在客户端就能进行时钟同步了。要把服务器地址加入系统的时间服务器地址,还需要修改注册表:[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\DateTime\Servers]加入你自己的时间服务器。

附录:NTP服务器时间同步一级时间服务器更精确(stratum 1)、二级时间服务器(stratum2)、……、15级时间服务器(stratum 15)。 stratum1: 210.72.145.44 中国科学院国家授时中心 s1a.time.edu.cn ?#26412;┯实?#22823;学 s1b.time.edu.cn 清华大学 s1c.time.edu.cn ?#26412;?#22823;学 s1d.time.edu.cn 东南大学 s1e.time.edu.cn 清华大学 time.windows.com 美国微软

客户端同步一般解决是这样:开始——控制面板——性能与维护——管理工具——服务——windowstime属性——启动类型自动——启动。就好了!如果启动该服务时提示: 错误1058:无法启动服务,原因可能是已被禁用与其相关联的设备没有启动。 原因是windowstime服务失效。

修复:

1.运行 cmd 进入命令行,然后键入 w32tm/register 正确的响应为:W32Time成功注册。

2.如果上一步正确,用 net start "windows time" 或 net start w32time启动服务。

3.开始——控制面板——性能与维护——管理工具——服务——windows time属性——启动类型自动——启动。就好了!

调整Windows Xp时间同步?#24503;?/p>

系统时间走的越来越快总调是不准,而WindowsXp时间同步调整周期为一周时间,太长了,所以想调整为每2小时同步如下,在网上?#19994;?#26041;法如下:打开注册表编辑器,依次展开HKEY_LOCAL_MACHINE\\SYSTEM\\ControlSet001\\Services\\W32Time\\TimeProviders\\NtpClient接着双击后面的“SpecialPollInterval?#20445;?#25226;其中的604800(十进制)改成“7200?#20445;?#21313;进制)就可以了,修改的这个数字其实就是校对时间间隔的秒数。

NTP时钟 配置指南

No Comments CISCO ,

路由器日志显示时间戳
提问 在路由器 的日志和排错信息里面显示时间
回答
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#service timestamps log datetime localtime
Router(config)#service timestamps debug datetime localtime
Router(config)#end
Router#
注释 还可以在命令后面?#30001;蟬how-timezone, msec等?#38382;?#35753;时间戳包含时区信息和毫秒级
14.2.  设置时间
提问 设置路由器时间
回答
内?#26102;?/span>
Router#clock set 14:27:22 January 29 2006
Router#
高端路由器使用电池保存时间
Router#calendar set 14:34:39 January 29 2006
Router#
注释 如果没有电池保护路由器重启时间配置消失,show calendar一方面可以显示目前时钟,也可以?#32654;?#39564;证是否有电池保护,内部时钟和calendar时钟不一致时可以使用clock update-calendar或者clock read-calendar来互相同步
14.3.  设置时区
提问 设置路由器时区
回答
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#clock timezone EST 5
Router(config)#end
Router#
注释 缺省路由器使用UTC就是以前的GMT
14.4.  夏时制调整
提问 路由器自动对时钟进行夏时制调整
回答
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#clock summer-time EDT date 26 oct 2003 02:00 6 apr 2003 02:00
或者
Router(config)#clock summer-time AEDT recurring last sun oct 02:00 last sun mar 02:00
Router(config)#end
Router#
注释 缺省是没有夏时制的,启用后可以使用show clock detail来验证
14.5.  时钟同步(NTP)
提问 路由器自动同步网络时间
回答
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#clock timezone EST -5
Router(config)#clock summer-time EDT recurring
Router(config)#ntp server 172.25.1.1
Router(config)#end
Router#
对于不支持NTP的路由器,使用SNTP
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#clock timezone EST -5
Router(config)#clock summer-time EDT recurring
Router(config)#sntp server 172.25.1.1
Router(config)#end
Router#
注释 可以使用ntp source loopback0 或者ntp server 10.1.1.1 source Serial 0/0 命令来指定NTP发送的源地址。由于NTP同步的是内部时钟,所以需要配置ntp update-calendar 来同时同步其calendar时钟
14.6.  配置NTP 冗余
提问 配置多个NTP服务器的方式来提供冗余
回答
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#clock timezone EST -5
Router(config)#clock summer-time EDT recurring
Router(config)#ntp server 172.25.1.1
Router(config)#ntp server 10.121.33.231
Router(config)#ntp peer 192.168.12.12
Router(config)#end
Router#
注释 无
14.7.  设置路由器为网络NTP服务器
提问设置路由器为网络NTP服务器,成为网络的主时钟源
回答
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#clock timezone EST 5
Router(config)#clock summer-time EDT recurring
Router(config)#clock calendar-valid
Router(config)#ntp master 8
Router(config)#end
Router#
注释 这里设置ntp master 8使其成为Stratum level 8,尽量不要配置其为1
14.8.  调整NTP同步周期
提问 调整多久路由器发送NTP数据包来验证同步
回答
NTP不允许手动修改同步?#24503;剩?#20294;是内置的算法可以自动调整?#20284;德?
注释 开始为64秒一个周期,如果网络足够稳定此周期会逐渐增加,最长到1024秒,如下例
Router>show ntp associations
      address         ref clock     st  when  poll reach  delay  offset    disp
*~172.25.1.1       130.207.244.240   2   440  1024  377     1.6   -3.23     5.6
+~172.25.1.3       204.152.184.72    2   829  1024  377     1.7    8.06     0.9
* master (synced), # master (unsynced), + selected, – candidate, ~ configured
Router>
14.9.  NTP 发送周期性广播包保?#25351;?#26032;
提问 工作于广播模式下,不需要周期性去查询
回答
服务器端
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#clock timezone EST -5
Router1(config)#clock summer-time EDT recurring
Router1(config)#ntp server 172.25.1.1
Router1(config)#ntp server 172.25.1.2
Router1(config)#interface FastEthernet0/0
Router1(config-if)#ntp broadcast
Router1(config-if)#end
Router1#
客户端
Router2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router2(config)#clock timezone EST -5
Router2(config)#clock summer-time EDT recurring
Router2(config)#ntp broadcastdelay 4
Router2(config)#interface Ethernet0
Router2(config-if)#ntp broadcast client
Router2(config-if)#end
Router2#
注释 工作于广播模式时间数据包是单方向的,通过broadcastdelay来控制周期,广播模式不妨碍客户端工作于服务器客户端模式

NTP发送周期性组播包保?#25351;?#26032;
提问 工作于组播模式下,不需要周期性去查询
回答
服务器端
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#clock timezone EST -5
Router1(config)#clock summer-time EDT recurring
Router1(config)#ntp server 172.25.1.1
Router1(config)#ntp server 172.25.1.3
Router1(config)#interface FastEthernet 0/0
Router1(config-if)#ntp multicast 224.0.1.1 ttl 1
Router1(config-if)#end
Router1#
客户端
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#clock timezone EST -5
Router1(config)#clock summer-time EDT recurring
Router1(config)#ntp server 172.25.1.1
Router1(config)#ntp server 172.25.1.3
Router1(config)#interface FastEthernet 0/0
Router1(config-if)#ntp multicast 224.0.1.1 ttl 1
Router1(config-if)#end
Router1#
注释 组播相对于广播的好处不用多说了,并?#20197;?#36825;个模式的初始客户端会先发送一些单播包来测量延迟,以?#25925;?#38388;更准确,需要注意的是不是所有的设备都支持这种组播模式
14.11.  基于接口开启NTP
提问 路由器配置为NTP服务器,但是某些端口禁止NTP服务
回答
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface Serial0/1
Router(config-if)#ntp disable
Router(config-if)#end
Router#
或者
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#access-list 107 deny udp any eq 123 any eq 123
Router(config)#access-list 107 permit ip any any
Router(config)#interface Serial0/1
Router(config-if)#ip access-group 107 in
Router(config-if)#end
Router#
注释 控制列表的方式更严格,第一种只是阻止了相应的associations,但阻止不了NTP数据包
14.12.  NTP ?#29616;?
提问 鉴权NTP数据包保证安全
回答
服务器端
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#ntp authentication-key 2 md5 neoshi
Router1(config)#ntp authenticate
Router1(config)#ntp trusted-key 2
Router1(config)#end
Router1#
客户端
Router2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router2(config)#ntp authentication-key 2 md5 neoshi
Router2(config)#ntp authenticate
Router2(config)#ntp trusted-key 2
Router2(config)#ntp server 172.25.1.5 key 2
Router2(config)#end
Router2#
注释 对于广播或者组播模式key配置为ntp broadcast key 2 和ntp multicast key 2
14.13.  限制NTP Peers数目
提问 限?#22369;?#30001;器可以?#37038;?#30340;NTP Peers的数目
回答
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#ntp max-associations 30
Router(config)#end
Router#
注释 无
14.14.  限制Peers
提问 对NTP服务进行更好粒度的控制
回答
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#access-list 88 permit host 172.25.1.1
Router(config)#access-list 88 permit host 10.1.1.1
Router(config)#access-list 99 permit 172.25.0.0 0.0.255.255
Router(config)#access-list 99 permit 10.2.0.0 0.0.255.255
Router(config)#clock timezone EST -5
Router(config)#clock summer-time EDT recurring
Router(config)#ntp server 172.25.1.1 version 3
Router(config)#ntp server 10.1.1.1 version 3
Router(config)#ntp access-group peer 88
Router(config)#ntp access-group serve-only 99
Router(config)#end
Router#
注释 路由器只允许内部时钟从ACL88定义的两个服务器中获得同步,同时只有ACL99定义的两个网段的客户端可以从本设备请求时间信息
14.15.  设定时钟周期
提问 希望调整自动生成的ntp clock-period xxxxxx 数值
回答
路由器在重启之后会自动生成一个时钟周期来加速再同步,不建议删除或者修改
Router#show running-config | include clock-period
ntp clock-period 17180200
Router#
注释 无
14.16.  检查NTP状态
提问 查看当前NTP状态
回答
Router>show clock detail
Router>show ntp status
Router>show ntp associations
Router>show ntp associations detail
注释 Router>show clock detail
.15:54:33.079 EST Sun Jan 29 2006
Time source is NTP
此输出前面有个.代表此时?#29992;?#26377;同步
14.17.  NTP排错
提问 解决NTP出错的问题
回答
NTP非常稳定,出问题很大可能性就是连?#26377;?#30340;问题
Router#debug ntp packets
注释 Router#debug ntp packet
NTP packets debugging is on
.Mar 21 02:39:18: NTP: xmit packet to 172.25.1.5:
.Mar 21 02:39:18:  leap 3, mode 3, version 3, stratum 0, ppoll 64
.Mar 21 02:39:18:  rtdel 28C7 (159.286), rtdsp 2444 (141.663), refid AC190101
.Mar 21 02:39:18:  ref C043C43F.47A9CD5C (21:30:23.279 EST Wed Mar 20 2003)
.Mar 21 02:39:18:  org 00000000.00000000 (19:00:00.000 EST Thu Dec 31 1899)
.Mar 21 02:39:18:  rec 00000000.00000000 (19:00:00.000 EST Thu Dec 31 1899)
.Mar 21 02:39:18:  xmt C043C656.4DFC7394 (21:39:18.304 EST Wed Mar 20 2003)
.Mar 21 02:39:25: NTP: rcv packet from 172.25.1.5 to 172.16.2.2 on Fa0/0.1:
.Mar 21 02:39:25:  leap 3, mode 3, version 3, stratum 0, ppoll 64
.Mar 21 02:39:25:  rtdel 286E (157.928), rtdsp 0EC6 (57.709), refid AC190101
.Mar 21 02:39:25:  ref C043C4D7.1D633CDE (21:32:55.114 EST Wed Mar 20 2003)
.Mar 21 02:39:25:  org 00000000.00000000 (19:00:00.000 EST Thu Dec 31 1899)
.Mar 21 02:39:25:  rec 00000000.00000000 (19:00:00.000 EST Thu Dec 31 1899)
.Mar 21 02:39:25:  xmt C043C65D.1D0A6CBC (21:39:25.113 EST Wed Mar 20 2003)
.Mar 21 02:39:25:  inp C043C65D.1296E3C7 (21:39:25.072 EST Wed Mar 20 2003)
上面是一个debug的输出,从中看到了来自server的数据包显示为stratum 0,代表服务器没有同步,既然上游服务器没有同步,本地服务器就更不能同步了
14.18.  NTP 日志
提问 记录重要的NTP事件
回答
Router2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router2(config)#ntp logging
Router2(config)#end
Router2#
注释 此命令来自12.3(7)T,下面是一个日志记录
Router2#show logging | include NTP
000019: Jan 29 10:57:52.633 EST: %NTP-5-PEERSYNC: NTP synced to peer 172.25.1.5
000020: Jan 29 10:57:52.637 EST: %NTP-6-PEERREACH: Peer 172.25.1.5 is reachable
000024: Jan 29 11:01:20.653 EST: %NTP-4-PEERUNREACH: Peer 172.25.1.5 is unreachable
000026: Jan 29 11:15:11.985 EST: %NTP-4-UNSYNC: NTP sync is lost
14.19.  Extended Daylight Saving Time
注释 美国为了节省能?#21019;?007年开始调整了夏时制的设置,此略去
NTP 服务器配置
注释 主机配置暂略去

配置CiscoNTP服务和协议

No Comments CISCO ,

 

NTP协议全称网络时间协议(Network Time Procotol)。它的目的是在国际互联网上传递统一、标准的时间。具体的实现方案是在网络?#29616;?#23450;若干时钟源网站,为用户提供授时服务,并且这些网站间应该能够相互比对,提高准确度。

* 服务器:

conf tntp autentication-key 1 md5 cxzhzx 7 NTP?#29616;tp authenticate NTP?#29616;tp trusted-key 1 NTP?#29616;tp source vlan1 设置ntp时钟原的端口或IP地址ntp update-calendar 允许NTP定期更新calendarntp master 2 允许本机作为NTP协议的主时钟,精度级别2,供其它对等体同步用ntp server 202.112.7.150 在网络?#29616;?#23450;若干时钟源网站End

* 客户端:

conf tntp authentication-key 1 md5 cxzhzx 7ntp authenticatentp trusted-key 1ntp source vlan1ntp server 10.1.47.100endclip_image001

H3C NTP服务器相关配置

No Comments 网络技术 ,

配置NTP 服务器1. 组网需求

    router1 设置本地时钟作为ntp 主时钟,层数为2,router2 以router1 作为时间服务器,将其设为server 模式,自己为client 模式。

    2. 组网图

    3. 配置步骤

    (1) 配置router1

    # 进入系统视图。

    [h3c] system-view

    # 设置本地时钟作为ntp 主时钟,层数为2。

    [h3c] ntp-service refclock-master 2

    (2) 配置router2

    # 进入系统视图。

    [h3c] system-view

    # 设置router1 为时间服务器。

    [h3c] ntp-service unicast-server 1.0.1.11

    以上配置将router2 向router1 进行时间同步,同步前观察router2 的状态为:

    [h3c] display ntp-service status

    clock status: unsynchronized

    clock stratum: 16

    reference clock id: none

    nominal frequency: 99.8562 hz

    actual frequency: 99.8562 hz

    clock precision: 2^7

    clock offset: 0.0000 ms

    root delay : 0.00 ms

    root dispersion: 0.00 ms

    peer dispersion: 0.00 ms

    reference time: 00:00:00.000 utc jan 1 1900 (00000000.00000000)

    同步后观测router2 的状态为:

    [h3c] display ntp-service status

    clock status: synchronized

    clock stratum: 3

    reference clock id: 1.0.1.11

    nominal frequency: 250.0000 hz

    actual frequency: 249.9992 hz

    clock precision: 2^19

    clock offset: 198.7425 ms

    root delay : 27.47 ms

    root dispersion: 208.39 ms

    peer dispersion: 9.63 ms

    reference time: 17:03:32.022 utc thu apr 6 2006 (bf422ae4.05aea86c)

    此时router2 已经与router1 同步,层数比router1 大1,为3。

    观察router2 的sessions 情况,router2 与router1 建立了连?#21360;?/p>

30选5玩法