30选5玩法|福彩30选5开奖结果321|
 

标签:hsrp

配置基本HSRP

No Comments 网络技术 ,

配置基本HSRP
当主用路由器当掉以后备份路由器可以接管主用路由器的IP地址和MAC地址
回答
Router1:
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#interface FastEthernet 0/1
Router1(config-if)#ip address 172.22.1.3 255.255.255.0
Router1(config-if)#standby 1 ip 172.22.1.1
Router1(config-if)#standby 1 priority 120
Router1(config-if)#exit
Router1(config)#end
Router1#
Router2:
Router2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router2(config)#interface FastEthernet 1/0
Router2(config-if)#ip address 172.22.1.2 255.255.255.0
Router2(config-if)#standby 1 ip 172.22.1.1
Router2(config-if)#standby 1 priority 110
Router2(config-if)#exit
Router2(config)#end
Router2#
注释 由于HSRP虚拟出来的MAC地址跟组相关,所以可能会出现同一交换机收到多个相同的MAC地址?#37027;?#20917;,这时候就需要用standby 1 mac-address 0000.0c07.ad01 命令来人工指定一个MAC地址

使用HSRP 强占特性
提问 强制某个路由器启动后一直在组中处于主用状态
回答
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#interface FastEthernet 0/1
Router1(config-if)#standby 1 ip 172.22.1.1  
Router1(config-if)#standby 1 priority 120   
Router1(config-if)#standby 1 preempt    
Router1(config-if)#exit
Router1(config)#end
Router1#
Router2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router2(config)#interface FastEthernet 1/0
Router2(config-if)#standby 1 ip 172.22.1.1  
Router2(config-if)#standby 1 priority 110   
Router2(config-if)#standby 1 preempt      
Router2(config-if)#exit
Router2(config)#end
Router2#
注释 正常情况下当LAN端口up后就会发生强占,而此时可能网络还没有收敛,所以建议配置强占延迟时间,让路由器启动后过一?#38382;?#38388;再发起强占standby 1 preempt delay 60
22.3.  配置HSRP对接口问题追踪的支持
提问 当主用路由器的上联端口出现问题后主动切换到备用路由器
回答
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#interface FastEthernet0/1
Router1(config-if)#standby 1 ip 172.22.1.1
Router1(config-if)#standby 1 priority 120
Router1(config-if)#standby 1 preempt
Router1(config-if)#standby 1 track Serial0/0 20
Router1(config-if)#exit
Router1(config)#end
Router1#
从12.2(15)T后引入更多可追踪实例
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#track 11 interface Serial1/1 ip routing     
Router1(config-track)#exit                                   
Router1(config)#interface FastEthernet0/0
Router1(config-if)#standby 1 ip 172.22.1.1
Router1(config-if)#standby 1 priority 120 
Router1(config-if)#standby 1 preempt
Router1(config-if)#standby 1 track 11 decrement 50
Router1(config-if)#end
Router1#
注释 Router1#show track  
Track 11
  Interface Serial1/1 ip routing
  IP routing is Down (hw admin-down, ip disabled)
    1 change, last change 00:
  Tracked by:
    HSRP FastEthernet0/0 1
22.4.  HSRP负载均衡
提问 在两台或者多台HSRP路由器上实现流量的负载均衡
回答
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#interface FastEthernet0/1
Router1(config-if)#ip address 172.22.1.3 255.255.255.0
Router1(config-if)#standby 1 ip 172.22.1.1
Router1(config-if)#standby 1 priority 120
Router1(config-if)#standby 1 preempt
Router1(config-if)#standby 2 ip 172.22.1.2
Router1(config-if)#standby 2 priority 110
Router1(config-if)#standby 2 preempt
Router1(config-if)#exit
Router1(config)#end
Router1#
Router2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router2(config)#interface FastEthernet1/0
Router2(config-if)#ip address 172.22.1.4 255.255.255.0
Router2(config-if)#standby 1 ip 172.22.1.1
Router2(config-if)#standby 1 priority 110
Router2(config-if)#standby 1 preempt
Router2(config-if)#standby 2 ip 172.22.1.2
Router2(config-if)#standby 2 priority 120
Router2(config-if)#standby 2 preempt
Router2(config-if)#exit
Router2(config)#end
Router2#
注释 由于出现两个网关,所以需要在终端设备上分开配置各自的缺省网关。
22.5.  HSRP中ICMP重定向
提问 在HSRP中启用ICMP重定向
回答
Router2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router2(config)#interface FastEthernet 1/0
Router2(config-if)#no ip redirects          
Router2(config-if)#standby redirects disable
Router2(config-if)#exit
Router2(config)#end
Router2#
注释
22.6.  调整HSRP定时器
提问 调整备份路由器接管主用路由器所需时长
回答
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#interface FastEthernet0/1
Router1(config-if)#standby 1 ip 172.22.1.1
Router1(config-if)#standby 1 priority 120
Router1(config-if)#standby 1 preempt
Router1(config-if)#standby 1 timers 1 3
Router1(config-if)#exit
Router1(config)#end
Router1#
注释 缺省Hello包时长为3秒,10秒后会接管,如果主用路由器调整时长,整个组内的路由器都要调整为相同的时长。最短可以到达毫秒Router1(config-if)#standby 1 timers msec 100 msec 300
22.7.  在令牌环网络中使用HSRP
提问 在令牌环网络中配置HSRP
回答
如果只用IP协议配置同前面例子,如果还有其他协议,特别是使用了source-route bridging就用下面的配置方法
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#interface Tokenring0
Router1(config-if)#ip address 172.22.1.3
Router1(config-if)#standby ip 172.22.1.1
Router1(config-if)#standby use-bia
Router1(config-if)#standby priority 120
Router1(config-if)#standby preempt
Router1(config-if)#exit
Router1(config)#end
Router1#
Router2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router2(config)#interface Tokenring0
Router2(config-if)#ip address 172.22.1.2
Router2(config-if)#standby ip 172.22.1.1
Router2(config-if)#standby use-bia
Router2(config-if)#standby priority 110
Router2(config-if)#standby preempt
Router2(config-if)#exit
Router2(config)#end
Router2#
注释 由于令牌环网络会用到设备的MAC地址信息,所以如果HSRP用到虚拟MAC就会出问题,因此在配置中使用了burned-in address (BIA)来代替MAC来避免出现问题

配置HSRP 的SNMP支持
提问 启用HSRP的SNMP Traps
回答
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#snmp-server enable traps hsrp
Router1(config)#snmp-server host 172.25.1.1 ORATRAP
Router1(config)#end
Router1#
注释 无
22.9. 增加HSRP的安全性
提问 提高HSRP的安全
回答
组内设备使用相同的配置
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#interface FastEthernet 0/1
Router1(config-if)#standby 1 ip 172.22.1.1
Router1(config-if)#standby 1 priority 120
Router1(config-if)#standby 1 authentication NEOSHI
Router1(config-if)#exit
Router1(config)#end
Router1#
从12.3(2)T后支持MD5?#29992;?#23494;码
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#interface FastEthernet0/1                        
Router1(config-if)#standby 1 ip 10.1.1.1                         
Router1(config-if)#standby 1 priority 200                        
Router1(config-if)#standby 1 authentication md5 key-string OREILLY
Router1(config-if)#end
Router1#
为了防止其他路由器成为主用路由器,设置本路由器高优先级
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#interface FastEthernet 0/1
Router1(config-if)#standby 1 ip 172.22.1.1
Router1(config-if)#standby 1 priority 255
Router1(config-if)#exit
Router1(config)#end
Router1#
注释 无
22.10.  显示HSRP状态信息
提问 显示HSRP状态信息
回答
Router2#show standby
Router2#show standby FastEthernet 1/0
Router2#show standby brief
注释
22.11.  HSRP排错
提问 对HSRP进?#20449;?#38169;
回答
Router2#debug standby errors
Router2#debug standby events
Router2#debug standby packets
Router2#debug standby terse
注释
22.12.  启用HSRP 版本2
提问 部署HSRPv2
回答
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#interface FastEthernet0/1         
Router1(config-if)#standby version 2                 
Router1(config-if)#standby 4095 ip 10.1.1.1          
Router1(config-if)#standby 4095 timers msec 15 msec 50
Router1(config-if)#standby 4095 priority 200         
Router1(config-if)#standby 4095 preempt              
Router1(config-if)#end
Router1#
Router2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router2(config)#interface FastEthernet0/0
Router2(config-if)#standby version 2
Router2(config-if)#standby 4095 ip 10.1.1.1
Router2(config-if)#standby 4095 timers msec 15 msec 50
Router2(config-if)#standby 4095 priority 150
Router2(config-if)#standby 4095 preempt
Router2(config-if)#end
Router2#
注释 从12.3(4)T后开始支持HSRPv2,主要是扩展了可用组数,从v1的256个组到现在的4095个组,使用不同的MAC地址和组播地址,因此不能混用
22.13.  VRRP
提问 在思科路由器上启用VRRP
回答
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#interface FastEthernet0/1
Router1(config-if)#ip address 10.1.1.2 255.255.255.0
Router1(config-if)#vrrp 1 ip 10.1.1.1
Router1(config-if)#vrrp 1 preempt
Router1(config-if)#vrrp 1 priority 200
Router1(config-if)#end
Router1#
Router2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router2(config)#interface FastEthernet0/0
Router2(config-if)#ip address 10.1.1.3 255.255.255.0
Router2(config-if)#vrrp 1 ip 10.1.1.1
Router2(config-if)#vrrp 1 preempt
Router2(config-if)#vrrp 1 priority 150
Router2(config-if)#end
Router2#
注释 注意在鉴权的配置上如果思科和非思?#35774;备搭配可能会有问题。在配置定时器?#29616;?#33021;配?/SPAN>Hello间隔,可以在主路由器上配置,备份路由器可以通过配置vrrp 1 timers learn 命令来自动学习,可以为配置添?#29992;?#36848;,也支持Track
<!–[if !supportLists]–>22.14.       <!–[endif]–>GLBP
提问 配置GLBP来实现流量的自动负荷分担
回答
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#interface FastEthernet0/0
Router1(config-if)#ip address 172.22.1.3 255.255.255.0
Router1(config-if)#glbp 1 ip 172.22.1.1
Router1(config-if)#exit
Router1(config)#end
Router1#
Router2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router2(config)#interface FastEthernet0/0
Router2(config-if)#ip address 172.22.1.2 255.255.255.0
Router2(config-if)#glbp 1 ip 172.22.1.1
Router2(config-if)#exit
Router2(config)#end
Router2#
注释 GLBP通过组内设备轮回的相应虚拟MAC地址来实现自动的负荷分担,当然也可以使用其他的分担方式,比如权重等,这样不需要通过配置多HSRP组的方式实现了均衡,并且所有设备使用同一的网关地址

CCIE试验备考之冗余备份(HSRP)这是hello me的原创

No Comments CISCO

 

HRRP 热备份路由协议
多台路由器组成一个“热备份组?#20445;?#29992;来模拟为一个虚拟的路由器(拥有虚拟的IP 地址和虚拟的MAC地址),在一个备份组中,只有一台路由器作为活动路由器发送数据包,只有当活动路由器失效后,将选择一台备份路由器才能成为活动路由器转发数据包,但对于网络中的主机来?#25285;?#34394;拟路由器并没有发生任何改变。
HSRP有三?#27490;?#25773;包:
1) Hello包,hello消息通知其他路由器发?#21520;?#30001;器的HSRP优先级和状态信息,HSRP路由器,默认为每3秒钟发送一个hello消息;可以修改这个?#38382;?
2) Coup包,当一个备用路由器变为一个主动路由器时发送一个coup消息。
3) Resign包,当主动路由器要宕机或者当有优先级更高的路由器发送hello消息时,主动路由器发送一个resign消息。
HSRP状态类型:
1) Initial初始化,HSRP启动时的状态,HSRP还没有运行,一般是在改变配置或端口刚启动时进入该状态。
2) Learn学习状态,路由器已经得到了虚拟IP地址,但是它既不是活动路由器也不是备份路由器。它一直监听从活动路由器和备份路由器发来的HELLO报文。
3) Listen监听状态,路由器正在监听hello消息。
4) Speak对话状态,在该状态下,路由器定期发送HELLO报文,并?#19968;?#26497;参加活动路由器或等待路由器的竞选。
5) Standby被动状态,当主动路由器失效时路由器准备接包传输功能。
6) Active活动状态,路由器执行包传输功能。
HSRP路由器体系
1)活动路由器,负责转发发送到虚拟路由器的数据。它通过发送HELLO消息(基于UDP,端口号为1985的广播)来通告它的活跃状态
2)备份路由器,监视HSRP组中的运行状态,并?#20197;?#24403;前活跃路由器不可用时,迅速承担起负责数据转发的任务。备份路由器也发送HELLO消息来通告组中其他的路由器它备份路由器的?#24039;?
3) 虚拟路由器,向最终的用户来代表一台能?#20013;?#24037;作的路由器设备。它有自己的MAC和IP地址。但是实际上它是不用来转发数据包,它的作用仅仅是代表一台可用的路由设备。
虚拟MAC地址组成:
Vendor ID:厂商ID,构成MAC地址的头3个字节
HSRP代码:表示该地址是HSRP虚拟路由器的。XX07.acxx
组ID:最后一个字节是组ID,由组号组成
如我们可以通过命令:show ip arp命令查看
           0000.0007.ac01
4)其他路由器,?#24067;?#21548;HELLO消息,但是不作应答,这样它就不会在备份组有身份的概念,同时它也不参与发送到虚拟路由器的数据包,但是?#25925;?#36716;发其他路由器发来的数据包。
选举过程
1) 默认情况下,优先级为100,这时MAC地址最小的成为活动路由器
2) 当活动路由器失效后,备份路由器替代成为活动路由器,当活动和备份路由器都失效后,其他路由器将参与活动和备份路由器的选举工作
a) 优先级高的成为活动路由器,默认为100,取值为0~255
b) 优先级别相同时,接口IP地址高的将成为活动路由器

HSRP?#37027;?#21344;Preempt技术
HRSP技术能够保证优先级高的路由器失效?#25351;?#21518;总能处于活动状态。活动路由器失效后,优先级最高的备用路由器处于活动状态,如果没有使用preempt技术,则当活动路由器?#25351;?#21518;,只能处于备用状态,先前的备用服务器代替其?#24039;?#22788;于活动状态,直到下一次选举发生。
HSRP的端口跟踪track技术
如果所监测的端口出现故障,则也可以进行路由器?#37027;?#25442;。如果主路由器上有多条线路被跟踪,则当一条线路出现故障时,就会切换到备份路由器上,即使其他都线路正常工作,直到主路由器该线路正常工作,才能重新切换回来。接口跟踪使得能够根据HSRP组路由器的接口是否可用,来自动调整该路由器的优先级。当被跟踪的接口不可用时,路由器的HSRP优先级将?#26723;汀SRP跟踪特性确保当HSRP活跃路由器的重要入站接口不可用时,该路由器不再是活跃路由器。
多组HSRP
为了方便负载均衡,同一台路由器可以是同一个网段或VLAN中多个HSRP备用组的成员。配置多个备用组可进一步提高冗余性,在网络中均衡负载,提高冗余路由器的使用?#30465;?#36335;由器在为一个HSRP组转发通信流的同时,可以在另一个HSRP组中处于备用或监听状态。每个备用组都模拟一个虚拟路由器。在VLAN或接口上,最多可以有255个备用组
       如下图,路由器A和路由器B都是HSRP组1和2的成?#20445;?#28982;而,路由器A是HSRP组1的活跃路由器和HSRP组2的备用路由器;而路由器B是HSRP组2的活跃路由器和HSRP组1的备用路由器。

配置过程:
默认配置
特性          默认配置
——————————–
HSRP组                    未定义
备用组编号             0
备用组MAC地址             0000.0c07.acXX, XX是HSRP组号
优先级                     100
延时                     0(没有延时)
跟踪端口的优先级 10
HELLO时间             3秒
HOLD时间             10秒
配置要求:
1. HSRP最多可以配置32个VLAN或路由接口
2. 配置接口必须是3层接口
路由接口:接口使用no switchport,并且配置ip地址
SVI(交换虚拟接口):使用命令interface vlan vlan号
3层以太网通道(EtherChannel)
3. 所有3层接口都必须配置IP地址
配置HSRP
1) 进入全局模式       configure terminal
2) 进入接口模式       interface 接口
3) 使能HSRP,指定热备份组的组号和虚拟IP 地址
        standby 组号 ip IP地址
        组号:取值为0-255,如果是一个备用组,可以不输入组号,默认为0
        ip地址:是虚拟的Ip地址,不能为接口上的地址
4) 指定备用组的优先级别
        standby 组号 priority 优先级别
        优先级:取值为1-255,默认为100,数值越大级别越高
5) 指定抢占模式,当活动路由器失效后,备份路由器马上替换为活动路由器,不需要时间等待(hold time)
         standby 组号 preempt [delay 秒数]
      d      elay:取值为0-3600(1小时)
6) 设置端口跟踪(可选)
        standby 组号 track 端口号 ?#26723;?#30340;优先级别
        ?#26723;?#30340;优先级别:默认为10
7) 人工指定虚拟mac地址(可选)
        standby 组号 mac mac地址
8) 使用实际接口的mac地址(可选,只有25系列路由器使用)
        standby 组号 use-bia
9) 配置?#29616;ぃ?#21487;选)
        standby 组号 authentication mode text 密码
        密码:密码是明文,默认为cisco
        注意:对于IOS12.3以上的版本中,HSRP支持MD5的?#29616;ぃ?#20855;体配置命令为
        standby 组号 authentication md5 key-string 密码
10)配置HSRP时间(可选)
        standby 组号 timers hello秒数 hold秒数
        hello秒数:取值为1-255,默认为3秒
        hold秒数:取值为1-255,默认为10秒,hold time= 3*hello time
检验和调试:
检验:
        show standby [接口 [组]][active|init|listen|standby][brief]
如:
        show standby Ethernet0 init brief
调试:
        debug standby:显示所有的HSRP错误、事件和数据包
        debug standby terse :显示除hello和通告以外的所有HSRP错误、事件和数据包
        debug standby events detail:显示HSRP事件
        debug standby error:显示HSRP错误
        debug standby packets [advertise|coup|hello|resign][detail]
案例:
sw1(config)#int vlan 10
sw1(config-if)#ip address 192.168.1.1 255.255.255.0
sw1(config-if)#standby 1 ip 192.168.1.254
sw1(config-if)#standby 1 priority 110
—————————————————–
sw2(config)#int vlan 10
sw2(config-if)#ip address 192.168.1.2 255.255.255.0
sw2(config-if)#standby 1 ip 192.168.1.254
sw2(config-if)#standby 1 priority 100
——————————————————
SW1#show standby
Vlan10 – Group 1
      State is Active
        2 state changes, last state change 00:02:38
      Virtual IP address is 192.168.1.254
      Active virtual MAC address is 0000.0c07.ac01
        Local virtual MAC address is 0000.0c07.ac01 (v1 default)
      Hello time 3 sec, hold time 10 sec
        Next hello sent in 0.124 secs
      Preemption enabled
      Active router is local
      Standby router is 192.168.1.2, priority 100 (expires in 7.992 sec)
      Priority 110 (configured 110)
      IP redundancy name is "hsrp-Vl10-1" (default)
———————————————————
SW2#show standy
Vlan10 – Group 1
      State is Standby
        1 state change, last state change 00:02:32
      Virtual IP address is 192.168.1.254
      Active virtual MAC address is 0000.0c07.ac01
        Local virtual MAC address is 0000.0c07.ac01 (v1 default)
      Hello time 3 sec, hold time 10 sec
        Next hello sent in 0.328 secs
      Preemption enabled
      Active router is 192.168.1.1, priority 110 (expires in 9.456 sec)
      Standby router is local
      Priority 100 (default 100)
      IP redundancy name is "hsrp-Vl10-1" (default)
SW1#show stan brie
                         P indicates configured to preempt.
                         |
Interface       Grp Prio P State        Active              Standby             Virtual IP     
V10               1       110      P Active       local               192.168.1.2         192.168.1.254    
多组HSRP备用组

Router A Configuration
Switch# configure terminal
Switch(config)# interface gigabitethernet0/1
Switch(config-if)# no switchport
Switch(config-if)# ip address 10.0.0.1 255.255.255.0
Switch(config-if)# standby 1 ip 10.0.0.3
Switch(config-if)# standby 1 priority 110
Switch(config-if)# standby 1 preempt
Switch(config-if)# standby 2 ip 10.0.0.4
Switch(config-if)# standby 2 preempt
Switch(config-if)# end
Router B Configuration
Switch# configure terminal
Switch(config)# interface gigabitethernet0/1
Switch(config-if)# no switchport
Switch(config-if)# ip address 10.0.0.2 255.255.255.0
Switch(config-if)# standby 1 ip 10.0.0.3
Switch(config-if)# standby 1 preempt
Switch(config-if)# standby 2 ip 10.0.0.4
Switch(config-if)# standby 2 priority 110
Switch(config-if)# standby 2 preempt
Switch(config-if)# end
案例:
CCIE-LAB(V160)
题目要求:
Configure HSRP on R3 and R4 for hosts on VLAN A:Carefully read the requirements:
There are 10 hosts on VLAN A。5 Windows PC’s and 5 Unix workstations
The Windows PC’s are configured to use 160.YY.10.50 as their default gateway
The UNIX workstations are configured to use 160.YY.10.100 as their default gateway
R3 is the preferred router for Windows users.
R4 is the prefered router for Unix users.
If the frame relay connection on R3 goes down,then R4 becomes the preferred router for all users。
If the frame relay connection on R4 goes down,then R3 becomes the preferred router for all users。
Once either R3 or R4 recover from a failure then the network must operate as outined
above,I.e Each router must resume their original role。

配置:
R3
       config termi
       interface f0/0
       standby 1 ip 160.11.10.50
       standby 1 priority 110
       standby 1 track s0/0      20
       standby 1 preempt
       standby 2 ip 160.11.10.100
       standby 2 preempt
R4
       config termi
       interface f0/0
       standby 1 ip 160.11.10.50
       standby 1 preempt
       standby 2 ip 160.11.10.100
       standby 2 priority 110
       standby 2 track s0/0      20
       standby 2 preempt
Trunk链路上的HSRP
此项功能能通过在子网和VLAN间提供负载均衡和冗余能力提高整个网络的韧性。我们可以实现通过两个路由器来实现在干道上的互为活跃/备份路由器。我们只要设置一下他们在HSRP中的优先级就可以实现。
配置步骤:
1. 定义封装类型和vlan
如:
interface f0/0.10
encapaulation isl 10
interface f0/0.20
encapaulation isl 20
            2.分配IP地址
              如:
interface f0/0.10
ip address 10.10.10.2 255.255.255.0
interface f0/0.20
ip address 10.10.20.2 255.255.255.0
            3.启动HSRP
              如:
inteface f0/0.10
standby 1 ip 10.10.10.254
standby 1 priority 105
standby 1 preempt
interface f0/0.20
standby 2 ip 10.10.20.254
standby 2 priority 90
新:HSRP2
在CISCO IOS 12.3以上的版本中,HSRP支持V2的版本。HSRP V2和HSRP V1命令上没有什么不同,只是HSRP V2所支持的组号进行了扩展,HSRP V1只支持0-255个组,而HSRP V2可以支持0-4095个组,主要是应用在它可以支?#21046;?#37197;在子接口上的VLAN号(扩展的VLAN可以支持到4094个)
HSRP V1和HSRP V2不能同时在一个接口上启用,但是在同一台路由器上的不同接口上,可以应用不同版本的HSRP
配置过程:
1) 进入全局模式       configure terminal
2) 进入接口模式       interface 接口
3) 启用HSRP版本2
      standby version 2
4) 配置HSRP
      standby 组号 ip ip地址
      组号:取值?#27573;?-4095
案例:
RouterA#configure terminal
RouterA(config)#interface f0/0         
RouterA(config-if)#standby version 2                  
RouterA(config-if)#standby 4095 ip 10.1.1.1           
RouterA(config-if)#standby 4095 timers msec 15 msec 50
RouterA(config-if)#standby 4095 priority 200          
RouterA(config-if)#standby 4095 preempt               
———————————————————–
RouterB#configure terminal
RouterB(config)#interface f0/0         
RouterB(config-if)#standby version 2                  
RouterB(config-if)#standby 4095 ip 10.1.1.1           
RouterB(config-if)#standby 4095 timers msec 15 msec 50
RouterB(config-if)#standby 4095 preempt               
————————————————————
RouterA#show standby
FastEthernet0/0 – Group 4095 (version 2)
      State is Active
        2 state changes, last state change 00:11:47
      Virtual IP address is 10.1.1.1
      Active virtual MAC address is 0000.0c9f.ffff
        Local virtual MAC address is 0000.0c9f.ffff (v2 default)
      Hello time 15 msec, hold time 50 msec
        Next hello sent in 0.007 secs
      Preemption enabled
      Active router is local
      Standby router is 10.1.1.3, priority 100 (expires in 0.030 sec)
      Priority 200 (configured 200)
      IP redundancy name is "hsrp-Fa0/0-4095" (default)

hsrp 和 vrrp 比较

No Comments 网络技术 ,

在功能上,VRRP和HSRP非常相似,但是就安全而言,VRRP对HSRP的一个主要优势:它允许参与VRRP组的设备间建立?#29616;?#26426;制.并且,不像HSRP那样要求虚拟路由器不能是其中一个路由器的ip地址,但是VRRP允许这种情况发生(如果”拥?#23567;?#34394;拟路由器地址的路由器被建立并且正在运行,那?#20174;?#35813;总是由这个虚拟路由器管理—等价于HSRP中的活动路由器),但是为了确保万一失效发生的时候终端主机不必重新学习MAC地址,它指定使 用的MAC地址00-00-5e-00-01-VRID,这里的VRID是虚拟路由器的ID(等价于一个HSRP的组标识符).
2.另外一个不同是VRRP不使用HSRP中的政变或者一个等价消息,VRRP的状态机比HSRP的要简单,HSRP有6个状态(初始(Initial)状态,学习(Learn)状态,监听(Listen)状态,对话(Speak)状态,备份(Standby)状态,活动(Active)状态)和8个事件, VRRP只有3个状态(初始状态(Initialize)、主状态(Master)、备份状态(Backup))和5个事件.

3. HSRP有三?#30452;?#25991;,而且有三种状态可以发送报文       呼叫(Hello)报文       告辞(Resign)报文       突变(Coup)报文       

VRRP有一?#30452;?#25991;
VRRP广播报文:由主路由器定时发出来通告它的存在,使用这些报文可以检测虚拟路由器各种?#38382;?#36824;可以用于主路由器的选举。

4. HSRP将报文?#24615;?#22312;UDP报文上,而VRRP?#24615;?#22312;TCP报文上(HSRP 使用UDP 1985端口,向组播地址224.0.0.2 发送hello消息。) 
5.VRRP的安全:VRRP协议包括三种主要的?#29616;?#26041;式:无?#29616;?简单的明文密码和使用 MD5 HMAC ip?#29616;さ那咳现? 
强?#29616;?#26041;法使用IP?#29616;?#22836;(AH)协议.AH是与用在IPSEC中相同的协议,AH为?#29616;RRP分组中的内容和分组头提供了一个方法. MD5 HMAC 的使用表明使用一个共享的密钥用于产生hash值.路由器发送一个VRRP分组产生MD5 hash值,并将它置于要发送的通告中,在接收时,接受方使用相同的密钥和MD5值,重新计算分组内容和分组头的hash值,如果结果相同,这个消息就是真正来自于一个可信?#26723;?#20027;机,如果不相同,它必须丢弃,这可以防止攻击者通过访问LAN而发出能影响选择过程的通告消息或者其他一些方法中断网络. 
另外,VRRP包括一个保护VRRP分组不会被另外一个远程网络添加内容的机制(设置TTL值=255,并在接受时检查),这限制了可以进行本地攻击的大部分缺陷.而另一方面,HSRP在它的消息中使用的TTL值是1. 
6.VRRP的崩溃间隔时间:3*通告间隔+时滞时间(skew-time)

HSRP 详解

No Comments CISCO

默?#29616;?/strong>

HSRP groups                                     None configured
Standby group number                      0
Standby MAC address     System assigned as: 0000.0c07.acXX, where XX is the HSRP   group number
Standby priority                                 100
Standby delay                                    0 (no delay)
Standby track interface priority          10
Standby hello time                              3 seconds
Standby holdtime                               10 seconds

Step 1 configure terminal

Enter global configuration mode.
Step 2 interface interface-id

Enter interface configuration mode, and enter the Layer 3 interface on
which you want to enable HSRP.
Step 3   standby [group-number] ip [ip-address[secondary]]
Create (or enable) the HSRP group using its number and virtual IP
address.
? (Optional) group-number—The group number on the interface for
which HSRP is being enabled. The range is 0 to 255; the default is 0.
If there is only one HSRP group, you do not need to enter a group
number.
? (Optional on all but one interface) ip-address—The virtual IP address
of the hot standby router interface. You must enter the virtual IP
address for at least one of the interfaces; it can be learned on the other
interfaces.
? (Optional) secondary—The IP address is a secondary hot standby
router interface. If neither router is designated as a secondary or
standby router and no priorities are set, the primary IP addresses are
compared and the higher IP address is the active router, with the next
highest as the standby router.
Step 4 end

Return to privileged EXEC mode.

例:

Switch# configure terminal
Switch(config)# interface gigabitethernet0/1
Switch(config-if)# no switchport
Switch(config-if)# standby 1 ip
Switch(config-if)# end
Switch# show standby

Displaying HSRP Configurations
From privileged EXEC mode, use this command to display HSRP settings:
show standby [interface-id [group]] [brief] [detail]

Configuring HSRP Authentication and Timers

Step 1 configure terminal

Enter global configuration mode.
Step 2 interface interface-id

Enter interface configuration mode, and enter the HSRP
interface on which you want to set authentication.
Step 3 standby [group-number] authentication string

(Optional) authentication string—Enter a string to be carried in
all HSRP messages. The authentication string can be up to eight
characters in length; the default string is cisco.
(Optional) group-number—The group number to which the
command applies.
Step 4 standby [group-number] timers hellotime holdtime
(Optional) Configure the time between hello packets and the
time before other routers declare the active router to be down.
? group-number—The group number to which the command
applies.
? hellotime—The hello interval in seconds. The range is from
1 to 255; the default is 3 seconds.
? holdtime—The time in seconds before the active or standby
router is declared to be down. The range is from 1 to 255;
the default is 10 seconds.
Step 5 end Return to privileged EXEC mode.

Configuring HSRP Priority

Step 1 configure terminal

Enter global configuration mode.
Step 2 interface interface-id

Enter interface configuration mode, and enter the HSRP interface on which you
want to set priority.
Step 3 standby [group-number] priority priority [preempt [delay delay]]

Set a priority value used in choosing the active router. The range is 1 to 255;
the default priority is 100. The highest number represents the highest priority.
? (Optional) group-number—The group number to which the command
applies.
? (Optional) preempt—Select so that when the local router has a higher
priority than the active router, it assumes control as the active router.
? (Optional) delay—Set to cause the local router to postpone taking over the
active role for the shown number of seconds. The range is 0 to
3600(1 hour); the default is 0 (no delay before taking over).
Use the no form of the command to restore the default values.

Step 4 standby [group-number] [priority priority] preempt [delay delay]

Configure the router to preempt, which means that when the local router has
a higher priority than the active router, it assumes control as the active router.
? (Optional) group-number—The group number to which the command
applies.
? (Optional) priority—Enter to set or change the group priority. The range
is 1 to 255; the default is 100.
? (Optional) delay—Set to cause the local router to postpone taking over the
active role for the number of seconds shown. The range is 0 to 3600
(1 hour); the default is 0 (no delay before taking over).
Use the no form of the command to restore the default values.
Step 5 standby [group-number] track type number [interface-priority]

Configure an interface to track other interfaces so that if one of the other
interfaces goes down, the device’s Hot Standby priority is lowered.
? (Optional) group-number—The group number to which the command
applies.
? type—Enter the interface type (combined with interface number) that is
tracked.
? number—Enter the interface number (combined with interface type) that is
tracked.
? (Optional) interface-priority—Enter the amount by which the hot standby
priority for the router is decremented or incremented when the interface
goes down or comes back up. The default value is 10.
Step 6 end Return to privileged EXEC mode.

HSRP多组负载均衡配置

No Comments CISCO ,

R1#conf t
R1(config)#int E0
R1(config-if)#standby 1 ip add 192.168.10.254     //激活HSRP,设置R1连接的内网的虚拟网关
R1(config-if)#standby 1 priority 120 //用于设定端口的HSRP优先级,具有最高备份优先级的HSRP成员将成为激活路由器
R1(config-if)#standby 1 preempt   //表明当本地路由器的备份优先级超过当前激活路由器时,它就将接管控制权,成为激活路由器
R1(config-if)#standby 1 track serial 0 40 //用于设置允许路由器端口根据另一端口的可用性而修改自己的HSRP优先级?#25285;?#21363;监视端口状态)
R1(config-if)#standby use-bia     //启用HSRP多组均衡负载
R1(config-if)#standby 2 ip add 192.168.20.254
R1(config-if)#standby 2 prempt

R3#conf t
R3(config)#int E0
R3(config-if)#standby 2 ip add 192.168.20.254     //激活HSRP,设置R3连接的内网的虚拟网关
R3(config-if)#standby 2 priority 120 //用于设定端口的HSRP优先级,具有最高备份优先级的HSRP成员将成为激活路由器
R3(config-if)#standby 2 preempt   //表明当本地路由器的备份优先级超过当前激活路由器时,它就将接管控制权,成为激活路由器
R3(config-if)#standby 2 track serial 0 40   //用于设置允许路由器端口根据另一端口的可用性而修改自己的HSRP优先级值
R3(config-if)#standby use-bia    //启用HSRP多组均衡负载
R3(config-if)#standby 1 ip add 192.168.20.254
R3(config-if)#standby 1 prempt

HSRP+负载均衡 行业思科解决方案!

项?#32771;?#20171;——
今天我要向大家介绍的是广东省某电力公司采用思科的解决方案组建超级?#38047;?#32593;。主要是通过双4507R来实现双机热备和负载匀衡。接入交换机是CISCO-2960-24TC-L
设备简介——
CISCO-4507R是一款中档三层路由交换机,有七个插槽,其中第一、二个插槽是用来插引擎滴,千万不要弄插哦,不然它会痛的。剩下五个插槽全是业务插槽,千兆光口板,千兆电口板等业务板可?#36816;?#20320;插了。
CISCO-2960-24TC-L是一款二层接入交换机,2960系列有多款交换机,24口、48口、百兆、千兆、SFP模块等,产品线相当丰富,满足中小型企?#26723;?#25509;入需求。
拓?#24605;?#20171;——
出口是CISCO-2821路由器,这是思科在2006年推出的ISR系列路由器中28系列路由器的中档配置,满足企业分支构多?#27490;?#22495;网接入方式,E1,T1,ADSL,FR,宽带接入等。
从网络的安全性能考虑,我们给客户推荐了天融信的防火墙作透明。
通过防火墙下联两台CISCO-4507R做双机热备,同时实现负载匀衡。
接入交换机通过光纤冗余接入CISCO-4507R。
实施步骤——
一 完全拓扑连接
二 设备加电、完成设备自检
三 配置路由器
配置外网口IP,网关,默认路由,内网各VLAN 网段回执路由
四 配置防火墙
将防火墙配置成透明模式,实现对包的过滤
五 配置核心交换机
两台设备配置HSRP,所以两台4507R的配置?#36127;?#23436;全一样。
创建CHANNEL,将端口加入CHANNEL
创建VLAN
给各VLAN 接口配置IP,配置STANDBY的IP,以及STANDBY优先级等?#38382;?
(在这里有一点提醒大家,如果要在HSRP基础上实现负载匀衡,那么两台交换机的配置?#24039;?#26377;不同的。HSRP是一主一次,只有一台设备转发包,如果要实现负载匀衡,
我们就得让两台设备都工作起来。可以通过设备STANDBY的优先级来实现。具体的配置在后面的实例中详谈。)
配置默认路由指向路由器的内网口IP
配置TRUNK口,封装协议
配置ACL策略
六 配置接入交换机
配置管理IP
配置VLAN
配置TRUNK口
配置文档——
在这里只贴出4507R的配置
C4507R-S#sh run
Building configuration…
Current configuration : 8888 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service compress-config
!
hostname C4507R-S
!
boot-start-marker
boot-end-marker
!
!
redundancy
mode sso
enable secret 5 $1$mDs3$W6xmvv0ZxWxih3VH.7/ES0   ciscoh3c
enable password cisco
!
no aaa new-model
qos
vtp mode transparent
ip subnet-zero
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
power redundancy-mode redundant
!
!
!
vlan internal allocation policy ascending
!
vlan 9,37-38,40-43,60 -----------(创建VLAN)
!
interface Port-channel1-----------(创建CHENNEL)
switchport
switchport trunk encapsulation dot1q
!
interface GigabitEthernet1/1----------(将端口加入CHENNEL)
switchport trunk encapsulation dot1q
channel-group 1 mode on
!
interface GigabitEthernet1/2----------(将端口加入CHENNEL)
switchport trunk encapsulation dot1q
channel-group 1 mode on
!
interface GigabitEthernet3/5
switchport trunk encapsulation dot1q
switchport mode trunk
ip access-group 100 in
!………………..--------------(将端口配置成TRUNK,并封装)
…………………--------------(将端口配置成TRUNK,并封装)
interface GigabitEthernet3/48--------------(将端口配置成TRUNK,并封装)
switchport trunk encapsulation dot1q
channel-group 1 mode on
!
interface GigabitEthernet5/1--------------(将端口配置成TRUNK,并封装)
switchport trunk encapsulation dot1q
switchport mode trunk
ip access-group 100 in
……..
……..
……..
interface GigabitEthernet5/18
switchport mode trunk--------------(将端口配置成TRUNK,并封装)
!
interface Vlan1--------------(配置VLAN 接口)
ip address 172.16.1.252 255.255.255.0--------------(配置VLAN 接口IP)
standby 1 ip 172.16.1.254--------------(配置VLAN 接口STANDBY IP,这才是数据转发用的实际IP)
standby 1 preempt--------------(配置HSRP允许抢占优先)
standby 1 priority 110-----------------------(HSRP优先级如何不配置默认是100)
!
interface Vlan9
ip address 172.16.9.252 255.255.255.0
standby 9 ip 172.16.9.254
standby 9 preempt-----------------------(HSRP优先级如何不配置默认是100,因为要实现负载匀衡这个VLAN默认优先级)
!…….. ××××××××××××××注意看,VLAN1优先级110,所?#36816;?#20250;是VLAN1的STANDBY1组的主,另一台是备!!!!!!!!
                                             VLAN9优先级100,另一台是110,所以这台是备,另一台是主,由此实现负载匀衡!!!!
………
interface Vlan60
ip address 192.168.60.252 255.255.255.0
standby 60 ip 192.168.60.254
standby 60 preempt
!
ip route 0.0.0.0 0.0.0.0 192.168.60.1--------------(配置默认路由)
no ip http server
!
!--------------(配置ACL策略)
access-list 100 permit tcp 172.16.43.0 0.0.0.255 host 172.16.9.16 eq www
access-list 100 permit tcp 172.16.43.0 0.0.0.255 host 172.16.9.17 eq www
access-list 100 permit tcp 172.16.43.0 0.0.0.255 host 172.16.9.18 eq www
access-list 100 permit ip 172.16.37.0 0.0.0.255 172.16.40.192 0.0.0.15
access-list 100 permit ip 172.16.38.0 0.0.0.255 172.16.40.192 0.0.0.15
access-list 100 permit ip 172.16.41.0 0.0.0.255 172.16.40.192 0.0.0.15
access-list 100 permit ip 172.16.42.0 0.0.0.255 172.16.40.192 0.0.0.15
access-list 100 deny ip 172.16.37.0 0.0.0.255 172.16.40.0 0.0.0.255
access-list 100 deny ip 172.16.37.0 0.0.0.255 172.16.41.0 0.0.0.255
access-list 100 deny ip 172.16.37.0 0.0.0.255 172.16.42.0 0.0.0.255
access-list 100 deny ip 172.16.38.0 0.0.0.255 172.16.37.0 0.0.0.255
access-list 100 deny ip 172.16.38.0 0.0.0.255 172.16.40.0 0.0.0.255
access-list 100 deny ip 172.16.38.0 0.0.0.255 172.16.41.0 0.0.0.255
access-list 100 deny ip 172.16.38.0 0.0.0.255 172.16.42.0 0.0.0.255
access-list 100 deny ip 172.16.41.0 0.0.0.255 172.16.40.0 0.0.0.255
access-list 100 deny ip 172.16.41.0 0.0.0.255 172.16.42.0 0.0.0.255
access-list 100 deny ip 172.16.42.0 0.0.0.255 172.16.40.0 0.0.0.255
access-list 100 deny ip 172.16.43.0 0.0.0.255 192.168.60.0 0.0.0.255
access-list 100 deny ip 172.16.43.0 0.0.0.255 172.16.9.0 0.0.0.255
access-list 100 permit ip any any
!
!
!
line con 0
stopbits 1
line vty 0 4--------------(配置VTY接口)
password cisco
login
line vty 5 15
no login
!
!
end

HSRP协议原理和配置案例

No Comments CISCO ,

一、 HSRP协议概述
实现HSRP的条件是系统中有多台路由器,它们组成一个“热等待组?#20445;?#36825;个组形成一个虚拟路由器。在?#25105;?#26102;刻,一个组内只有一个路由器是活动的,并由它来转发数据包,如果活动路由器发生了故障,将选择一个等待路由器来替代活动路由器,但是在本网络内的主机看来,虚拟路由器没有改变。所以主机仍然保持连接,没有受到故障的影响,这样就较好地解决了路由器切换的问题。
为了减少网络的数据流量,在设置完活动路由器和等待路由器之后,只有活动路由器和等待路由器定时发送HSRP报文。如果活动路由器失效,等待路由器将接管成为活动路由器。如果等待路由器失效或者变成了活动路由器,将由另外的路由器被选为等待路由器。
在实际的一个特定的?#38047;?#32593;中,可能有多个热等待组并存或重叠。每个热等待组模仿一个虚拟路由器工作,它有一个Well-known-MAC地址和一个IP地址。该IP地址、组内路由器的接口地址、主机在同一个子网内,但是不能一样。当在一个?#38047;?#32593;上有多个热等待组存在时,把主机分布到不同的热等待组,可以使负载得到分担。
二、HSRP协议数据包格式
在热等待组内,路由器定时以不同类型的数据报文广播状态信息。该协议运?#24615;赨DP之上,端口号为1985,目的地址为多播地址224.0.0.2,TTL标记为1。数据包的源地址为发送方路由器的实际IP地址,而不是虚拟地址,这样可以用来标记不同的路由器。UDP的格式如图1所示。

clip_image001

clip_image002

版本: 指示HSPR的版本信息。
操作码: 用来描述数据包中报文的类型,可能的值为0、1和2,如表1所示。
状态: 描述发出该报文的路由器的当前状态。在一个热等待组内的所有路由器都运行着这样的状态机,有以下6种状态,见表2。
呼叫时间: 只在呼叫报文中有意义,表示路由器定时发送呼叫报文的间隔时间,以秒为单位。如果该?#38382;?#27809;?#24615;?#36335;由器上配置,它可能要从活动路由器上学习获得。如果没有配置也没有学习,那么建议使用缺省值3。
保持时间: 只在呼叫报文中有意义,被接?#31456;?#30001;器用来判断该呼叫报文是否合法,单位为秒,其值至少是呼叫时间的3倍。如果该?#38382;?#27809;有配置,也同样可以从活动路由器上学习。活动路由器不能从等待路由器学习呼叫时间和保持时间,它只能继续使用从先前的活动路由器学习来的该值。建议的缺省值为10。
优先级: 该?#38382;?#29992;来选择活动和等待路由器,2个具有不同优先级的路由器,优先级高的将成为活动路由器。2个具有相同优先级的路由器,IP地址高的将成为活动路由器。
组: 用来标记路由器所在的热等待组。对令牌环类型的网络,合法的值是0、1和2,对于其他类型的网络,合法值是0~255。
?#29616;?#30721;: 包括8个明文的?#22336;?#20316;为密码,如果没有配置,缺省值为0×63 0×69 0×73 0×63 0×6F 0×00 0×00 0×00。
虚拟IP地址: 4个8位组,用来指定本热等待组的虚拟IP地址,它可以是从活动路由器的呼叫报文中学习来的。如果没有配置该地址,并且呼叫报文是需要认识的,那么只能通过活动路由器学习。
—- 在配置路由器或路由交换模块(Route Switch Module,RSM)时需要为上述字段?#25345;怠?
三、 HSRP中路由器的状态及状态转换
在热等待组中,每个路由器运行着一个简单的状态机,通过当前的状态和事件的触发,而转换成不同的状态。其中包括以下状态。
1.初始状态 HSRP启动时的状态,HSRP还没有运行,一般是在改变配置或端口刚刚启动时进入该状态。
2.学习状态 在该状态下,路由器还没有决定虚拟IP地址,也没有看到?#29616;?#30340;、来自活动路由器的HELLO报文。路由器仍在等待活动路由器发来的HELLO报文。
3.监听状态 路由器已经得到了虚拟IP地址,但是它既不是活动路由器也不是等待路由器。它一直监听从活动路由器和等待路由器发来的HELLO报文。
4.说话状态 在该状态下,路由器定期发送HELLO报文,并?#19968;?#26497;参加活动路由器或等待路由器的竞选。
5.等待状态 处于该状态的路由器是下一个候选的活动路由器,它定时发送HELLO报文。
6.活动状态 处于活动状态的路由器承担转发数据包的任务,这些数据包是发给该组的虚拟MAC地址的。它定时发出HELLO报文。
另外,每一个路由器都有3个计时器,即活动计时器、等待计时器和呼叫计时器。
状态的变化都是由事件引起的,不同的事件作用于不同的状态在就会产生不同的动作,如启动计时器、发报文等。
四、HSRP的配置实例
某校园网规模比较大,上网的主机相对比较多,共分配有16个C类地址。为了保证数据安全和广播风暴,提高网络性能,将校园网划分成60个子网。在网络中心采用Cisco系统公司的Catalyst 5509作为中心交换机,并且带有RSM作为VLAN间的路由器,另外使用一个Cisco 7000系列的路由器和RSM。它们都支持VLAN以及VLAN上的HSRP。如图2所示。

clip_image003

在每一个虚拟?#38047;?#32593;内都有一个HSRP组,从逻辑上讲,Cisco 7010和Cisco 5509的RSM在每个虚拟?#38047;?#32593;上都有?#38047;?#32593;接口,并且都配置有IP地址,同时配置一个虚拟地址,该地址作为在该虚拟?#38047;?#32593;内所有主机的网关。下面以VLAN 9为例,RSM中VLAN 9的配置如下:
—- interface Vlan9
—- description surportcenter
—- ip address 202.120.95.66 255.255.255.224
该路由器在该VLAN9上的接口的IP地址以及掩码
no ip redirects
no ip directed-broadcast
no ip route-cache cef
standby 9 timers 3 250
定义热等待组号为9,每3秒交换一次hello信息,250没有收到hello信息就开切换
standby 150 priority 110
定义路由器的权?#25285;?#20540;越大,成为活动路由器的希望越大
standby 9 preempt
Enable该组的HSRP抢占功能,谁的权值大就可以立即成为活动路由器
standby 9 ip 202.120.95.65
该组的虚拟IP地址,作为该VLAN中主机的网关地址
Cisco 7010路由器中接口的配置如下:
interface FastEthernet0/0.9
description surportcenter
ip address 202.120.95.67 255.255.255.224
cisco7010在VLAN9上的接口的IP地址以及掩码,该地址和RSM中的地址必须属于同一个子网,并且不同
no ip redirects
encapsulation is l 9
所使用的虚拟?#38047;?#32593;协议
standby 9 timers 3 250
和在RSM中的含义一样,并且必须相同
standby 9 priority 100
比在RSM中的值小,所以RSM在该VLAN中为活动的
standby 9 preempt
和在RSM中含义一样
standby 9 ip 202.120.95.65
该组的虚拟IP地址,必须和RSM中一样

为了达到负载均衡的目的,应该使Cisco 5509 RSM和Cisco 7010承担大致相同的负载,我们的方法是,在RSM中,VLAN 1到VLAN 30的权值为110,VLAN 31到VLAN 60的权值为100; 相反,在Cisco 7010中,VLAN 1到VLAN 30的权值为100,VLAN 31到VLAN 60的权值为100。这样,在正常情况下,Cisco 5509的RSM负责VLAN 1到VLAN 30的路由,Cisco 7010负责VLAN 31到VLAN 60的路由。如果有一方出现了故障,将由另一个来负载全部的路由工作。
五、HSRP存在的问题
对于在HSRP协议,最大的问题是没有提供安全防护,在一个?#38047;?#32593;内部,通过发送虚假的UDP多播数据包很容易对?#38047;?#32593;中的路由器实施攻击,导致数据包黑洞(Packet Black Hole)和拒绝服务攻击(Denial-of-Service Attack)。一般无法从一个?#38047;?#32593;的外部实施攻击,因为大多数路由器都不转发目的地址为所有路由器的多播地址(224.0.0.2)。
HSRP只是实现了路由器的?#20132;?#20999;换,使用户感觉不到这种切换,保证了网络的稳定性。但是,一个HSRP组内的路由器不能互通它们的其他网络配置信息,例如访问控制列表等。所以在管理实施管理时,为了保证一致性,必须?#36816;?#20204;进行相同的修?#27169;?#22686;加了管理的复杂性,这也许是为了提高性能而付出的代价吧。

30选5玩法