30选5玩法|福彩30选5开奖结果321|
 

标签:详解

思科OSPF技术详解

 

OSPF的五个包:

1.Hello:9项内容,4个必要

2.DBD:数据库描述数据包(主要描述始发路由器数据库中的一些或者全部LSA信息),主要包括接口的MTU,主从位MS,数据库描述序列号等);

3.LSR:链路状态请求数据包(查看收到的LSA是否在自己的数据库,或是更新的LSA,如果是将向邻居发送请求);

4.LSU:链路状态更新数据包(用于LSA的泛洪扩散和发送LSA去响应链路状态请求数据包);

5.LSACK:链路状态确认数据包(用来进行LSA可靠的泛洪扩散,即对可靠包的确认)。

Hello包作用:

1.发现邻居;

2.建立邻居关系;

3.维持邻居关系;

4.选举DR,BDR

5.确保双向通信。

Hello包所包含的内容:

路由器id

Hello&Dead间隔 *

区域id *

邻居

DR

BDR

优先级

验证 *

末节区域 *

注:1.“*”部分全?#31185;?#37197;才能建立邻居关系。

2.邻居关系为FULL状态;而邻接关系是处于TWO-WAY状态。

Hello时间间隔:

在点对点网络与广播网络中为10秒;

在NBMA网络与点对多点网络中为30秒。

注:

保持时间为hello时间4倍

虚电路传送的LSA为DNA,时间抑制,永不老化.

OSPF的组播地址:

DR将使用组播地址224.0.0.5泛洪扩散更新的数据包到DRothers

DRothers使用组播地址224.0.0.6发送更新数据包

组播的MAC地址分别为:0100.5E00.0005,0100.5E00.0006

OSPF的包头格式:

| 版本    | 类型 | 长度  | 路由器ID | 区域ID  | 验证和 | 验证类型  |验证 | 数据 |
| 1 byte |   1   | 2 | 4 | 4 | 2 | 2 | 8 | variance |

OSPF支持的验证类型:

OSPF支持明文和md5?#29616;ぃ?#29992;Sniffer抓包看到明文验证的代码是“1?#20445;琺d5验证的代码是“2”。

OSPF支持的网络类型:

1.广播

2.非广播

3.点对点(若MTU不匹配 将停留在EX-START状态)

4.点对多点

5.虚电路(虚电路的网络类型是点对点)

虚链路必须配置在ABR上,

虚链路的配置使用的命令是area transit-area-id virtual-link router-id

虚链路的Metric等同于所经过的全部链路开销之和

DR /BDR选举:

1.优先级(0~255; 0代表不参加选举;默认为1);

2.比较Router-id。

次者为BDR。

在Point-to-Point, Point-to-Multipoint(广播与非广播)这三种网络类型不选取DR与BDR; Broadcast, NBMA选取DR与BDR。

先启动OSPF进程的路由器会等待一?#38382;?#38388;,这个时间内你没有启动其它路由的OSPF进程的话,第一台路由就认为自己是DR,之后再加进来的也不能在选举了,这个等待时间叫做Wait Timer计时器,CISCO规定的Wait Timer是40秒。这个时间内你启动的路由是参与选举的,所以真实工作环境中,40秒你大概只启动了两台,DR会再前两台启动的路由中产生,工作一?#38382;?#38388;以后,活的最久的路由最有可能成为DR

OSPF over FRAME-RELAY 的配置:

(1) NBMA : 在HUB?#29616;?#23450;邻居;SPOKE上设置优先级为0。

(2) P-TO-P: 接口下配置命令 ip ospf network point-to-point。

(3) P-TO-MULT P:接口下配置命令 ip ospf network point-to-multipoint。

按需电路配置:

接口下配置命令 ip ospf demand-cricuit。

孤立区域问题解决:

1.虚电路 (虚电路穿过?#37027;?#22495;一定是标准区域,标准区域一定是全路由的)

2.隧道

3.多进程重分发

注:如果中间间隔区域为stub区域,则只能用隧道解决.

OSPF分区域的原因:

1.LSA数据过大,造成带宽负载过大。

2.计算全网拓扑,对cup要求过高。

3.数据库过大,对内存要求过高。

OSPF?#37027;?#22495;类型:

骨干: LSA:1 2 3 4 5

标准: LSA:1 2 3 4 5

stub: LSA1 2 3

nssa: LSA1 2 3 7 7(default)

AREA 1 NSSA DEFAULT INFORMATION-ORIGINATE

(ABR上产生默认路由LSA 7)

total-stub: 1 2一条默认3

total-nssa: 1 2 7一条默认3

LSA的类型:

类型1: 路由器链路信息

内容包括:路由器链路Router-id; 接口地址; 接口网络; 接口花费

可使用show ospf database router命令查看。

类型2: 网络链路信息

由DR通告,如果是点对点的网络类型,没有LSA2

类型3、4:汇总链路(都是ABR通告)

3号通告ospf区域间信息

4号通告asbr的router-id信息(通告nssa区域的abr)

类型5: 通告外部路由

类型7: nssa区域外部路由

类型11: 用于打标签

类型代码

类型名称

描述

1

路由器LSA

每台路由器都会产生,在区域内泛洪

2

网络LSA

DR产生,在区域内泛洪

3

网络汇总LSA

ABR始发,在整个OSPF域中泛洪

4

ASBR汇总LSA

ABR始发,在整个OSPF域中泛洪

5

AS外部LSA

ASBR始发,在整个OSPF域中泛洪

6

组成员LSA

标识OSPF组播中的组成?#20445;?#19981;做讨论

7

NSSA外部LSA

ASBR始发,

8

外部属性LSA

没有实现

9

Opaque LSA(本地链路?#27573;В?/p>

用于MPLS流量工程,不做讨论

10

Opaque LSA(本地区域?#27573;В?/p>

11

Opaque LSA(AS?#27573;В?/p>

OSPF邻居建立过程:

A————————-B

down

init B收到A 发来hello进入init状态

two way hello 4个“*”匹配,选举DR BDR ;A在hello中发现自己的Router-id;

exstart 交换DBD;确立主从关系(多路访问Router-id高为主,低为从; 串行接口下接口地址大的为主)

exchange 交换数据DBD (主的先发)

loading 交换完整数据包LSR LSU

full

注:

每个LSA由序列号确认为最新的更新。

当路由器收到LSA之后的处理过程:

(1)如果数据库有这样的,再查看序列号,如果序列号相同,忽略这条LSA;如果序列号偏大,将其转到数据库,并进行SPF,更新路由表;如果序列号偏小,将一个包含自己的LSA新信息发送给发送方。

(2)如果数据可没有这样的,将其加到数据库表,并发一个ACK返回,并运行SPF,更新路由表。‘

OSPFMetric值:

Cost=10的8次方/带宽,简便记做100Mb/带宽值。Metric值是由cost值逐跳累加的。

环回口的路由,掩码为/32,既我们所?#26723;摹?#20027;机路由”。在实际应用中,环回口以32位的居多,用作ospf的管理接口。但是如果你想?#27809;?#22238;口模拟一个网段,我们可以通过以下配置来消除。

R1(config)#int loopback 0

R1(config-if)#ip ospf network point-to-point

环回口只能配置成point-to-point这种类型,不可以配置成其它的类型。

其他:

1.当一个路由器既是ABR又是ASBR时为了不让巨量外部路由分发进nssa区域使用命令:area 1 nssa no-redistribution default-information originate

2.配置命令show ip ospf database router用来查询拓扑

3.一个路由器在理论?#29616;?#25345;65535个OSPF进程,在实际环境中一个路由器可支持的OSPF

进程数量与其可用物理接口数量相等。(这个我对老师?#26723;?#26377;疑问,如果我启用了很多环回口,每个环回口一个区域不可?#26376;穡浚?/p>

OSPF汇总

在OSPF骨干区域当中,一个区域的所有地址都会被通告进来。但是如果某个子网忽好忽坏不稳定,那么在它?#30475;?#25913;变状态的时候,都会引起LSA在整个网络中泛洪。为了解决这个问题,我们可以对网络地址进行汇总。

Cisco路由器的汇总有两种类型:区域汇总和外部路由汇总。区域汇总就是区域之间的地址汇总,一般配置在ABR上;外部路由汇总就是一组外部路由通过重发布进入OSPF中,将这些外部路由进行汇总。一般配置在ASBR上。

区域汇总:

area area-id range ip-address mask

外部路由汇总:

summary-address ip-address mask

------中间广告---------

我设计的两个试验,把几个知识点串起来

试验一

用一个试验总结一下ospf over 桢中继的时候,OSPF几种网络类型的差别。

clip_image002

封装好FR,DEBUG看到的几种情况

情况一:两边只起了OSPF进程,其它全部默认

这种情况下邻居需要手动配置!

R2(config)#router ospf 10

R2(config-router)#neighbor 12.1.1.3

选举了DR,BDR

hello的间隔是30s

OSPF的数据包是单播传送的。

情况二:两边的网络类型改为Broadcast(命令接口下ip ospf network broadcast

这种网络类型下是不需要手动配置邻居关系

有DR与BDR的选举。

Hello时间间隔为10s。

使用224.0.0.5这个组播地址传送数据包。

情况三?#21644;?#32476;类型改为Point-to-Point(命令接口下ip ospf net point-to-point

不需要手动指定邻居

没有DR/BDR的选举

Hello时间间隔为10s

使用224.0.0.5这个组播地址传送数据。

情况?#27169;?/b>Point-to-Multipoint(命令接口下ip ospf network point-to-multipoint

不需要手动指定邻居

没有DR和BDR的选举

Hello时间间隔为30s

以224.0.0.5这个组播地址发送数据

情况五:非广播的Point-to-Multipoint

(命令接口下ip ospf network point-to-multipoint non-broadcast)

邻居需要手动指定,但是邻居只要在一边指定即可。

没有DR和BDR的选取

Hello时间间隔为30s

使用单播传送OSPF数据

列出一张表,方便看

网络类型

邻居自动发现

有无DR选举

Hello间隔

传输方式

默认

30s

单播

Broadcast

10s

组播

Point-to-Point

10s

组播

Point-to-Multipoint

30s

组播

Point-to-Multipoint(非广播)

否,单边指即可

30s

单播

试验二

OSPF的?#29616;?#24635;结:

clip_image004

OSPF的?#29616;?#26377;2种类型(不验证也算的话是3种),使用DEBUG可以看到type0表示无?#29616;ぃ瑃ype1表示明文?#29616;ぃ瑃ype2表示MD5?#29616;ぁ?#26126;文?#29616;?#21457;送密码进行?#29616;ぃ?#32780;MD5?#29616;?#21457;送的是报文摘要。

OSPF的?#29616;?#21487;以在链路上进行,?#37096;?#20197;在整个区域内进行?#29616;ぁ?#21478;外虚链路同样?#37096;?#20197;进行?#29616;ぁ?/p>

同样也是分情况来讨论。

情况一:R1和R2明文验证

R1(config)#int s1/0

R1(config-if)#ip ospf authentication(启用?#29616;ぃ?/b>

R1(config-if)#ip ospf authentication-key cisco(配置密码)

不配置R2的话

通过debug工具我们可以看到如下信息:

*Aug 15 22:51:54.275: OSPF: Rcv pkt from 10.1.1.2, Serial1/0 : Mismatch Authentication type. Input packet specified type 0, we use type 1

这里的type0是指对方没有启用?#29616;ぃ瑃ype1是明文?#29616;ぁ?/p>

在R2上配置?#29616;ぃ?#20351;得邻居关系?#25351;础?/p>

R2(config)#int s1/0

R2(config-if)#ip ospf authentication

R2(config-if)#ip ospf authentication-key cisco

*Aug 15 22:54:55.815: %OSPF-5-ADJCHG: Process 10, Nbr 1.1.1.1 on Serial1/0 from LOADING to FULL, Loading Done

情况二:在R2和R3的串行链路上进行MD5?#29616;?#30340;:

R2(config)#int s1/1

R2(config-if)#ip ospf authentication message-digest(定义?#29616;?#31867;型为MD5

R2(config-if)#ip ospf message-digest-key 1 md5 cisco(定义key和密码)

R3(config)#int s1/0

R3(config-if)#ip ospf authentication message-digest

R3(config-if)#ip ospf message-digest-key 1 md5 cisco

情况三:增加R2和R3上串行链路的MD5?#29616;?#30340;密码:

在R2原有的配置上?#30001;?#19979;面这条命令:

R2(config-if)#ip ospf message-digest-key 2 md5 openlab

R2#sho ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface

3.3.3.3 0 FULL/ – – 11.1.1.2 OSPF_VL0

1.1.1.1 1 FULL/BDR 00:00:34 21.1.1.1 FastEthernet0/0

1.1.1.1 0 FULL/ – 00:00:37 10.1.1.1 Serial1/0

3.3.3.3 0 FULL/ – 00:00:31 11.1.1.2 Serial1/1

邻居关系没有丢失。

增加新的密码钥匙,然后在将原来的密码?#22659;?#20505;邻居关系不受影响。

情况?#27169;?#22312;Area0上进行区域?#29616;ぃ?#20197;前没做过吧)

R1(config)#router ospf 10

R1(config-router)#area 0 authentication

还没?#34892;?#19979;一步,就是刚启用,还没设置密码,邻居就down掉了

同样,R2上启用一下,邻居就?#25351;?/p>

或者都设置相同的密码?#37096;?#20197;。

情况五:Area0上进行区域?#29616;?#20197;后。。。

R2#clear ip ospf pro清进程,A2区域的学不到邻居了。R3是通过虚链路连接到骨干区域的。因为virtual-link属于Area0,因此在R2配置完成Area0区域?#29616;?#21518;,R3也需要相应的配置。

R3(config)#router ospf 10

R3(config-router)#area 0 authentication

这样就可以了

情况六:单纯的虚链路的?#29616;ぃ?#36825;个以前也没做过吧)

明文?#29616;ぃ琈D5?#29616;ぁ?#37197;置命令如下:

明文:

R2(config-router)#area 1 virtual-link 3.3.3.3 authentication-key cisco

R3(config-router)#area 1 virtual-link 2.2.2.2 authentication-key cisco

MD5:

R2(config-router)#area 1 virtual-link 3.3.3.3 authentication message-digest

R2(config-router)#area 1 virtual-link 3.3.3.3 message-digest-key 1 md5 cisco

R3(config-router)#area 1 virtual-link 2.2.2.2 authentication message-digest

R3(config-router)#area 1 virtual-link 2.2.2.2 message-digest-key 1 md5 cisco

另外通过实验知道虚链路在建立起来后是DNA LSA(不老化LSA),所以如果没有重启OSPF进程的话,即使一端配置了?#29616;ぃ?#34394;链路也是不会断开的。

后面是sniffer抓得包

Hello包

clip_image006

Lsu包

clip_image008

clip_image010

LSACK包

clip_image012

上面是一般情况,下面是明文验证的几个包

Hello

clip_image014

DBD

clip_image016

LSR

clip_image018

LSU

clip_image020

LSACK

clip_image022

下面是MD5?#29992;莧现?#24471;包

Hello

clip_image024

DBD

clip_image026

LSR

clip_image028

LSU

clip_image030

clip_image032

LSACK

clip_image034

基于MAC的访问控制列表 详解

No Comments CISCO ,

 

Creating Named MAC Extended ACLs

Step 1 configure terminal Enter global configuration mode.
Step 2 mac access-list extended name Define an extended MAC access list using a name.

Step 3

{deny | permit}

{any | host source MACaddress | source MAC address mask}

{any |host destination MAC address | destination
MAC address mask} [type mask | lsap lsap mask
| aarp | amber | dec-spanning | decnet-iv |
diagnostic | dsm | etype-6000 | etype-8042 | lat
| lavc-sca | mop-console | mop-dump | msdos |
mumps | netbios | vines-echo |vines-ip |
xns-idp | 0-65535
]

[cos cos]

Step 4 end Return to privileged EXEC mode.
Step 5 show access-lists [number | name] Show the access list configuration.
Step 6 copy running-config startup-config (Optional) Save your entries in the configuration file.

This example shows how to create and display an access list named mac1, denying only EtherType
DECnet Phase IV traffic, but permitting all other types of traffic.
Switch(config)# mac access-list extended mac1
Switch(config-ext-macl)# deny any any decnet-iv
Switch(config-ext-macl)# permit any any
Switch(config-ext-macl)# end
Switch # show access-lists
Extended MAC access list mac1
10 deny any any decnet-iv
20 permit any any

交换机二层、三层、四层存在哪些区别

No Comments CISCO , ,

 

二层交换技术是发展比较成熟,二层交换机属数据链路层设备,可以识别数据包中的MAC地址信息,根据MAC地址进行转发,并将这些MAC地址与对应的端口记录在自己内部的一个地址表?#23567;?#20855;体的工作流程如下:
(1)当交换机从某个端口收到一个数据包,它先读取包头中的源MAC地址,这样它就知道源MAC地址的机器是连在哪个端口上的;

(2) 再去读

(3)如表中有与这目的MAC地址对应的端口,把数据包直接复制到这端口上;
(4)如表中找不到相应的端口则把数据包广播到所有端口上,当目的机器对源机器回应?#20445;?#20132;换机又可以学习一目的MAC地址与哪个端口对应,在下次传送数据时就不再需要?#36816;?#26377;端口进行广播了。
不断的循环这个过程,对于全网的MAC地址信息都可以学习到,二层交换机就是这样建立和维护它自己的地址表。

从二层交换机的工作原理可以推知以下三点:

(1)由于交换机对多数端口的数据进行同时交换,这就要求具有很宽的交换总线带宽,如果二层交换机有N个端口,每个端口的带宽是M,交换机总线带宽超过N×M,那么这交换机就可以实现线速交换;

(2)学习端口连接的机器的MAC地址,写入地址表,地址表的大小(一般两种表示方式:一为BEFFER RAM,一为MAC表项数值),地址表大小影响交换机的接入容量;

(3)还有一个就是二层交换机一般?#24049;?#26377;专门用于处理数据包转发的ASIC (Application specific Integrated Circuit)芯片,因此转发速度可以做到非常快。由于各个厂?#20063;?#29992;ASIC不同,直接影响产品性能。

以?#20808;?#28857;也是评判二三层交换机性能优劣的主要技术?#38382;?#36825;一点请大家在考虑设备选型时注意比较。
二)路由技术

路由器工作在OSI模型的第三层—网络层操作,其工作模?#25509;?#20108;层交换相似,但路由器工作在第三层,这个区别决定了路由和交换在传递包时使用不同的控制信息,实现功能的方式就不同。工作原理是在路由器的内部也有一个表,这个表所标示的是如果要去某一个地方,下一?#25509;?#35813;向那里走,如果能从路由表中?#19994;?#25968;据包下一步往那里走,把链路层信息?#30001;?#36716;发出去;如果不能知?#32769;?#19968;步走向那里,则将此包丢弃,然后返回一个信息交给源地址。

路由技术实质上来说不过两种功能:决定最优路由和转发数据包。路由表中写入各?#20013;?#24687;,由路由算法计算出到达目的地址的最佳路径,然后由相对简单直接的转发机制发送数据包。接受数据的下一台路由器依?#38556;?#21516;的工作方式继续转发,?#26469;?#31867;推,直到数据包到达目的路由器。

而路由表的维护,也有两种不同的方式。一种是路由信息的更新,将部分或者全部的路由信息公布出去,路由器通过互相学习路由信息,就掌握了全网的拓扑结构,这一类的路由协议称为距离矢量路由协议;另一种是路由器将自己的链路状态信息进行广播,通过互相学习掌握全网的路由信息,进而计算出最佳的转发路径,这类路由协议称为链路状态路由协议。

由于路由器需要做大量的路径计算工作,一般处理器的工作能力直接决定其性能的优劣。
?#27604;?#36825;一判断?#25925;?#23545;中低端路由器而言,因为高端路由器往往采用分布式处理系?#31243;?#31995;设计。

(三)三层交换技术

近年来的对三层技术的宣传,耳朵都能起茧子,到处都在喊三层技术,有人说这是个非常新的技术,也有人说,三层交换嘛,不就是路由器和二层交换机的堆叠,也没有什么新的玩意,事实果真如此吗?下面先来通过一个简单的网络来看看三层交换机的工作过程。
组网比较简单

使用IP的设备A————————三层交换机————————使用IP的设备B

比如A要给B发送数据,已知目的IP,那么A就用子网掩码取得网络地址,判断目的IP是否与自己在同一网段。
如果在同一网段,但不知道转发数据所需的MAC地址,A就发送一个ARP请求,B返回其MAC地址,A用此MAC封装数据包并发送给交换机,交换机起用二层交换模块,查找MAC地址表,将数据包转发到相应的端口。

如果目的IP地址显示不是同一网段的,那么A要实现和B的通讯,在流缓存条目中没有对应MAC地址条目,就将第一个正常数据包发送向一个缺省网关,这个缺省网关一般在操作系统中已经设好,对应第三层路由模块,所以可见对于不是同一子网的数据,最先在MAC表中放的是缺省网关的MAC地址;然后就由三层模块接收到此数据包,查询路由表以确定到达B的路由,将构造一个新的帧头,其中以缺省网关的MAC地址为源MAC地址,以主机B的MAC地址为目的MAC地址。通过一定的识别触发机制,确立主机A与B的MAC地址及转发端口的对应关系,并记录进流缓存条目表,以后的A到B的数据,就直接交由二层交换模块完成。这就通常所?#26723;?#19968;次路由多次转发。

以上就是三层交换机工作过程的简单概括,可以看出三层交换的特点:
由?#24067;?#32467;合实现数据的高速转发。

这就不是简单的二层交换机和路由器的叠加,三层路由模块直接叠加在二层交换的高速背板总线上,突破了传统路由器的接口速率限制,速率可达几十Gbit/s。算上背板带宽,这些是三层交换机性能的两个重要?#38382;?

简洁的路由软件使路由过程简化。

大部分的数据转发,除了必要的路由选择交由路由软件处理,都是又二层模块高速转发,路由软件大多都是经过处理的高效优化软件,并不是简单照搬路由器中的软件。

结论

二层交换机用于小型的局域网络。这个就不用多言了,在小型局域网中,广播包影响不大,二层交换机的快速交换功能、多个接入端口和低谦价格为小型网络用户提供了很完善的解决方案。

路由器的优点在于接口类?#22836;?#23500;,支持的三层功能?#30475;螅?#36335;由能力?#30475;螅?#36866;合用于大型的网络间的路由,它的优势在于选择最佳路由,负荷分担,链路备份及和其他网络进行路由信息的交换等等路由器所具有功能。
三层交换机的最重要的功能是加快大型局域网络内部的数据的快速转发,加入路由功能也是为这个目的服务的。如果把大型网络按照部门,地域等等因素划分成一个个小局域网,这将导致大量的网际互访,单纯的使用二层交换机不能实现网际互访;如单纯的使用路由器,由于接口数量有限和路由转发速度慢,将限制网络的速度和网络规模,采用具有路由功能的快速转发的三层交换机就成为首选。如果把大型网络按照部门,地域等等因素划分成一个个小局域网,这将导致大量的网际互访,单纯的使用二层交换机不能实现网际互访;如单纯的使用路由器,由于接口数量有限和路由转发速度慢,将限制网络的速度和网络规模,采用具有路由功能的快速转发的三层交换机就成为首选。

一般来说,在内网数据流?#30475;螅?#35201;求快速转发响应的网络中,如全部由三层交换机来做这个工作,会造成三层交换机负担过重,响应速度受影响,将网间的路由交由路由器去完成,充分发挥不同设备的优点,不失为一种好的组网策略,?#27604;唬?#21069;提是?#31361;?#30340;腰包很?#27169;?#19981;然就退而求其次,让三层交换机?#24067;?#20026;网际互连。

第四层交换的一个简单定义是:它是一种功能,它决定传输不仅仅依据MAC地址(第二层网桥)或源/目标IP地址(第三层路由),而且依据TCP/UDP(第四层) 应用端口号。第四层交换功能就象是虚IP,指向物理服务器。它传输的业务服从的协议多种多样,有HTTP、FTP、NFS、Telnet或其他协议。这些业务在物理服务器基础上,需要复杂的载?#31185;?#34913;算法。在IP世界,业务类型由终端TCP或UDP端口地址来决定,在第四层交换中的应用区间则由源端和终端IP地址、TCP和UDP端口共同决定。
在第四层交换中为每个供搜寻使用的服务器组设立虚IP地址(VIP),每组服务器支持?#25345;?#24212;用。在域名服务器(DNS)中存储的每个应用服务器地址是VIP,而不是真?#26723;?#26381;务器地址。
当某用户申请应用?#20445;?#19968;个带有目标服务器组的VIP连接请求(例如一个TCP SYN包)发给服务器交换机。服务器交换机在组中选取最好的服务器,将终端地址中的VIP用实际服务器的IP取代,并将连接请求传给服务器。这样,同一区间所有的包由服务器交换机进行?#25104;洌?#22312;用户和同一服务器间进行传输。
第四层交换的原理
OSI模型的第四层是传输层。传输层负责端对?#36865;?#20449;,即在网络源和目标系?#25345;?#38388;协调通信。在IP协议栈中这是TCP(一种传输协议)和UDP(用户数据包协议)所在的协议层。

在第四层中,TCP和UDP标题包含端口号(portnumber),它们可以唯一区分每个数据包包含哪些应用协议(例如HTTP、FTP等)。端点系统利用这?#20013;?#24687;来区分包中的数据,尤其是端口号使一个接收?#24605;?#31639;机系统能够确定它所收到的IP包类型,并把它交给合适的高层软件。端口号和设备IP地址的组合通常称作?#23433;?#21475;(socket)”。
1和255之间的端口号被保留,他们称为“熟知?#20493;?#21475;,也就是说,在所有主机TCP/IP协议栈实现中,这些端口号是相同的。除了“熟知?#20493;?#21475;外,标准UNIX服务分配在256到1024端口?#27573;В?#23450;制的应用一般在1024以上分配端口号。分配端口号的最近清单可以在RFc1700”Assigned Numbers”上?#19994;健CP/UDP端口号提供的附加信息可以为网络交换机所利用,这是第4层交换的基础。
"熟知"端口号举例:
应用协议 端口号
FTP 20(数据)
21(控制)
TELNET 23
SMTP 25
HTTP 80
NNTP 119
NNMP 16
162(SNMP traps)
TCP/UDP端口号提供的附加信息可以为网络交换机所利用,这是第四层交换的基础。

具有第四层功能的交换机能够起?#25509;?#26381;务器相连接的“虚拟IP”(VIP)前端的作用。

每台服务器和支持单一或通用应用的服务器组都配置一个VIP地址。这个VIP地址被发送出去并在域名系统上注册。

在发出一个服务请求?#20445;?#31532;四层交换机通过判定TCP开始,来识别一?#20301;?#35805;的开始。然后它利用复杂的算法来确定处理这个请求的最佳服务器。一旦做出这种决定,交换机就将会话与一个具体的IP地址联系在一起,并用该服务器真正的IP地址来代替服务器上的VIP地址。

每台第四层交换机都保存一个与被选择的服务器相配的源IP地址以及源TCP 端口相关联的连接表。然后第四层交换机向这台服务器转发连接请求。所有后续包在?#31361;?#26426;与服务器之间重新影射和转发,直到交换机发现会话为止。
在使用第四层交换?#37027;?#20917;下,接入可以与真正的服务器连接在一起来满足用户制定的规则,诸如使每台服务器上有相等数量的接入或根据不同服务器的容量来分配传输流。

如何选用合适的第四层交换
a,速度 为了在企业网中行之?#34892;В?#31532;四层交换必须提供与第三层线速路由器可比拟的性能。也就是说,第四层交换必须在所有端口以全介质速度操作,即使在多个千兆以太网连?#30001;?#20134;如此。千兆以太网速度等于以每秒1488000 个数据包的最大速度路由(假定最?#26723;那?#24418;,即所有包为以及网定义的最小尺寸,长64字节)。
b,服务器容?#31185;?#34913;算法 依据所希望的容?#31185;?#34913;间隔尺寸,第四层交换机将应用分配给服务器的算法有很多种,有简单的检测环路最近的连接、检测环路时延或检测服务器本身的闭环反馈。在所有的预测中,闭环反馈提供?#20174;?#26381;务器现有业务量的最精确的检测。
c,表容量 应注意的是,进行第四层交换的交换机需要有区分和存贮大量发送表项的能力。交换机在一个企业网的核心时尤其如此。许多第二/ 三层交换机倾向发送表的大小与网络设备的数量成正比。对第四层交换机,这个数量必须乘以网络中使用的不同应用协议和会话的数量。因而发送表的大小随端点设备和应用类型数量的增长而迅速增长。第四层交换机设计者在设计其产品时需要考虑表的这种增长。大的表容量对制造支持线速发送第四层流量的高性能交换机至关重要。
d,冗余 第四层交换机内部有支持冗余拓扑结构的功能。在具有双链路的网卡容错连接?#20445;?#23601;可能建立从一个服务器到网卡,链路和服务器交换器的完全冗余系统。存在哪些区别

二层交换技术是发展比较成熟,二层交换机属数据链路层设备,可以识别数据包中的MAC地址信息,根据MAC地址进行转发,并将这些MAC地址与对应的端口记录在自己内部的一个地址表?#23567;?#20855;体的工作流程如下:
(1)当交换机从某个端口收到一个数据包,它先读取包头中的源MAC地址,这样它就知道源MAC地址的机器是连在哪个端口上的;

(2) 再去读

(3)如表中有与这目的MAC地址对应的端口,把数据包直接复制到这端口上;
(4)如表中找不到相应的端口则把数据包广播到所有端口上,当目的机器对源机器回应?#20445;?#20132;换机又可以学习一目的MAC地址与哪个端口对应,在下次传送数据时就不再需要?#36816;?#26377;端口进行广播了。
不断的循环这个过程,对于全网的MAC地址信息都可以学习到,二层交换机就是这样建立和维护它自己的地址表。

从二层交换机的工作原理可以推知以下三点:

(1)由于交换机对多数端口的数据进行同时交换,这就要求具有很宽的交换总线带宽,如果二层交换机有N个端口,每个端口的带宽是M,交换机总线带宽超过N×M,那么这交换机就可以实现线速交换;

(2)学习端口连接的机器的MAC地址,写入地址表,地址表的大小(一般两种表示方式:一为BEFFER RAM,一为MAC表项数值),地址表大小影响交换机的接入容量;

(3)还有一个就是二层交换机一般?#24049;?#26377;专门用于处理数据包转发的ASIC (Application specific Integrated Circuit)芯片,因此转发速度可以做到非常快。由于各个厂?#20063;?#29992;ASIC不同,直接影响产品性能。

以?#20808;?#28857;也是评判二三层交换机性能优劣的主要技术?#38382;?#36825;一点请大家在考虑设备选型时注意比较。
二)路由技术

路由器工作在OSI模型的第三层—网络层操作,其工作模?#25509;?#20108;层交换相似,但路由器工作在第三层,这个区别决定了路由和交换在传递包时使用不同的控制信息,实现功能的方式就不同。工作原理是在路由器的内部也有一个表,这个表所标示的是如果要去某一个地方,下一?#25509;?#35813;向那里走,如果能从路由表中?#19994;?#25968;据包下一步往那里走,把链路层信息?#30001;?#36716;发出去;如果不能知?#32769;?#19968;步走向那里,则将此包丢弃,然后返回一个信息交给源地址。

路由技术实质上来说不过两种功能:决定最优路由和转发数据包。路由表中写入各?#20013;?#24687;,由路由算法计算出到达目的地址的最佳路径,然后由相对简单直接的转发机制发送数据包。接受数据的下一台路由器依?#38556;?#21516;的工作方式继续转发,?#26469;?#31867;推,直到数据包到达目的路由器。

而路由表的维护,也有两种不同的方式。一种是路由信息的更新,将部分或者全部的路由信息公布出去,路由器通过互相学习路由信息,就掌握了全网的拓扑结构,这一类的路由协议称为距离矢量路由协议;另一种是路由器将自己的链路状态信息进行广播,通过互相学习掌握全网的路由信息,进而计算出最佳的转发路径,这类路由协议称为链路状态路由协议。

由于路由器需要做大量的路径计算工作,一般处理器的工作能力直接决定其性能的优劣。
?#27604;?#36825;一判断?#25925;?#23545;中低端路由器而言,因为高端路由器往往采用分布式处理系?#31243;?#31995;设计。

(三)三层交换技术

近年来的对三层技术的宣传,耳朵都能起茧子,到处都在喊三层技术,有人说这是个非常新的技术,也有人说,三层交换嘛,不就是路由器和二层交换机的堆叠,也没有什么新的玩意,事实果真如此吗?下面先来通过一个简单的网络来看看三层交换机的工作过程。
组网比较简单

使用IP的设备A————————三层交换机————————使用IP的设备B

比如A要给B发送数据,已知目的IP,那么A就用子网掩码取得网络地址,判断目的IP是否与自己在同一网段。
如果在同一网段,但不知道转发数据所需的MAC地址,A就发送一个ARP请求,B返回其MAC地址,A用此MAC封装数据包并发送给交换机,交换机起用二层交换模块,查找MAC地址表,将数据包转发到相应的端口。

如果目的IP地址显示不是同一网段的,那么A要实现和B的通讯,在流缓存条目中没有对应MAC地址条目,就将第一个正常数据包发送向一个缺省网关,这个缺省网关一般在操作系统中已经设好,对应第三层路由模块,所以可见对于不是同一子网的数据,最先在MAC表中放的是缺省网关的MAC地址;然后就由三层模块接收到此数据包,查询路由表以确定到达B的路由,将构造一个新的帧头,其中以缺省网关的MAC地址为源MAC地址,以主机B的MAC地址为目的MAC地址。通过一定的识别触发机制,确立主机A与B的MAC地址及转发端口的对应关系,并记录进流缓存条目表,以后的A到B的数据,就直接交由二层交换模块完成。这就通常所?#26723;?#19968;次路由多次转发。

以上就是三层交换机工作过程的简单概括,可以看出三层交换的特点:
由?#24067;?#32467;合实现数据的高速转发。

这就不是简单的二层交换机和路由器的叠加,三层路由模块直接叠加在二层交换的高速背板总线上,突破了传统路由器的接口速率限制,速率可达几十Gbit/s。算上背板带宽,这些是三层交换机性能的两个重要?#38382;?

简洁的路由软件使路由过程简化。

大部分的数据转发,除了必要的路由选择交由路由软件处理,都是又二层模块高速转发,路由软件大多都是经过处理的高效优化软件,并不是简单照搬路由器中的软件。

结论

二层交换机用于小型的局域网络。这个就不用多言了,在小型局域网中,广播包影响不大,二层交换机的快速交换功能、多个接入端口和低谦价格为小型网络用户提供了很完善的解决方案。

路由器的优点在于接口类?#22836;?#23500;,支持的三层功能?#30475;螅?#36335;由能力?#30475;螅?#36866;合用于大型的网络间的路由,它的优势在于选择最佳路由,负荷分担,链路备份及和其他网络进行路由信息的交换等等路由器所具有功能。
三层交换机的最重要的功能是加快大型局域网络内部的数据的快速转发,加入路由功能也是为这个目的服务的。如果把大型网络按照部门,地域等等因素划分成一个个小局域网,这将导致大量的网际互访,单纯的使用二层交换机不能实现网际互访;如单纯的使用路由器,由于接口数量有限和路由转发速度慢,将限制网络的速度和网络规模,采用具有路由功能的快速转发的三层交换机就成为首选。如果把大型网络按照部门,地域等等因素划分成一个个小局域网,这将导致大量的网际互访,单纯的使用二层交换机不能实现网际互访;如单纯的使用路由器,由于接口数量有限和路由转发速度慢,将限制网络的速度和网络规模,采用具有路由功能的快速转发的三层交换机就成为首选。

一般来说,在内网数据流?#30475;螅?#35201;求快速转发响应的网络中,如全部由三层交换机来做这个工作,会造成三层交换机负担过重,响应速度受影响,将网间的路由交由路由器去完成,充分发挥不同设备的优点,不失为一种好的组网策略,?#27604;唬?#21069;提是?#31361;?#30340;腰包很?#27169;?#19981;然就退而求其次,让三层交换机?#24067;?#20026;网际互连。

第四层交换的一个简单定义是:它是一种功能,它决定传输不仅仅依据MAC地址(第二层网桥)或源/目标IP地址(第三层路由),而且依据TCP/UDP(第四层) 应用端口号。第四层交换功能就象是虚IP,指向物理服务器。它传输的业务服从的协议多种多样,有HTTP、FTP、NFS、Telnet或其他协议。这些业务在物理服务器基础上,需要复杂的载?#31185;?#34913;算法。在IP世界,业务类型由终端TCP或UDP端口地址来决定,在第四层交换中的应用区间则由源端和终端IP地址、TCP和UDP端口共同决定。
在第四层交换中为每个供搜寻使用的服务器组设立虚IP地址(VIP),每组服务器支持?#25345;?#24212;用。在域名服务器(DNS)中存储的每个应用服务器地址是VIP,而不是真?#26723;?#26381;务器地址。
当某用户申请应用?#20445;?#19968;个带有目标服务器组的VIP连接请求(例如一个TCP SYN包)发给服务器交换机。服务器交换机在组中选取最好的服务器,将终端地址中的VIP用实际服务器的IP取代,并将连接请求传给服务器。这样,同一区间所有的包由服务器交换机进行?#25104;洌?#22312;用户和同一服务器间进行传输。
第四层交换的原理
OSI模型的第四层是传输层。传输层负责端对?#36865;?#20449;,即在网络源和目标系?#25345;?#38388;协调通信。在IP协议栈中这是TCP(一种传输协议)和UDP(用户数据包协议)所在的协议层。

在第四层中,TCP和UDP标题包含端口号(portnumber),它们可以唯一区分每个数据包包含哪些应用协议(例如HTTP、FTP等)。端点系统利用这?#20013;?#24687;来区分包中的数据,尤其是端口号使一个接收?#24605;?#31639;机系统能够确定它所收到的IP包类型,并把它交给合适的高层软件。端口号和设备IP地址的组合通常称作?#23433;?#21475;(socket)”。
1和255之间的端口号被保留,他们称为“熟知?#20493;?#21475;,也就是说,在所有主机TCP/IP协议栈实现中,这些端口号是相同的。除了“熟知?#20493;?#21475;外,标准UNIX服务分配在256到1024端口?#27573;В?#23450;制的应用一般在1024以上分配端口号。分配端口号的最近清单可以在RFc1700”Assigned Numbers”上?#19994;健CP/UDP端口号提供的附加信息可以为网络交换机所利用,这是第4层交换的基础。
"熟知"端口号举例:
应用协议 端口号
FTP 20(数据)
21(控制)
TELNET 23
SMTP 25
HTTP 80
NNTP 119
NNMP 16
162(SNMP traps)
TCP/UDP端口号提供的附加信息可以为网络交换机所利用,这是第四层交换的基础。

具有第四层功能的交换机能够起?#25509;?#26381;务器相连接的“虚拟IP”(VIP)前端的作用。

每台服务器和支持单一或通用应用的服务器组都配置一个VIP地址。这个VIP地址被发送出去并在域名系统上注册。

在发出一个服务请求?#20445;?#31532;四层交换机通过判定TCP开始,来识别一?#20301;?#35805;的开始。然后它利用复杂的算法来确定处理这个请求的最佳服务器。一旦做出这种决定,交换机就将会话与一个具体的IP地址联系在一起,并用该服务器真正的IP地址来代替服务器上的VIP地址。

每台第四层交换机都保存一个与被选择的服务器相配的源IP地址以及源TCP 端口相关联的连接表。然后第四层交换机向这台服务器转发连接请求。所有后续包在?#31361;?#26426;与服务器之间重新影射和转发,直到交换机发现会话为止。
在使用第四层交换?#37027;?#20917;下,接入可以与真正的服务器连接在一起来满足用户制定的规则,诸如使每台服务器上有相等数量的接入或根据不同服务器的容量来分配传输流。

如何选用合适的第四层交换
a,速度 为了在企业网中行之?#34892;В?#31532;四层交换必须提供与第三层线速路由器可比拟的性能。也就是说,第四层交换必须在所有端口以全介质速度操作,即使在多个千兆以太网连?#30001;?#20134;如此。千兆以太网速度等于以每秒1488000 个数据包的最大速度路由(假定最?#26723;那?#24418;,即所有包为以及网定义的最小尺寸,长64字节)。
b,服务器容?#31185;?#34913;算法 依据所希望的容?#31185;?#34913;间隔尺寸,第四层交换机将应用分配给服务器的算法有很多种,有简单的检测环路最近的连接、检测环路时延或检测服务器本身的闭环反馈。在所有的预测中,闭环反馈提供?#20174;?#26381;务器现有业务量的最精确的检测。
c,表容量 应注意的是,进行第四层交换的交换机需要有区分和存贮大量发送表项的能力。交换机在一个企业网的核心时尤其如此。许多第二/ 三层交换机倾向发送表的大小与网络设备的数量成正比。对第四层交换机,这个数量必须乘以网络中使用的不同应用协议和会话的数量。因而发送表的大小随端点设备和应用类型数量的增长而迅速增长。第四层交换机设计者在设计其产品时需要考虑表的这种增长。大的表容量对制造支持线速发送第四层流量的高性能交换机至关重要。
d,冗余 第四层交换机内部有支持冗余拓扑结构的功能。在具有双链路的网卡容错连接?#20445;?#23601;可能建立从一个服务器到网卡,链路和服务器交换器的完全冗余系统。

HDLC 详解

No Comments 网络技术 ,

一、HDLC

HDLC是CISCO路由器使用的缺省协议,一台新路由器在未指定封装协议时默认使用HDLC封装。

1.        有关命令

端口设置

任务

命令

设置HDLC封装

encapsulation hdlc

设置DCE端线路速度

clockrate speed

复位一个?#24067;?#25509;口

clear interface serial unit

显示接口状态

show interfaces serial [unit] 1

注:1.以下给出一个显示Cisco同步串口状态的例子.

Router#show interface serial 0

Serial 0 is up, line protocol is up

Hardware is MCI Serial

Internet address is 150.136.190.203, subnet mask is 255.255.255.0

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/255

Encapsulation HDLC, loopback not set, keepalive set (10 sec)

Last input 0:00:07, output 0:00:00, output hang never

Output queue 0/40, 0 drops; input queue 0/75, 0 drops

Five minute input rate 0 bits/sec, 0 packets/sec

Five minute output rate 0 bits/sec, 0 packets/sec

16263 packets input, 1347238 bytes, 0 no buffer

Received 13983 broadcasts, 0 runts, 0 giants

2 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 2 abort

22146 packets output, 2383680 bytes, 0 underruns

0 output errors, 0 collisions, 2 interface resets, 0 restarts

1 carrier transitions      

2.        举例

clip_image001

设置如下:

Router1:

interface Serial0

ip address 192.200.10.1 255.255.255.0

clockrate 1000000

Router2:

interface Serial0

ip address 192.200.10.2 255.255.255.0

!

3.      举例使用E1线路实现多个64K专线连接.

相关命令:

任务

命令

进入controller配置模式

controller {t1 | e1} number

选择帧类型

framing {crc4 | no-crc4}

选择line-code类型

linecode {ami | b8zs | hdb3}

建立逻辑通道组与时隙的?#25104;?/p>

channel-group number timeslots range1

显示controllers接口状态

show controllers e1 [slot/port]2

注: 1. 当链路为T1时,channel-group编号为0-23, Timeslot?#27573;?-24; 当链路为E1时, channel-group编号为0-30, Timeslot?#27573;?-31.

2.使用show controllers e1观察controller状态,以下为帧类型为crc4时controllers正常的状态.

Router# show controllers e1

e1 0/0 is up.

Applique type is Channelized E1 – unbalanced

Framing is CRC4, Line Code is HDB3 No alarms detected.

Data in current interval (725 seconds elapsed):

0 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Total Data (last 24 hours)     0 Line Code Violations, 0 Path Code Violations,

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

以下例子为E1连接3条64K专线, 帧类型为NO-CRC4,非平衡链路,路由器具体设置如下:

shanxi#wri t

Building configuration…

Current configuration:

!

version 11.2

no service udp-small-servers

no service tcp-small-servers

!

hostname shanxi

!

enable secret 5 $1$XN08$Ttr8nfLoP9.2RgZhcBzkk/

enable password shanxi

!

!

ip subnet-zero

!

controller E1 0

framing NO-CRC4

channel-group 0 timeslots 1

channel-group 1 timeslots 2

channel-group 2 timeslots 3

!

interface Ethernet0

ip address 133.118.40.1 255.255.0.0

media-type 10BaseT

!

interface Ethernet1

no ip address

shutdown

!

interface Serial0:0

ip address 202.119.96.1 255.255.255.252

no ip mroute-cache

!

interface Serial0:1

ip address 202.119.96.5 255.255.255.252

no ip mroute-cache

!

interface Serial0:2

ip address 202.119.96.9 255.255.255.252

no ip mroute-cache

!

no ip classless

ip route 133.210.40.0 255.255.255.0 Serial0:0

ip route 133.210.41.0 255.255.255.0 Serial0:1

ip route 133.210.42.0 255.255.255.0 Serial0:2

!

line con 0

line aux 0

line vty 0 4

password shanxi

login

!

end

PPP详解

No Comments 网络技术 ,

 

PPP(Point-to-Point Protocol)是SLIP(Serial Line IP protocol)的继承者,它提供了跨过同步和异步电路实现路由器到路由器(router-to-router)和主机到网络(host-to-network)的连接。

CHAP(Challenge Handshake Authentication Protocol)和PAP(Password Authentication Protocol) (PAP)通常被用于在PPP封装的串行线路上提供安全性?#29616;ぁ?#20351;用CHAP和PAP?#29616;?每个路由器通过名字来识别,可以防止未经授权的访问。

CHAP和PAP在RFC 1334上有详细的说明。

1.        有关命令

端口设置

任务

命令

设置PPP封装

encapsulation ppp1

设置?#29616;?#26041;法

ppp authentication {chap | chap pap | pap chap | pap} [if-needed] [list-name | default] [callin]

指定口令

username name password secret

设置DCE端线路速度

clockrate speed

注:1、要使用CHAP/PAP必须使用PPP封装。在与非Cisco路由器连接?#20445;?#19968;般采用PPP封装,其它厂家路由器一般不支持Cisco的HDLC封装协议。

2.        举例

路由器Router1和Router2的S0口均封装PPP协议,采用CHAP做?#29616;ぃ?#22312;Router1中应建立一个用户,以对端路由器主机名作为用户名,?#20174;没?#21517;应为router2。同时在Router2中应建立一个用户,以对端路由器主机名作为用户名,?#20174;没?#21517;应为router1。所建的这?#25509;没?#30340;password必须相同。

clip_image001
设置如下:

Router1:

hostname router1

username router2 password xxx

interface Serial0

ip address 192.200.10.1 255.255.255.0

clockrate 1000000

ppp authentication chap

!

Router2:

hostname router2

username router1 password xxx

interface Serial0

ip address 192.200.10.2 255.255.255.0

ppp authentication chap

X25 详解

No Comments 网络技术 ,

1.        X25技术

X.25规范对应OSI三层,X.25的第三层描述了分组的格式及分组交换的过程。X.25的第二层由LAPB(Link Access Procedure, Balanced)实现,它定义了用于DTE/DCE连接的帧格式。X.25的第一层定义了电气和物理端口特性。

X.25网络设备分为数据终端设备(DTE)、数据电路终端设备(DCE)及分组交换设备(PSE)。DTE是X.25的末端系?#24120;?#22914;终端、计算机或网络主机,一般位于用户端,Cisco路由器就是DTE设备。DCE设备是专用通信设备,如调制解调器和分组交换机。PSE是公共网络的主干交换机。

X.25定义了数据通讯的电话网络,每个分配给用户的x.25 端口都具有一个x.121地址,当用户申请到的是SVC(交换虚电路)?#20445;瑇.25一端的用户在访问另一端的用户?#20445;?#39318;先将呼叫对方x.121地址,然后接收到呼叫的一端可以接受或拒绝,如果接受请求,于是连接建立实现数据传输,当没有数据传输时挂断连接,整个呼叫过程就类似我们拨打普通电话一样,其不同的是x.25可以实现一点对多点的连接。其中x.121地址、htc均必须与x.25服务提供商分配的?#38382;?#30456;同。X.25 PVC(永久虚电路),没有呼叫的过程,类似DDN专线。

2.        有关命令:

任务

命令

设置X.25封装

encapsulation x25 [dce]

设置X.121地址

x25 address x.121-address

设置远方站点的地址?#25104;?/p>

x25 map protocol address [protocol2 address2[…[protocol9 address9]]] x121-address [option]

设置最大的双向虚电路数

x25 htc citcuit-number1

设置一次连接可同时建立的虚电路数

x25 nvc count2

设置x25在清除?#38556;?#34394;电路前的等待周期

x25 idle minutes

重新启动x25,或清一个svc,启动一个pvc相关?#38382;?/p>

clear x25 {serial number | cmns-interface mac-address} [vc-number] 3

清x25虚电路

clear x25-vc

显示接口及x25相关信息

show interfaces serial

show x25 interface

show x25 map

show x25 vc

注:1、虚电路号从1到4095,Cisco路由器默认为1024,国内一般分配为16。

   2、虚电路计数从1到8,缺省为1。

   3、在改变了x.25各层的相关?#38382;?#21518;,应重新启动x25(使用clear x25 {serial number | cmns-interface mac-address} [vc-number]或clear x25-vc命令),否则新设置的?#38382;?#21487;能不能生效。同时应对照服务提供商对于x.25交换机端口的设置来配置路由器的相关?#38382;?#33509;出现?#38382;?#19981;匹配则可能会导致连接失败或其它意外情况。

3.        实例:

3.1. 在以下实例中每二个路由器间均通过svc实现连接。

clip_image001

路由器设置如下:

Router1:

interface Serial0

    encapsulation x25

    ip address 192.200.10.1 255.255.255.0

    x25 address 110101

    x25 htc 16

    x25 nvc 2

    x25 map ip 192.200.10.2 110102 broadcast

    x25 map ip 192.200.10.3 110103 broadcast

!

Router2:

interface Serial0

    encapsulation x25

    ip address 192.200.10.2 255.255.255.0

    x25 address 110102

    x25 htc 16

    x25 nvc 2

    x25 map ip 192.200.10.1 110101 broadcast

    x25 map ip 192.200.10.3 110103 broadcast

!

Router:

interface Serial0

    encapsulation x25

    ip address 192.200.10.3 255.255.255.0

    x25 address 110103

    x25 htc 16

    x25 nvc 2

    x25 map ip 192.200.10.1 110101 broadcast

    x25 map ip 192.200.10.2 110102 broadcast

!

相关调试命令

clear x25-vc

show interfaces serial

show x25 map

show x25 route

show x25 vc

3.2. 在以下实例中路由器router1和router2均通过svc与router连接,但router1和router2不通过svc直接连接,此三个路由器的串口运行RIP路由协议,使用了子接口的概念。由于使用子接口,router1和router2均学习到了访问对方局域网的路径,若不使用子接口,router1和router2将学不到到对方局域网的路由。

子接口(Subinterface)是一个物理接口上的多个虚接口,可以用于在同一个物理接口上连接多个网。我们知道为了避免路由循环,路由器支持split horizon法则,它只允许路由更新被分配到路由器的其它接口,而不会再分配路由更新回到此路由被接收的接口。

无论如何,在广域网环境使用基于连接的接口(象 X.25和Frame Relay),同一接口通过虚电路(vc)连接多台远端路由器?#20445;?#20174;同一接口来的路由更新信息不可以再被发回到相同的接口,除非强制使用分开的物理接口连接不同的路由器。Cisco提供子接口(subinterface)作为分开的接口对待。你可以将路由器逻辑地连接到相同物理接口的不同子接口, 这样来自不同子接口的路由更新就可以被分配到其他子接口,同时?#33268;?#36275;split horizon法则。

clip_image002

Router1:

interface Serial0

encapsulation x25

ip address 192.200.10.1 255.255.255.0

x25 address 110101

x25 htc 16

x25 nvc 2

x25 map ip 192.200.10.3 110103 broadcast

!

router rip

network 192.200.10.0

!

Router2:

interface Serial0

encapsulation x25

ip address 192.200.11.2 255.255.255.0

x25 address 110102

x25 htc 16

x25 nvc 2

x25 map ip 192.200.11.3 110103 broadcast

!

router rip

network 192.200.11.0

!

Router:

interface Serial0

encapsulation x25

x25 address 110103

x25 htc 16

x25 nvc 2

!

interface Serial0.1 point-to-point

ip address 192.200.10.3 255.255.255.0

x25 map ip 192.200.10.1 110101 broadcast

!

interface Serial0.2 point-to-point

ip address 192.200.11.3 255.255.255.0

x25 map ip 192.200.11.2 110102 broadcast

!

router rip

network 192.200.10.0

network 192.200.11.0

!

PSTN 详解 2

No Comments 网络技术 ,

异步拨号备份DDN专线:

clip_image001
此例主连接采用DDN专线,备份线路为电?#23433;?#21495;。当DDN专线连接正常?#20445;?#20027;端口S0状态为up,line protocol亦为up,则备份线路状态为standby,line protocol为down,此时所有通信均通过主接口进?#23567;?#24403;主接口连接发生故障?#20445;?#31471;口状态为down,则激活备份接口,完成数据通信。此方法不适合为X.25做备份。因为,配置封装为X.25的接口只要和X.25交换机之间的连接正常其接口及line protocol的状态亦为 up,它并不考虑其它地?#21483;?#19982;之通信的路由器的状态如何,所以若本地路由器状态正常,而对方路由器连接即使发生故障,本地也不会激活备份线路。例4将会描述如何为X.25做拨号备份。

以下是相关命令:

任务

命令

指定主线路改变后,次线路状态发生改变的?#26144;?#26102;间

backup delay {enable-delay | never} {disable-delay | never}

指定一个接口作为备份接口

backup interface type number

hostname c2522rb

!

enable secret 5 $1$J5vn$ceYDe2FwPhrZi6qsIIz6g0

enable password cisco

!

username c4700 password 0 cisco

ip subnet-zero

chat-script cisco-default "" "AT" TIMEOUT 30 OK "ATDT \T" TIMEOUT 30 CONNECT \c

chat-script reset atz

!

interface Ethernet0

ip address 16.122.51.254 255.255.255.0

no ip mroute-cache

!

interface Serial0

backup delay 10 10

backup interface Serial2

ip address 16.250.123.18 255.255.255.252

no ip mroute-cache

no fair-queue

!

interface Serial1

no ip address

no ip mroute-cache

shutdown

!

interface Serial2

physical-layer async

ip address 16.249.123.18 255.255.255.252

encapsulation ppp

async mode dedicated

dialer in-band

dialer idle-timeout 60

dialer map ip 16.249.123.17 name c4700 6825179

dialer-group 1

ppp authentication chap

!

interface Serial3

no ip address

shutdown

no cdp enable

!

interface Serial4

no ip address

shutdown

no cdp enable

!

interface Serial5

no ip address

no ip mroute-cache

shutdown

!

interface Serial6

no ip address

no ip mroute-cache

shutdown

!

interface Serial7

no ip address

no ip mroute-cache

shutdown

!

interface Serial8

no ip address

no ip mroute-cache

shutdown

!

interface Serial9

no ip address

no ip mroute-cache

shutdown

!

interface BRI0

no ip address

no ip mroute-cache

shutdown

!

router eigrp 200

network 16.0.0.0

!

ip classless

!

dialer-list 1 protocol ip permit

!

line con 0

line 2

script dialer cisco-default

script reset reset

modem InOut

modem autoconfigure discovery

rxspeed 38400

txspeed 38400

flowcontrol hardware

line aux 0

line vty 0 4

password cisco

login

!

end

c2522rb#

4.       异步拨号备份X.25:

clip_image002
设置X.25的拨号备份,首先X.25连接的端口必须运行动态路由协议,异步拨号口必须使用静态路由.本例选择EIGRP作为路由选择协议,将静态路由的Metric的值设置为200,由于EIGRP的默认Metric为90,所以当同时有两条路径通往同一网?#38382;?其中Metric值小的路径生效,而当X.25连接出现问题时,路由器无法通过路由协议学习到路由表,则此时静态路由生效,访问通过拨号端口实现。当X.25连接?#25351;?#27491;常?#20445;?#36335;由器又可以学习到路由表,则由于 Metric?#26723;?#19981;同,静态路由自动被动态路由所代替,这样就实现了备份的功能。

路由器Router1配置如下:

hostname router1

!

enable secret 5 $1$UTvD$99YiY2XsRMxHudcYeHn.Y.

enable password cisco

!

username router2 password cisco

ip subnet-zero

chat-script cisco-default "" "AT" TIMEOUT 30 OK "ATDT \T" TIMEOUT 30 CONNECT \c

chat-script reset atz

interface Ethernet0

ip address 202.96.38.100 255.255.255.0

!

interface Serial0

ip address 202.96.0.1 255.255.255.0

encapsulation x25

x25 address 10112227

x25 htc 16

x25 map ip 202.96.0.2 10112225 broadcast

!

interface Serial1

no ip address

shutdown

!

!

interface Async 1

ip address 202.96.1.1 255.255.255.252

encapsulation ppp

dialer in-band

dialer idle-timeout 60

dialer map ip 202.96.1.2 name router2 modem-script cisco-default 2113470

dialer-group 1

ppp authentication chap

!

router eigrp 200

redistribute connected

network 202.96.0.0

!

ip route 202.96.37.0 255.255.255.0 202.96.1.2 200

dialer-list 1 protocol ip permit

line con 0

line aux 0

script dialer cisco-default

script reset reset

modem InOut

modem autoconfigure discovery

transport input all

rxspeed 38400

txspeed 38400

flowcontrol hardware

line vty 0 4

password cisco

login

!

end

路由器Router2配置如下:

hostname router2

!

enable secret 5 $1$T4IU$2cIqak8f/E4Ug6dLT0k.J0

enable password cisco

!

username router1 password cisco

ip subnet-zero

chat-script cisco-default "" "AT" TIMEOUT 30 OK "ATDT \T" TIMEOUT 30 CONNECT \c

chat-script reset atz

!

interface Ethernet0

ip address 202.96.37.100 255.255.255.0

!

interface Serial0

ip address 202.96.0.2 255.255.255.0

no ip mroute-cache

encapsulation x25

x25 address 10112225

x25 htc 16

x25 map ip 202.96.0.1 10112227 broadcast

!

interface Serial1

no ip address

shutdown

!

interface Async1

ip address 202.96.1.2 255.255.255.252

encapsulation ppp

keepalive 30

async default routing

async mode dedicated

dialer in-band

dialer idle-timeout 60

dialer wait-for-carrier-time 120

dialer map ip 202.96.1.1 name router1 modem-script cisco-default 2113469

dialer-group 1

ppp authentication chap

!

router eigrp 200

redistribute static

network 202.96.0.0

!

no ip classless

ip route 202.96.38.0 255.255.255.0 202.96.1.1 200

dialer-list 1 protocol ip permit

!

line con 0

exec-timeout 0 0

line aux 0

script reset reset

modem InOut

modem autoconfigure discovery

transport input all

rxspeed 38400

txspeed 38400

flowcontrol hardware

line vty 0 4

password cisco

login

!

end

PSTN 详解 1

No Comments 网络技术 ,

PSTN

电话网络(PSTN)是目前普及程度最高、成本最低的公用通讯网络,它在网络互连中也有广泛的应用。电话网络的应用一般可分为两种类型,一种是同等级别机构之间以按需拨号(DDR)的方式实现互连,一种是ISP为拨号上网为用户提供的远程访问服务的功能。

1.     远程访问

clip_image001

1.1.Access Server基本设置:

选用Cisco2511作为访问服务器,采用IP地址池动态分配地址.远程工作站使用WIN95拨号网络实现连接。

全局设置:

任务

命令

设置用户名和密码

username username password password

设置用户的IP地址池

ip local pool {default | pool-name low-ip-address [high-ip-address]}

指定地址池的工作方式

ip address-pool [dhcp-proxy-client | local]

基本接口设置命令:

任务

命令

设置封装?#38382;?#20026;PPP

encapsulation ppp

启动异步口的路由功能

async default routing

设置异步口的PPP工作方式

async mode {dedicated | interactive}

设置用户的IP地址

peer default ip address {ip-address | dhcp | pool [pool-name]}

设置IP地址与Ethernet0相同

ip unnumbered ethernet0

line拨号线设置:

任务

命令

设置modem的工作方式

modem {inout|dialin}

自动配置modem类型

modem autoconfig discovery

设置拨号线的通?#31471;?#29575;

speed speed

设置通讯线路的流控方式

flowcontrol {none | software [lock] [in | out] | hardware [in | out]}

连通后自动执行命令

autocommand command

访问服务器设置如下:

Router:

hostname Router

enable secret 5 $1$EFqU$tYLJLrynNUKzE4bx6fmH//

!

interface Ethernet0

ip address 10.111.4.20 255.255.255.0

!

interface Async1

ip unnumbered Ethernet0

encapsulation ppp

keepalive 10

async mode interactive

peer default ip address pool Cisco2511-Group-142

!

ip local pool Cisco2511-Group-142 10.111.4.21 10.111.4.36

!

line con 0

exec-timeout 0 0

password cisco

!

line 1 16

modem InOut

modem autoconfigure discovery

flowcontrol hardware

!

line aux 0

transport input all

line vty 0 4

password cisco

!

end

相关调试命令

show interface

show line

1.2.       Access Server通过Tacacs服务器实现安全?#29616;ぃ?/p>

使用一台WINDOWS NT服务器作为Tacacs服务器,地址为10.111.4.2,运行Cisco2511随机带的Easy ACS 1.0软件实现用户?#29616;?#21151;能.

相关设置:

任务

命令

激活AAA访问控制

aaa new-model

用户登录时默认起用Tacacs+做AAA?#29616;?/p>

aaa authentication login default tacacs+

列表名为no_tacacs使用ENABLE口令做?#29616;?/p>

aaa authentication login no_tacacs enable

在运行PPP的串行线上采用Tacacs+做?#29616;?/p>

aaa authentication ppp default tacacs+

由TACACS+服务器授权运行EXEC

aaa authorization exec tacacs+

由TACACS+服务器授权与网络相关的服务请求。

aaa authorization network tacacs+

为EXEC会话运行记帐.进程开始和结束时发通告给TACACS+服务器。

aaa accounting exec start-stop tacacs+

为与网络相关的服务需求运行记帐包括SLIP,PPP,PPP NCPs,ARAP等.在进程开始和结束时发通告给TACACS+服务器。

aaa accounting network start-stop tacacs+

指定Tacacs服务器地址

tacacs-server host 10.111.4.2

在Tacacs+服务器和访问服务器设定共享的关键字,访问服务器和Tacacs+服务器使用这个关键字去?#29992;?#21475;令和响应信息。这里使用tac作为关键?#24103;?/p>

tacacs-server key tac

访问服务器设置如下:

hostname router

!

aaa new-model

aaa authentication login default tacacs+

aaa authentication login no_tacacs enable

aaa authentication ppp default tacacs+

aaa authorization exec tacacs+

aaa authorization network tacacs+

aaa accounting exec start-stop tacacs+

aaa accounting network start-stop tacacs+

enable secret 5 $1$kN4g$CvS4d2.rJzWntCnn/0hvE0

!

interface Ethernet0

ip address 10.111.4.20 255.255.255.0

!

interface Serial0

no ip address

shutdown

interface Serial1

no ip address

shutdown

!

interface Group-Async1

ip unnumbered Ethernet0

encapsulation ppp

async mode interactive

peer default ip address pool Cisco2511-Group-142

no cdp enable

group-range 1 16

!

ip local pool Cisco2511-Group-142 10.111.4.21 10.111.4.36

tacacs-server host 10.111.4.2

tacacs-server key tac

!

line con 0

exec-timeout 0 0

password cisco

login authentication no_tacacs

line 1 16

login authentication tacacs

modem InOut

modem autoconfigure type usr_courier

autocommand ppp

transport input all

stopbits 1

rxspeed 115200

txspeed 115200

flowcontrol hardware

line aux 0

transport input all

line vty 0 4

password cisco

!

end

2.      DDR(dial-on-demand routing)实例

clip_image002
此例通过Cisco 2500系列路由器的aux端口实现异步拨号DDR连接。Router1拨号连接到Router2。其中采用PPP/CHAP做安全?#29616;ぃ?#22312;Router1中应建立一个用户,以对端路由器主机名作为用户名,?#20174;没?#21517;应为Router2。同时在Router2中应建立一个用户,以对端路由器主机名作为用户名,?#20174;没?#21517;应为Router1。所建的这?#25509;没?#30340;password必须相同。

相关命令如下:

任务

命令

设置路由器与modem的接口指令

chat-script script-name EXPECT SEND EXPECT SEND (etc.)

设置端口在挂断前的等待时间

dialer idle-timeout seconds

设置协议地址与电话号码的?#25104;?/p>

dialer map protocol next-hop-address [name hostname] [broadcast] [modem-script

modem-regexp] [system-script system-regexp] [dial-string]

设置电话号码

dialer string dial-string

指定在特定线路下路由器默认 使用的chat-script

script {dialer|reset} script-name

Router1:

hostname Router1

!

enable secret 5 $1$QKI7$wXjpFqC74vDAyKBUMallw/

!

username Router2 password cisco

chat-script cisco-default "" "AT" TIMEOUT 30 OK "ATDT \T" TIMEOUT 30 CONNECT \c

!

interface Ethernet0

ip address 10.0.0.1 255.255.255.0

!

interface Async1

ip address 192.200.10.1 255.255.255.0

encapsulation ppp

async default routing

async mode dedicated

dialer in-band

dialer idle-timeout 60

dialer map ip 192.200.10.2 name Router2 modem-script cisco-default 573

dialer-group 1

ppp authentication chap

!

ip route 10.0.1.0 255.255.255.0 192.200.10.2

dialer-list 1 protocol ip permit  

!

line con 0

line aux 0

modem InOut

modem autoconfigure discovery

flowcontrol hardware                                                                          

Router2:

hostname Router2

!

enable secret 5 $1$F6EV$5U8puzNt2/o9g.t56PXHo.

!

username Router1 password cisco

!

interface Ethernet0

ip address 10.0.1.1 255.255.255.0

!

interface Async1

ip address 192.200.10.2 255.255.255.0

encapsulation ppp

async default routing

async mode dedicated

dialer in-band

dialer idle-timeout 60

dialer map ip 192.200.10.1 name Router1

dialer-group 1

ppp authentication chap

!

ip route 10.0.0.0 255.255.255.0 192.200.10.1

dialer-list 1 protocol ip permit

!

line con 0

line aux 0

modem InOut

modem autoconfigure discovery

flowcontrol hardware

!

相关调试命令

debug dialer

debug ppp authentication

debug ppp error

debug ppp negotiation

debug ppp packet

show dialer   

综合数字业务网(ISDN)详解

No Comments 网络技术 ,

 

综合数字业务网(ISDN)由数字电话和数据传输服务两部分组成,一般由电话局提供这种服务。ISDN的基本速率接口(BRI)服务提供2个B信道和1个D信道(2B+D)。BRI的B信道速率为64Kbps,用于传输用户数据。D信道的速率为16Kbps,主要传输控制信号。在北美和日本,ISDN的主速率接口(PRI)提供23个B信道和1个D信道,总速率可达1.544Mbps,其中D信道速率为64Kbps。而在?#20998;蕖?#28595;大利亚等国家,ISDN的PRI提供30个B信道和1个64Kbps D信道,总速率可达2.048Mbps。我国电话局所提供ISDN PRI为30B+D。

2.        基本命令

任务

命令

设置ISDN交换类型

isdn switch-type switch-type1

接口设置

interface bri 0

设置PPP封装

encapsulation ppp

设置协议地址与电话号码的?#25104;?/p>

dialer map protocol next-hop-address [name hostname] [broadcast] [dial-string]

启动PPP多连接

ppp multilink

设置启动另一个B通道?#20320;?#20540;

dialer load-threshold load

显示ISDN有关信息

show isdn {active | history | memory | services | status [dsl | interface-type number] | timers}

注:1.交换机类型如下表,国内交换机一般为basic-net3。

按区域分关键字

交换机类型

Australia

basic-ts013

Australian TS013 switches

Europe

basic-1tr6

German 1TR6 ISDN switches

basic-nwnet3

Norway NET3 switches (phase 1)

basic-net3

NET3 ISDN switches (UK, Denmark, and other nations); covers the Euro-ISDN E-DSS1 signalling system

primary-net5

NET5 switches (UK and Europe)

vn2

French VN2 ISDN switches

vn3

French VN3 ISDN switches

Japan

ntt

Japanese NTT ISDN switches

primary-ntt

Japanese ISDN PRI switches

North America

basic-5ess

AT&T basic rate switches

basic-dms100

NT DMS-100 basic rate switches

basic-ni1

National ISDN-1 switches

primary-4ess

AT&T 4ESS switch type for the U.S. (ISDN PRI only)

primary-5ess

AT&T 5ESS switch type for the U.S. (ISDN PRI only)

primary-dms100

NT DMS-100 switch type for the U.S. (ISDN PRI only)

New Zealand

basic-nznet3

New Zealand Net3 switches

3.        ISDN实现DDR(dial-on-demand routing)实例:

clip_image001
设置如下:

Router1:

hostname router1

user router2 password cisco

!

isdn switch-type basic-net3

!

interface bri 0

ip address 192.200.10.1 255.255.255.0

encapsulation ppp

dialer map ip 192.200.10.2 name router2 572

dialer load-threshold 80

ppp multilink

dialer-group 1

ppp authentication chap

dialer-list 1 protocol ip permit

!

Router2:

hostname router2

user router1 password cisco

!

isdn switch-type basic-net3

!

interface bri 0

ip address 192.200.10.2 255.255.255.0

encapsulation ppp

dialer map ip 192.200.10.1 name router1 571

dialer load-threshold 80

ppp multilink

dialer-group 1

ppp authentication chap

dialer-list 1 protocol ip permit

!

Cisco路由器同时支持回拨功能,我们将路由器Router1作为Callback Server,Router2作为Callback Client。

与回拨相关命令:

任务

命令

?#25104;?#21327;议地址和电话号码,并在接口上使用在全局模式下定义的PPP回拨的?#25104;?#31867;别。

dialer map protocol address name hostname class classname dial-string

设置接口支持PPP回拨

ppp callback accept

在全局模式下为PPP回拨设置?#25104;?#31867;别

map-class dialer classname

通过查找注册在dialer map里的主机名来决定回拨.

dialer callback-server [username]

设置接口要求PPP回拨

ppp callback request

设置如下:

Router1:

hostname router1

user router2 password cisco

!

isdn switch-type basic-net3

!

interface bri 0

ip address 192.200.10.1 255.255.255.0

encapsulation ppp

dialer map ip 192.200.10.2 name router2 class s3 572

dialer load-threshold 80

ppp callback accept

ppp multilink

dialer-group 1

ppp authentication chap

map-class dialer s3

dialer callback-server username

dialer-list 1 protocol ip permit

!

Router2:

hostname router2

user router1 password cisco

!

isdn switch-type basic-net3

!

interface bri 0

ip address 192.200.10.2 255.255.255.0

encapsulation ppp

dialer map ip 192.200.10.1 name router1 571

dialer load-threshold 80

ppp callback request

ppp multilink

dialer-group 1

ppp authentication chap

dialer-list 1 protocol ip permit

!

相关调试命令

debug dialer

debug isdn event

debug isdn q921

debug isdn q931

debug ppp authentication

debug ppp error

debug ppp negotiation

debug ppp packet

show dialer

show isdn status

举例:执行debug dialer命令观察router2呼叫router1,router1回拨router2的过程.

router1#debug dialer

router2#ping 192.200.10.1

router1#

00:03:50: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

00:03:50: BRI0:1:PPP callback Callback server starting to router2 572

00:03:50: BRI0:1: disconnecting call

00:03:50: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down

00:03:50: BRI0:1: disconnecting call

00:03:50: BRI0:1: disconnecting call

00:03:51: %LINK-3-UPDOWN: Interface BRI0:2, changed state to up

00:03:52: callback to router2 already started

00:03:52: BRI0:2: disconnecting call

00:03:52: %LINK-3-UPDOWN: Interface BRI0:2, changed state to down

00:03:52: BRI0:2: disconnecting call

00:03:52: BRI0:2: disconnecting call

00:04:05: : Callback timer expired

00:04:05: BRI0:beginning callback to router2 572

00:04:05: BRI0: Attempting to dial 572

00:04:05: Freeing callback to router2 572

00:04:05: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

00:04:05: BRI0:1: No callback negotiated

00:04:05: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up

00:04:05: dialer Protocol up for Vi1

00:04:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed state

to up

00:04:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, chang

ed state to up

00:04:11: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 572

#router1

4.      ISDN访问首都在线263网实例:

clip_image002
本地局部网地址为10.0.0.0/24,属于保留地址,通过NAT地址翻译功能,局域网用户可以通过ISDN上263网访问Internet。263的ISDN电话号码为2633,用户为263,口令为263,所涉及的命令如下表:

任务

命令

指定接口通过PPP/IPCP地址协商获得IP地址

ip address negotiated

指定内部和外部端口

ip nat {inside | outside}

使用ppp/pap作?#29616;?/p>

ppp authentication pap callin

指定接口属于拨号组1

dialer-group 1

定义拨号组1允许所有IP协议

dialer-list 1 protocol ip permit

设定拨号,号码为2633

dialer string 2633

设定登录263的用户名和口令

ppp pap sent-username 263 password 263

设定默认路由

ip route 0.0.0.0 0.0.0.0 bri 0

设定符合访问列表2的所有源地址?#29615;?#35793;为bri 0所拥有的地址

ip nat inside source list 2 interface bri 0 overload

设定访问列表2,允许所?#34892;?#35758;

access-list 2 permit any

具体配置如下:

hostname Cisco2503

!

isdn switch-type basic-net3

!

ip subnet-zero

no ip domain-lookup

ip routing

!

interface Ethernet 0

ip address 10.0.0.1 255.255.255.0

ip nat inside

no shutdown

!

interface Serial 0

shutdown

no description

no ip address

!

interface Serial 1

shutdown

no description

no ip address

!

interface bri 0

ip address negotiated

ip nat outside

encapsulation ppp

ppp authentication pap callin

ppp multilink

dialer-group 1

dialer hold-queue 10

dialer string 2633

dialer idle-timeout 120

ppp pap sent-username 263 password 263

no cdp enable

no ip split-horizon

no shutdown

!

ip classless

!

! Static Routes

!

ip route 0.0.0.0 0.0.0.0 bri 0

!

! Access Control List 2

!

access-list 2 permit any

!

dialer-list 1 protocol ip permit

!

! Dynamic NAT

!

ip nat inside source list 2 interface bri 0 overload

snmp-server community public ro

!

line console 0

exec-timeout 0 0

!

line vty 0 4

!

end

5.        Cisco765M通过ISDN拨号上263

由于Cisco765的设置命令与我们常用的Cisco路由器的命令不同,所以以下列举?#36865;?#36807;Cisco765上263访问Internet的具体命令行设置步骤。

>set system c765

c765> set multidestination on

c765> set switch net3

c765> set ppp multilink on

c765> cd lan

c765:LAN> set ip routing on

c765:LAN> set ip address 10.0.0.1

c765:LAN> set ip netmask 255.0.0.0

c765:LAN> set briding off

c765:LAN>cd

c765> set user remotenet

New user remotenet being created

c765:remotenet> set ip routing on

c765:remotenet> set bridging off

c765:remotenet> set ip framing none

c765:remotenet> set ppp clientname 263

c765:remotenet> set ppp password client

Enter new Password: 263

Re-Type new Password: 263

c765:remotenet> set ppp authentication out none

c765:remotenet> set ip address 0.0.0.0

c765:remotenet> set ip netmask 0.0.0.0

c765:remotenet> set ppp address negotiation local on

c765:remotenet> set ip pat on

c765:remotenet> set ip route destination 0.0.0.0/0 gateway 0.0.0.0

c765:remotenet> set number 2633

c765:remotenet> set active

命令描述如下:

任务

命令

设置路由器系统名称

set system c765

允许路由器呼叫多个目的地

set multidestination on

设置ISDN交换机类型为NET3

set switch net3

允许点到点间多条通道连接实现负载均衡

set ppp multilink on

关掉桥接

set briding off

建立用户预制文件用于设置拨号连接?#38382;? 可以设置多个用户预制文件用于相同的物理端口对应于不同的连接。

set user remotenet

使用PPP/IPCP

set ip framing none

设置上网用户帐号

set ppp clientname 263

设置上网口令

set ppp password client

Enter new Password: 263

Re-Type new Password: 263

不用PPP/CHAP或PAP做?#29616;?/p>

set ppp authentication out none

允许地址磋商

set ppp address negotiation local on

设置地址翻译

set ip pat on

设置默认路由

set ip route destination 0.0.0.0/0 gateway 0.0.0.0

设置ISP的电话号码

set number 2633

激活用户预制文件

set active

Display interface的显示信息详解

Display interface的显示信息详解Display interface的显示信息
本次工作希望统一Ethernet接口的信息,建议如下:
[1] GigabitEthernet3/0/1 current state : DOWN
[2] IP Sending Frames’ Format is PKTFMT_ETHNT_2, Hardware address is 00e0-fc00-0010
[3] The Maximum Transmit Unit is 1500
[4] Media type is not sure, loopback not set
[5] Port hardware type is No Connector
[6] Unknown-speed mode, unknown-duplex mode
[7] Link speed type is autonegotiation, link duplex type is autonegotiation
[8] Flow-control is not supported
[9] The Maximum Frame Length is 1536
[10] Broadcast MAX-ratio: 100%
[11] Allow jumbo frame to pass
[12] PVID: 1
[13] Port link-type: access
[14]    Tagged VLAN ID : none
[15]    Untagged VLAN ID : 504
[16] Last 5 minutes input rate 229 bytes/sec, 2 packets/sec
Last 5 minutes output rate 25 bytes/sec, 0 packets/sec
[17] Input(total):   34764 packets, 14212713 bytes
1021 broadcasts, 0 multicasts, 0 pauses
[18] Input(normal):   34764 packets, 14212713 bytes
1021 broadcasts, 0 multicasts, 0 pauses
[19] Input(error): 0 input errors, 0 runts, 0 giants,   0 throttles, 0 CRC, 0 frame,   0 overruns,
0 aborts, 0 ignored, 0 parity errors
[20] Output(total):   1630514 packets, 525467915 bytes                                 
774493 broadcasts, 822714 multicasts, 0 pauses
[21] Output(normal):   1630514 packets, 525467915 bytes                                 
774493 broadcasts, 822714 multicasts, 0 pauses
[22] Output(error):   0 output errors,   0 underruns, 0 buffer failures, 0 aborts,
0 deferred, 0 collisions, 0 late collisions, 0 lost carrier, 0 no carrier

注意?#21644;?#35745;项中不支持的项目填写:-
即:如果产品对deferred,collisions, late collisions, lost carrier, no carrie不支持
显示结果如下:
Output:   0 output errors,   0 underruns, 0 buffer failures, 0 aborts,
– deferred, – collisions, – late collisions, – lost carrier, – no carrier

[1] 接口状态 显?#23621;布?#38142;路的状态
[2] 接口的输出帧封装类型和MAC地址 显示接口的?#22659;?#24103;封装类型和MAC地址
[3] 接口的最大传输单元 显示接口的最大传输单元
[4] 端口的连接线类型和环回状态 显示接口的连接线类型和环回状态
[5] 端口的连接器?#24067;?#31867;型 显示接口的连接器?#24067;?#31867;型
[6] 端口的实际速度和双工状态 显示端口的实际速度和双工状态
[7] 端口是否是速度、双工的自协商配置 显示端口速度、双工的自协商配置
[8] 端口流控状态 显示端口的MDI类型(不是缺省?#26723;那?#20917;显示)
[9] 端口可以正常转发的帧长度 显示端口可以正常转发的帧长度
[10] 端口的广播抑制比 显示端口的广播抑制比
[11] 端口是否允许jumbo帧通过 显示端口是否允许jumbo帧通过
[12] 端口的PVID 显示端口的PVID
[13] 端口的链路类型 显示端口的链路类型(access,trunk,hybrid)
[14] 端口所属的tag的VLAN的列表 显示端口所属的tag的VLAN的列表
[15] 端口所属的untag的VLAN的列表 显示端口所属的untag的VLAN的列表
[16] 接口最近五分钟输出和输入速率和报文数 实现最近五分钟输出和输入速率和报文数
[17] 接口的物理层输入总?#20302;?#35745; 显示物理层输出的报文数/字节数/广播和多播/PAUSE帧
总的统计值只包括正常、异常包和PAUSE帧
[18] 接口的物理层输入中正常帧的统计 显示物理层输出的报文数/字节数/广播和多播/PAUSE帧
正常帧的统计值包括正常数据帧和正常PAUSE帧
[19] 接口的物理层输入错误统计 输入错误数,input errors等于各种重要错误信息的总和。不同的产品可以根据具体情况增加其它?#38382;?#25110;减少不能实现的?#38382;?
(1) Runts: discarded packets that are smaller than the medium’s minimum packet size.
( Receive Byte Count < 64 and NOT CRC Error 
or   Receive Byte Count < 64 and Tag Packet and NOT CRC Error,
无论是否有vlan tag,数据段小于64字节,而且没有CRC校验错误的帧。)
(2) Giants: discarded packets that are larger than the medium’s maximum packet size.
( Receive Byte Count > 1518 and NOT CRC Error 
or   Receive Byte Count > 1522 and Tag Packet and NOT CRC Error,
没有vlan tag,数据段大于1518字节,小于最大帧长度,而且没有CRC校验错误的帧,和有vlan tag,数据段大于1522字节,小于最大帧长度,而且没有CRC校验错误的帧。)

(3) Throttles: discarded packets that are incomplete frames.
( 交换机察觉缓存或CPU过载,关闭接口接收器?#37027;?#24418;称为 throttle,是cisco路由器上的一个概念,我们的交换机目?#23433;?#20855;备这个功能,一般应该显示为不支持。)
(4) CRC: discarded packets with checksum error.
( Receive Packet CRC error,帧长度在正常?#27573;В?#19981;带tag,长度在64到1518之间,或带tag,长度在64到1522之间),而且CRC校验错,如果支持此项,则不支持奇偶校验错误项。)
(5) Frame: discarded packets with frame pad/sequence/alignment error, out of frame etc.
(   不是整数字节,而是多1~7bit,因此不对齐,或乱序或空帧,而且CRC校验错误,但是不计入CRC错误。)
(6) Overrun: the receiver hardware is unable to hand received data to a hardware buffer because the input rate exceeds the receiver’s ability to handle the data.
(   由于接口输入速率超过接受方处理能力,导致丢包,由于我们的交换机一般是线速转发,这项一般应该为0,只有部分交换机对上传CPU或三层线速转发的帧有接口带宽限制,或是通过ACL实现的带宽限制,因此被丢弃的帧,计入此项。)
(7) Aborts: Input abnormal frames that are discarded. 
( 除其他错误之外,产品认为有必要统计的错误,例如前导码异常的帧,计入此项。)
(8) Ignored: packets that are discarded because the interface hardware does not have enough internal buffers.
( Packet ignored,由于接口内部buffer满,丢弃的帧,与由于主系统缓存空间缺乏,导致的丢弃帧不同。线速转发的帧,在多接口满带宽输入,单接口输出等情况下,由于输出接口的带宽不足,数据帧将内部缓存占满,导致从接口输入的帧在进入内部缓存之前被丢弃,以及进入内部缓存的帧超时无法输出,计入此项,上传到CPU的帧,由于CPU处理能力限制,toCPU的缓存满,导致被丢弃,?#24067;?#20837;此项。)
(9) Parity: Frames with parity error.
( Receive Packet parity error,如果支持此项,则不支持 CRC 错误项。)

[20] 接口的物理层输出总?#20302;?#35745; 显示物理层输入的报文数/字节数/广播和多播/PAUSE帧
总的统计值只包括正常帧、异常帧和PAUSE帧。
Pauses: Flow control pauses including Xon and Xoff.
[21] 接口的物理层输出正常帧统计 显示物理层输入的报文数/字节数/广播和多播/PAUSE帧
总的统计值只包括正常数据帧和正常PAUSE帧。
[22] 接口的物理层输出错误统计 输入丢弃数/输入错误数,output errors等于各种重要错误信息的总和。不同的产品可以根据具体情况增加其它?#38382;?#25110;减少不能实现的?#38382;?
(1) Underruns: There are no data in the output queue.
( Transmit under run,与 Overrun相反,输出接口的缓存从输出队列中取以太网帧?#20445;?#27809;有帧,是一?#22336;?#24120;少见的?#24067;?#24322;常。有的交换机就没有单独的接口输出缓存,与接口输出队列是同一块缓存。)
(2) Buffer failures: Hardware does not have enough internal buffers. 
( 内部缓存满,如果输出队列满,输出的以太网帧将在内部缓存中暂时存储,由于内部缓存满,导致帧丢弃。由于交换机对线速转发的数据帧发生的这种异常,认为只是到达内部缓存而没有到达出接口,是个输入帧,因?#24605;?#20837; Input Ignored Error,只有从CPU发出的帧,由于内部缓存满,导致帧丢弃,计入此项。)
(3) Aborts: Output abnormal frames that are discarded.
( 在半双工模式下,由于冲突检测,?#26144;?#21457;送超过15次的帧,被丢弃,计入此项。除其他错误之外,产品认为有必要统计的错误,例如添加前导码异常的帧,?#24067;?#20837;此项)
(4) Deferred: The packets could not be sent out for collision under half-duplex mode.
( 半双工模式下,由于检测到载波正在被声明,当时没有发出的包,延时一次,计数加一。)
(5) Collisions: Statistic of collision detection under half-duplex mode.
( 半双工模式下,在以太网帧数据部分?#37027;?4字节进入线路前,由于检测到冲突,当时没有发出的包。)
(6) Late collisions: Statistic of collision with GE port sending packets less than 512 bytes and 10/100M port less than 64 bytes.
( 半双工模式下,在以太网帧数据部分?#37027;?4字节进入线路后,由于检测到冲突,当时没有发出的包。)
(7) Lost carrier: Statistic of losing the carrier.
(   载波丢失,一般适用于串行WAN接口,发送过程中,每丢失一个载波,?#24605;?#25968;加一,对于交换机,通常是由于线路中断造成。)
(8) No carrier: Statistic of no carrier.
(   无载波,一般适用于串行WAN接口,当试图发送帧?#20445;?#22914;果没有载波出现 ,?#24605;?#25968;加一,对于交换机,通常是由于线路中断造成。)

30选5玩法