30选5玩法|福彩30选5开奖结果321|

原创:使用cisco路由器拨号,nat内网共享上网

来源:本站原创 网络技术 超过1,815 views围观 0条评论

使用cisco路由器拨号,nat内网共享上网。

配置步骤:

分2大部分

第一部分:

1.创建一个acl , 可以是标准acl,?#37096;?#20197;是扩展acl。(抓上网用户的网段)

access-list 1 permit 192.168.0.0 0.0.255.255

或者

access-list 100 permit ip any any

2.配置nat(NAT映射)

ip nat inside source list 1 interface dialer1 overload

|

此接口,为拨号接口

不明白,可以接着往下看

3.将nat配置运用到接口(dialer拨号接口)

int dialer1 //拨号接口

ip nat outside //out出去方向

int e0/1 //局域网接口,需要做NAT出去的接口可以是多个.

ip nat inside //in进入的方向

第二部分PPPOE拨号的创建

1.开启VPDN(建立PPOE标识)

vpdn enable

vpdn-group pppoe_client

request-dialin

protocol pppoe

exit

exit

2.进入拨号接口的物理接口

int e0/0 //与mode相连的那个接口

no ip add //没有地址

no shut

pppoe enable //开启pppoe功能

pppoe-client dial-pool-number 1 //这里是个关键点,与虚拟拨号接口关联起来。请认真揣摩一下这句话。

注意这个pppoe-client 和上面的pppoe_client 是完全2个不同的东西,后者是命令,前者是个标识,是个名称。

3.最关键的部分了,配置虚拟拨号接口。

int dialer 1 //进入虚拟拨号接口

encapsulation ppp //封装协议ppp

ppp pap sent-username [email protected] password 13714240380 //pap 认证 账号[email protected] 密码13714240380,就是你的ADSL拨号账号和密码

本实验指的是电信是PAP认证,如果是CHAP认证,配置要稍微复杂点,你必须得去了解CHAP认证。

dialer pool 1 //注意,虚拟接口和上面的物理接口是关联起

ip mtu 1492 //MTU 知道吧。为什么不是1500?

ip nat outside //前面有提到

ip address negotiated //获取ip地址。使用电脑拨号,不也需要动态获取个IP

最后别忘了添加一条默认路由

ip route 0.0.0.0 0.0.0.0 dialer1

图:

image

实例:

2811#sh run

Building configuration…

Current configuration : 1306 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname 2811

!

boot-start-marker

boot-end-marker

!

enable password cisco

!

no aaa new-model

clock timezone GMT 8

!

!

ip cef

!

!

multilink bundle-name authenticated

vpdn enable

!

vpdn-group pppoe_client

request-dialin

l2tp tunnel receive-window 1024

!

!

!

!

username cisco privilege 15 password 0 cisco

archive

log config

hidekeys

!

!

!

!

!

interface FastEthernet0/0

no ip address

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

pppoe enable

pppoe-client dial-pool-number 1

!

interface FastEthernet0/1

ip address 192.168.1.254 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

ppp pap sent-username ad65039771 password 0 vGQifu7S

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 192.168.2.0 255.255.255.0 192.168.1.1

!

!

ip http server

ip nat inside source list 101 interface Dialer1 overload

!

access-list 101 permit ip any any

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

login local

line vty 5 15

login local

!

scheduler allocate 20000 1000

!

end

文章出自:CCIE那点事 http://www.rygqfb.tw/ 版权所?#23567;?#26412;站文章除注明出处外,皆为作者原创文章,可自由引用,但请注明来源。 禁止全文转载。
本文链接:http://www.rygqfb.tw/?p=3022转载请注明转自CCIE那点事
如果?#19981;叮?a title="CCIE那点事 | IT运维故障发现和解决基地 我致力于为企业IT管理提供助力!" href="http://www.rygqfb.tw/?feed=rss2" target="_blank">点此订阅本站
下篇文章:
  • 相关文章
  • 为您推荐
  • 各种观点
?
?
30选5玩法
荣耀配资 北京赛车pk10助赢软件 河南快三推荐 极速飞艇开奖直播app 下载四川熊猫麻将 贵州快三开奖结果快 福建快3一定牛 江苏e球彩有什么技巧 广西白银交易平台 贵州闲来麻将